1. Are you ready for the Galaxy S20? Here is everything we know so far!

Portable hotspot not working but USB tethering is?

Discussion in 'Android Devices' started by dyst0pia, Apr 26, 2012.

  1. dyst0pia

    dyst0pia Lurker
    Thread Starter

    On stock 4.0.4. For some reason, I can't seem to get an internet connection when using the portable hotspot. The machine will connect to the hotspot, but it won't be able to reach the internet. USB tethering works just fine, as does my machine's wireless connection to other networks. Any ideas?

  2. quantumrand

    quantumrand Android Expert

    Have you tried connecting using WPA (not WPA2) or Open network settings? Some network cards (or older Wifi drivers) do not support WPA2. Also, Windows XP pre SP3 also has trouble with WPA2.
  3. windstrings

    windstrings Well-Known Member

    I keep seeing this issue but not one seems to follow through on the fix.
    I had the same issue and after pulling my hair out with tech support I tried some things of my own that worked.

    I decided to see if foxfi would work "free no root version" when reading the material, they alluded that some Samsung devices were quirky.

    Per foxfi instructions when you go to download it.... some samsung
    phones have issues.. need to turn on wifi but don't allow to
    connect to anything..

    I then installed foxfi "free without root"... rebooted and was
    able to get instant hotspot when activated!...

    then I turn off foxfi and turned on the stock hotspot and now it works!
    So I"m thinking all is well but will it work without foxfi installed?

    I then uninstalled foxfi, rebooted and turned on hotspot "with
    wifi off" ,now my stock hotspot works instantly when turned on
    with internet access!

    This time I turned it the hotspot off again.. turned wifi back on
    and logged onto a network in my house "wireless".. once logged on
    I tried to activate hotspot again. This turns off my wifi in the
    act of activating hotspot, but the hotspot now works!

    I rebooted just to confirm one more time and still works!
  4. I tried this workaround as suggested by windstrings on my S2. As I can connect to network & connect my tablet & windows 7 PC no problem. However I can connect on my XP laptop SP3 laptop but can load/open webpages. Initally I tried with inbuilt wifi hot spot I'm running offical ICS 4.0.3 from my carrier in my stock unrooted phone. So then I tried work around suggested using foxfi free from the play store. Same issue my XP laptop connects to the network I tried with & without password eg security enabled network & open & again only on my XP laptop I can't open/load a webpage. It's great this workaround was posted & it works for you but anyone on the forums got I fix if this doesn't work?
  5. rangergreg281

    rangergreg281 Lurker

    Yeah I tried windstrings method and still have nothing. Trying to connect my panasonic toughbook cf-29 to my galaxy s3 hotspot. Laptop is running winxp. I have tried everything under the sun and cannot get it to connect. Laptop connected fine to my old HTC G2, but will only connect to my s3 via usb. Im ready to trash the phone at this point. Any help would be greatly appreciated.
  6. windstrings

    windstrings Well-Known Member

    Have you tried to see if a windows 7 machine will logon?
    Every since android updated dome while back I haven't needed foxfi, bin fact I uninstalled them when they started charging. I thought that was a dumb move when verizon went "free hotspot".
  7. Driffman

    Driffman Lurker

    I am having the same problem and I think I know why.

    It is my laptops built in wifi card that is the problem, its an Intel Pro/Wireless 2200BG.

    This card works perfectly with all other wifi hotspots except the S3

    I put in an old US.Robotics 802.11g Wireless Turbo PC Card and it connects to the S3 with no problems.

    So obviously I tried to update the driver for the Intel card but Intels automatic scan says the driver is up to date.

    I am still searching for a solution to the Intel card problem.......
  8. tpc7522

    tpc7522 Lurker

    I'm so glad I found this post. I have been having the same problem. My tablet will connect to my S3 but not an older notebook that I put Win 8 on. I have went round and round with that thing and no luck. Saw this post and disabled the onboard Intel Pro wireless 2200 network card and added a USB wireless N and instantly connected to my phone. So there is an issue with the S3 and the Intel Pro 2200. BTW the notebook connects to any other hotspot normally but couldn't with the phone. Thanks for the heads up.

Nexus S Forum

The Nexus S release date was December 2010. Features and Specs include a 4.0" inch screen, 5MP camera, 512GB RAM, Hummingbird processor, and 1500mAh battery.

December 2010
Release Date

Share This Page