1. Are you ready for the Galaxy S20? Here is everything we know so far!

Post Froyo VPN Issues

Discussion in 'Android Devices' started by Misbehavin', Aug 3, 2010.

  1. Misbehavin'

    Misbehavin' Well-Known Member
    Thread Starter

    Before the update, I could connect to our corporate VPN. There were issues with PPTP not passing traffic after a few minutes (this issue with PPTP was apparently a long standing issue with PPTP and Windows RRAS involving MPPE), but after some testing I found that L2TP was working just fine. All was well up until the Froyo update.

    Now I connect to the VPN, using PPTP or L2TP, and it does connect as before. However, that all it does. It appears that no data traffic is passed at all after the inital connection. I can monitor the server to see what's happening, and the bytes of data being passed never changes after the initial connection.

    Anyone else seeing this issue or have any ideas?

    Edit: I'm not above doing a hard reset, however as nothing else seems to be an issue and I have the phone the way I want it, I really don't want to do a hard reset without knowing that it should fix my problem. In other words, I don't really care to be shooting in the dark to fix the issue.

    Deleted User likes this.

    1. Download the Forums for Android™ app!


  2. jsp91470

    jsp91470 Lurker

    At least it's not just me. I'm seeing exactly the same issue after upgrading my EVO to Froyo. The L2TP VPN connects just fine, with no errors on the server end (I've been watching it) but no data is passed after that.
    Good to know it's not my VPN server's fault.
    Misbehavin' likes this.
  3. Misbehavin'

    Misbehavin' Well-Known Member
    Thread Starter

    Well I'm relieved to see someone else is seeing this too. I was beginning to think that my thread would fall off the first page without anyone noticing.

    Hopefully someone can shed some light on this soon. This kills my ability to remotely manage the LAN.
  4. Misbehavin'

    Misbehavin' Well-Known Member
    Thread Starter

    Jsp, can you try something on your end? When my Evo is using WiFi, I can establish a VPN connection. It just doesn't work over 3G. I've connected to WiFi at home and it works flawlessly. Can you verify you see the same results? If you have access to 4G currently, and can check it too, that would be nice to know as well.

    If you are seeing the same thing as me, this may help Sprint and HTC some, as I have some contacts I have investigating this issue.
  5. Deleted User

    Deleted User Guest

    Same happens here. I connect w/o issue. I open a browser and go to "whatismyip"...and its displaying the ip of the phones connection...not my vpn server's gateway as expected.

    If I can find a 4g connection - I'll give it a shot.
    Misbehavin' likes this.
  6. Just another person posting.

    No difference on Wifi.

    Ping shows packets filtered by a public IP if I ping 192.168.*, i.e. the route to use the vpn isn't applied correctly to the linux routing table - Should be a pretty easy fix.

    I guess I may just root my phone and be able to apply the route, have stayed away from rooting since I haven't needed it..

    This is a pretty major show stopper bug for anyone using a VPN though, if Sprint would push out an official beta a day early I'm sure more people would have helped test (myself included). If I had needed to critically use my phone's VPN I would have been very upset over this bug.
    Misbehavin' likes this.
  7. Misbehavin'

    Misbehavin' Well-Known Member
    Thread Starter

    Thanks for the extra info, I'm going to play around some more tonight at home then.

    Hopefully Sprint/HTC can get this resolved quickly. As mentioned, this is a big show stopper for someone needing access to a corporate VPN via their Evo.
  8. Jensen

    Jensen Member

    I have a PPTP VPN at home and I was hoping 2.2 would finally allow me to pass data through the connection but... nope.
  9. Misbehavin'

    Misbehavin' Well-Known Member
    Thread Starter

    I never got PPTP working under 2.1, but I did set up L2TP at the server and get that working with 2.1. So I know that was working, until 2.2 came along.

    If you're still on 2.1, and you have the option of using L2TP, you might try that route. It would be easier to setup L2TP with a PSK.
  10. I never had an issue with any VPN on android until this Froyo update. DNS server issues a few times, but not vpn if using IP addresses.
  11. Misbehavin'

    Misbehavin' Well-Known Member
    Thread Starter

    Just curious, what protocol and encryption were you using under 2.1? I don't know of anyone I talk to who had PTPP working if MPPE was being used.
  12. I had MPPE but I would get disconnected every few minutes - I assumed it was when a SMS comes in but perhaps it was just random problems.

    I had planned on putting OpenVPN on the phone but this upgrade blocked root which is required to install the files for OpenVPN... argh..

    My wife's Samsung Moment VPN works perfectly with MPPE, although I didn't stay connected more than maybe 10 minutes for what I did using her phone once..
    Misbehavin' likes this.
  13. Deleted User

    Deleted User Guest

    I sent a message over to HTC and was just told to talk to my network admin and given the steps to setup a VPN. Though - that's my fault. I assume they would click the links to the forum to see I'm not the only person having problems. I'm in tech support...I should know better! [​IMG]

    ...that said mine is working now?

    I changed the password I was using for "credential storage". I also noticed the option "use secure credentials" was unchecked. I checked it and tested my VPN. It connected like normal, but now I'm able to route over the tunnel!

    When I uncheck it and test again, I am just prompted to type the password for credential storage. I get a prompt telling me its "credential storage is enabled" and then I type in my VPN pw. When I go back, I see option is automatically checked again.

    Someone else want to give it a shot? First confirm you're still having the issue. I hadn't tried in a few days...and I've done a few power cycles today for other issues. Not sure if THAT cleared the problem...


    Settings > Security > Credential Storage > Use Secure Credentials...

    Make sure its checked and then see if you're able to route over the network.

    (copied from the thread @ sprints forum)
    ProcessorHog and Misbehavin' like this.
  14. brittonx

    brittonx Newbie

    In my case, I was not able to establish a VPN connection tethered to the EVO on 2.1. Once I loaded 2.2, the VPN has been flawless.

    I am wondering if the OP had some cached credentials or other information / settings that caused an issue after the upgrade?
    Misbehavin' likes this.
  15. Deleted User

    Deleted User Guest

    @brittonx: sounds like you're establishing the vpn from the computer. I think this issue is/was with establishing from the evo itself.
  16. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    Misbehavin' likes this.
  17. Misbehavin'

    Misbehavin' Well-Known Member
    Thread Starter

    I already knew how to manage credential storage, that isn't the issue I am experiencing. A factory reset isn't going to help either. It is a issue that has been reproduced by Sprint support. I do know this issue is being investigated further, by Sprint and HTC, but that's about all I really know at the moment.

    When I did first apply the update, I did have an issue with cached credentials, but I got all of that addressed. Cached credentials has been selected during my entire episode to no avail.
  18. Misbehavin'

    Misbehavin' Well-Known Member
    Thread Starter

    Actually I may need to rescind my previous post. While I had to reset my cached credentials post install, I got to thinking that it wouldn't hurt to run through it all again. So I disabled cached credentials, and then tried to connect again. This prompted me to enable cached credentials and would restore what I currently typed in again.

    After doing this, L2TP VPN connections are working once again. So would a hard reset would have fixed this, probably so although it would have been an extreme measure to have to take.

    I'm not sure what the state of the cached credentials was. I was establishing a connection before, but not passing any data. I also thought it had been cleared but apparently something didn't clear directly after the upgrade.

    I guess we learned a little bit more about what may happen during the upgrade process, and hopefully more about how to solve It should it happen again with another update.

    Thanks again to all involved. I'm going to send this forum thread to my contact at Sprint again, in the event they need to explore this issue further on their end.
    EarlyMon likes this.
  19. izyforreal

    izyforreal Lurker

    So, this is weird. I was rooted with Unrevoked 3 when I installed OMJ's original Froyo ROM from 8/3 or 8/5. Needless to say, I was thrilled to find that the VPN worked PERFECTLY! I assumed that all was fixed in Froyo 2.2. Now that I have fully rooted and installed another 2.2 ROM I am finding that it no longer works at all, not even for a few seconds like the 2.1 VPN did. This is TOTALLY unacceptable. I went to the Evo from the TP2 expecting to have a working VPN client.
  20. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    You installed a custom rom and had things working, you've installed a new rom that you've said nothing specific about, now that you've done that, VPN stopped working - you've posted no detail whatsoever about whether the advice in this thread helped or not - and therefore the EVO doesn't compare to the TP2.


    Misbehavin' likes this.
  21. Misbehavin'

    Misbehavin' Well-Known Member
    Thread Starter

    lol!!! Love it!

  22. Misbehavin'

    Misbehavin' Well-Known Member
    Thread Starter

    OK. Now this is getting stranger by the minute. This was working last week, on both WiFi and 3G. However, after trying it this morning, L2TP is once again not working. A connection is established, but no data is being passed.

    I've cleared the credential storage again, just to be sure, to no avail. Nothing has changed on the phone, still running the stock HTC Froyo update.
  23. ProcessorHog

    ProcessorHog Lurker

    Thank you doctah. This helped immensely. I was going crazy, trying to change the routing table and trying to see if anything is going on with iptables. And it worked fine over 4g even without doing the credential tinkering.

    After going the credential storage magic, it works great over 3g as well. Now I can drive everyone at home crazy by turning on the squeezebox in the house at random times and switching it between different stations, all while I'm taking a walk.
  24. Misbehavin'

    Misbehavin' Well-Known Member
    Thread Starter

    I had forgotten about this thread. After clearing the credential storage, I've gotten VPN working again. I'm not sure why I've had some many issues with the credential storage, but all has been well for the past few weeks now.

HTC EVO 4G Forum

The HTC EVO 4G release date was June 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, Snapdragon S1 processor, and 1500mAh battery.

June 2010
Release Date

Share This Page