1. Check out our companion app, Forums for Android! Download from Google Play

Support PPTP VPN Connection

Discussion in 'Android Devices' started by hex1848, Jun 11, 2010.

  1. hex1848

    hex1848 New Member
    Thread Starter

    Jun 11, 2010
    Has anyone been able to get PPTP VPN working? While it appears I can connect to my works network, I can't seem to browse to any of the intranet sites. I've tried it with/without DNS Search Domains, and by simply hitting the ip address. One time I got the NTLM Authentication popup in the browser, but It didn't seem to actually connect. I've also tried hitting the internal 10.1.0.* address of the intranet server but that doesn


  2. incrediblefun

    incrediblefun Member

    Apr 8, 2010
    I am having a similar problem connecting to my PPTP VPN. I can connect to a ClearOS VPN (highly recommended) with no problems from my Win 7 and XP boxes, my Mac and even an iTouch.

    I set up the VPN on my wife's Eris running 2.1 (my Incredible hasn't arrived yet), it connects and I am even able to download a few bytes from an internal web server and then the connection justs hangs. I see the little key on the top left of the display, but I am no longer able to download anything (from any site). Killing the VPN app restores my internet connection (I am able to surf again). This same set of events happens everytime I try to initiate the PPTP VPN connection.

    Has any one else gotten PPTP to work on their Androd 2.1 phones? Can anyone point me(us) in the right direction? Any help would be much appreciated.

    Not being able to use PPTP VPN (or Cisco VPN for that matter on a non-rooted phone) and not being able to do hands free bluetooth dialing (now resolved in Froyo) have really dampend my enthusiasm on an otherwise "Incredibile" phone.
  3. hex1848

    hex1848 New Member
    Thread Starter

    Jun 11, 2010
    I called Sprint Tech Support on this issue yesterday, I'm hoping maybe they can work with HTC/Google on a fix for the 2.2 release? This phone rocks, but I can't make the case for it being a business class phone if the VPN doesn’t work.
  4. stevehy

    stevehy Well-Known Member

    Apr 10, 2010
    NJ, USA
    Having no problem with VPN to any of our clients sites. Once I connect to VPN, I then open eStrongs file manager and with the LAN tab I have set up servers by IP address. Browsing files is immediate with no problems and no problems transferring or downloading files from the sites with the VPN connection active. The only thing I have found with Android PPTP VPN is to not enable security as this hampers the connection.
  5. doggiedog

    doggiedog New Member

    Jul 13, 2010
    In my case I found out the vpn server did not give the right dns-server-ip to the vpn client of android. And also manually entering the DNS Search Domains in android did NOT work (it did not overwrite the dns-server-ip given by the vpn server).

    In the end I just had to make sure the vpn server did give the correct dns-server-ip.

    What vpn server do you use? I am using the (custom) dd-wrt firmware of my linksys router as vpn server.

    Btw: use apps such as IPdroid to check what ip-address and the dns-server-ip are given by the vpn server. IPdroid can be downloaded in the market.
  6. mshek

    mshek New Member

    Sep 30, 2010
    stevehy, what vpn device are you using to connect your droid to?
    I have here a Cisco 3000 concentrator; it sets up a pp2p session and then drops it. We have 2.2 motorola droid and droid x - both behaving identically.

  7. darthanubis

    darthanubis Active Member

    May 4, 2010

    In the end I just had to make sure the vpn server did give the correct dns-server-ip.

    How exactly. Using the same firmware. dd-wrt
  8. prpsarathy

    prpsarathy New Member

    Jan 9, 2011

    pls provide assistance to do the same for htc desire hd.
  9. bourasque

    bourasque New Member

    Jan 19, 2011
    Bump, I'm having the same issue on my htc desire Z.

    Two options for me:

    1. Root my phone and try the sonicwall application to use with our sonicwall vpn gatway

    2. Try to fix the PPtP issue to use with our windows 2003 server vpn gateway

    I'd love this to work as I often need access to our company's servers when I'm on the go.
  10. mickey53usa

    mickey53usa New Member

    Sep 23, 2010
    Know this is an "old" thread, but I also have a problem accessing my corporate network through VPN. This is with a Sprint HTC EVO 4G - Gingerbread 2.3.3. Connection to a Windows Server 2000 RAS Box.
    We have setup the VPN and can connect to the RAS Server. This is verified by looking at the live connection in the Windows 2000 Server.
    Attempt to use either EStrong File Manager or Astro File Manager on the HTC EVO and are unable to connect. Estrong gives error that the server cannot be found. Astro File Manager gives a "Java.io.IOException" error. A ping and a trace route give the following: We know the 144.XX is a Sprint IP Address.

    --- Sep 29, 2011 3:49:27 PM
    --- IP (rmnet0)
    PING 192.168.x.x (192.168.x.x) 56(84) bytes of data.
    From icmp_seq=6 Destination Net Unreachable
    --- 192.168.x.x ping statistics ---
    6 packets transmitted, 0 received, +1 errors, 100% packet loss, time 5002ms
    --- Sep 29, 2011 3:50:18 PM
    --- IP (rmnet0) 184.231.xxx.xxx
    [B][B][B][B][B][B][B][B][B]1 -[/B][/B][/B][/B][/B][/B][/B][/B][/B]
    [B][B][B][B][B][B][B][B]2 -[/B][/B][/B][/B][/B][/B][/B][/B]
    [B][B][B][B][B][B][B]3 - [URL="tel:"][/URL][/B][/B][/B][/B][/B][/B][/B]
    [B][B][B][B][B][B]4 -[/B][/B][/B][/B][/B][/B]
    [B][B][B][B][B]5 - [/B][/B][/B][/B][/B]
    [B][B][B][B]6 -[/B][/B][/B][/B]
    [B][B][B]7 -[/B][/B][/B]
    [B][B]8 -[/B][/B]
    [B]9 -[/B]
    10 -
    11 -
    12 -
    13 -
    14 -
    15 -
    16 -
    17 -
    18 -
    19 -
    20 -
    21 -
    22 -
    23 -
    24 -
    25 -
    26 -
    27 -
    28 -

    Any suggestions appreciated.
  11. lostdummy

    lostdummy New Member

    Jul 26, 2010
    I finally found solution for same issue - android connects, but very soon connection stop working even while VPN is still up.

    My phone (Samsung Galaxy S) has Android 2.3.1 , but I had same issues with earlier OS versions (2.1 and 2.2)

    My PPTP server is DD-WRT on Linksys router LS160 (Firmware: DD-WRT v24-sp2 (08/07/10) std ) - but I had same issues with PPTP server on native LS160 Linksys OS, and also with DD-WRT on WRT54G.

    Initial problem was that Android 2.1 would not connect at all, and initial solution was to allow "optional" encryption on DD-WRT, while Android did not use encryption. That "fixed" connection (it would connect and stay connected), BUT introduced next problem.

    Next problem was that after short time connection just stop working (ping packets start with 2 out of 3 lost, then after some more time none pass)

    SOLUTION to this is counter intuitive, because I had to do opposite of solution to initial problem:

    1) Set DD-WRT to REQUIRE encryption
    Go to Services/VPN/PPTP and set "Force MPPE Encryption" to "Enable"

    2) Set Android to USE encryption
    Go to Settings/Wireless&Net/VPN and Edit your VPN to have "Enable encryption" checked

    Key "solution" here was to remove "optional" from DD-WRT server, and force it to accept only encrypted. Without that, just setting Android to use encryption did not work (ie my original problem, android would not even connect to VPN).

    Downside for this is that I'm not sure if older versions of Android had "enable/disable encryption" checkbox. I think 2.1 didn't have this, in which case it was always "disabled encryption" and above soultion would not work. But Android 2.3 definitely have this option, and I believe 2.2 too.

Share This Page