1. Are you ready for the Galaxy S20? Here is everything we know so far!

Problem backing up ROM on Galaxy S II via ROM Manager

Discussion in 'Android Devices' started by borgmanjayce, Sep 17, 2011.

  1. borgmanjayce

    borgmanjayce Newbie
    Thread Starter

    I'm trying to backup the ROM on my Galaxy S II so I can install VillainROM as the battery life on my phone is totally shit right now plus overheats like crazy!

    I've already rooted it using Super One-Click and Odin so I can use Apps like Titanium and ROM Manager.

    When using ROM Manager to do a NANDROID backup using the instructions found here, I get the following message:

    -- Installing package...
    Finding update package...
    Opening update package...
    Verifying update package...

    E:failed to verify whole-file signature
    E:signature verification failed

    Installation aborted.

    At the top of the screen, it says "Android system recovery <3e> along with various options including system reboot and apply update from sd card.

    My main questions are the following:

    Is it possible to make a backup to an external SD card rather than an internal SD card
    How do I fix the problem with making a backup
    Is there anything I need to do to prevent this problem from happening again?

    I really need to fix this problem ASAP as I also have another problem in that I can't get a 3G signal any more plus when I took it into a phone shop to get it checked out, the idiot who was checking it put it into Flight Mode and now I can't get it switched off!:mad:
     

    Advertisement

  2. Slug

    Slug Check six!
    VIP Member

    This looks like a recovery issue.

    Go here, download the appropriate kernel package for your firmware version, and flash it to the handset using Odin. This will ensure that your recovery is 100% compatible with the GS2. ROM Manager should now function correctly, but if you still have problems you'll find an app named CWM in the drawer. This uses modified ROM Manager code and will work correctly with the GS2.

    p.s. To disable Flight Mode, go to Settings/Wireless & Networks and uncheck the Flight Mode box.
     
  3. borgmanjayce

    borgmanjayce Newbie
    Thread Starter

    I've tried to uncheck the Flight Mode box, but it won't let me!:mad:

    Also, if I flash the relevant kernel to my phone using Odin, will my data be safe or will I need to make a backup using Titanium and reinstall my Apps after doing so?
     
  4. Hawker

    Hawker Android Expert

    Nothing will be lost if all you flash is the kernel.
    In fact, you wont lose anything if you flash most of the complete ROMS. Only a few will wipe, or recommend a wipe.
     
    borgmanjayce likes this.
  5. borgmanjayce

    borgmanjayce Newbie
    Thread Starter

    That's good to know.

    How do I find out the information that I need to download the correct kernel. Also, what's the best custom ROM for the SGS II that has the best battery life and if I install a custom ROM, will it fix my problem with the 3G signal not being accessible any more as well as the Flight Mode not being able to be switched off?
     
  6. Slug

    Slug Check six!
    VIP Member

    Settings/About phone/Build number

    Somewhere in the version string will be "Kxn", where x is a letter and n a number. Look for the matching kernel in the CF-Root thread.

    The first thing to look at with data problems is the APN settings in Settings/Wireless & networks/Mobile networks. Let us know which network you use and someone should be able to compare settings.

    I've never encountered Flight Mode being unable to be disabled, so can't offer any help with that. It certainly isn't normal.
     
  7. borgmanjayce

    borgmanjayce Newbie
    Thread Starter

    According to the Build Number section, it says that it's GINGERBREAD.BUKE1 and the Kernel version is 2.6.35.7-I9100XWKDD-CL161513 root@DELL103 #2

    The network that I use is Vodafone UK and the problem with the 3G shutting itself off and not switching back on happened at my local cinema when I was checking some email before the movie started (I was the only person in the cinema screen that was showing a particular movie) and the 3G signal got switched off which was understandable as I was in a cinema after all.

    Usually the signal would come back on outside and yet for some reason, it didn't switch itself back on!

    Another thing that's weird is the fact that the phone won't let me check what network I'm on even though I know it's Vodafone UK as I keep getting the message below:

    Insert SIM card
    Insert SIM card to access network services
     
  8. Slug

    Slug Check six!
    VIP Member

    The closest to that still available is KE2 (which shouldn't be a problem), available here. This is a direct link to the attachment in post #3 of this topic at XDA.

    Have you checked that the SIM is clean and fully inserted into its slot? If so, then I'd take it back to the shop and demand that they either rectify whatever they did or replace the phone. The above appears to indicate that the handset isn't recognising the SIM any longer.
     
  9. steslatt

    steslatt Android Expert

    I had the exact same problem last week. My signal went dead for some reason so I put it into flight mode then tried to switch flight mode off and it just wouldn't let me. I rebooted the phone and still it wouldn't come out of flight mode. Tried everything with no joy. Luckily I had done a backup that same day so I just restored it and everything was fine again.
    When you wipe and update to Villain this should get rid of the problem.
     
    Slug likes this.
  10. Jblob

    Jblob Lurker

    I'm having the same problem, which version do I need? I know its one of these:

    CF-Root-SGS2_ZS_OZS_KG2-v4.1-CWM4.zip - [Click for QR Code] (5.97 MB, 9319 views)
    CF-Root-SGS2_JP_XSG_KG2-v4.1-CWM4.zip - [Click for QR Code] (5.97 MB, 5800 views)
    CF-Root-SGS2_XX_OXA_KG2-v4.1-CWM4.zip - [Click for QR Code] (6.08 MB, 22457 views)

    Android version 2.3.3

    Build number GINGERBREAD.BUKG2

    Kernel version 2.6.35.7-I9100XWKDD-CL161513root@DELL103 #2

    Thanks for the help :)
     
  11. Jblob

    Jblob Lurker

    i have read around A LOT lol, and the way you rooted your phone could be the issue. Did you soft root? apparently hard rooting doesn't cause this problem.
     
  12. Slug

    Slug Check six!
    VIP Member

    According to a post buried in the CF-Root thread on XDA, XX_OXA_KG2 is a 2.3.4 kernel so that's out. Either of the others should cause no problems, and there's one definite success story using ZS_OZS_KG2 with a 2.3.3 firmware.
     
  13. borgmanjayce

    borgmanjayce Newbie
    Thread Starter

    I've finally reflashed the kernel and it seems to have worked, but now I need some advice on the best way to backup everything as there's three partitions according to Titanium which it looks like I need to backup with the exception of the external SD card which are the internal SD card (whatever that is) and the Internal memory.

    Also according to Titanium, the backup folder for the backups are in /mnt/sdcard/TitaniumBackup which I take it means that they're in the internal SD card (why do they refer to the main internal memory itself (the 16GB storage within the phone itself) as a SD card?

    I definitely don't want to screw up my installation of VillainROM if I somehow inadvertently wipe the data from both partitions in the internal memory (Internal/SD Card) so I also want to know what's the best way of backing up all the settings on my phone itself to my external SD card so if I do need to wipe whatever it is I need to wipe, I can hopefully reinstall everything from Titanium Backup without difficulty...

    EDIT: I did the trick where you hold UP on the Volume button, the Power button as well as the Start button on the bottom and it took me to ClockworkMod Recovery, so I take it that would be a better thing to use than ROM Manager direct from the phone as I still had the same message as before when using the Down+Power+Star buttons trick.
     
  14. Slug

    Slug Check six!
    VIP Member

    Backup/Restore from CWM Recovery; a nandroid backs up everything on the internal memory, which is the most vulnerable. It will allow a full restore of your existing setup even if after a data wipe. Titanium Backup is used to back up apps and data, so between the two you have a complee disaster recovery plan. :)

    This can be changed from within TiB's settings to whichever location you wish.

    Because until recently Android devices had only a limited internal storage area plus the option of an external memory card for expansion. With the likes of the GS2 and its 11.5GB usable internal storage an external card may well not be used, therefore the /sdcard mount point won't exist and many apps would break if they expected to find it.

    For backup/restore/flashing, definitely. ROM Manager can still be used for backup management but I've found even the latest version doesn't boot into CWM reliably.
     
  15. borgmanjayce

    borgmanjayce Newbie
    Thread Starter

    I take it with a Backup/Restore from CWM, it backs up both the Internal partition as well as the Internal SD partition to a SD card (It looks like I may need a bigger SD card as I only have 11.3GB on my external card left and according to Titanium, my Internal is 2.11GB with 1.57GB left and the internal SD card is 12.3GB with 7.01MB left) or does it just back up the Internal partition itself? (Sorry about this, but it's still a bit weird to me that the internal memory is split into two partitions!)

    Also, where are the backups that CWM Recovery makes usually stored?
     
  16. steslatt

    steslatt Android Expert

    CWM doesnt backup the internal sd card, just internal and system storage. It stores backups in a folder called clockworkmod in backups.
     
  17. borgmanjayce

    borgmanjayce Newbie
    Thread Starter

    Do I put the latest version of VillainROM in the internal SD card partition root or on the root folder of the external SD card as it couldn't find the zip file of the latest version that I had placed on the internal version of the SD card.

    EDIT: What's the best way of cleaning a SIM card as I'm still getting the same bloody message about installing a SIM card even though it's already in the phone!
     
  18. steslatt

    steslatt Android Expert

    Have you tried your sim in another phone? Also what version of CWM are you using? One from Rom mangaer?
     
  19. borgmanjayce

    borgmanjayce Newbie
    Thread Starter

    I don't have another mobile to try my SIM in, so I'll have to take it in to my local mobile phone store tomorrow.

    Also, I seem to have a new problem in that I installed VillainROM from the external card as CWM couldn't find the zip file in the internal SD card, only the update zip and now it's stuck on the start screen for VillainROM.

    EDIT: I can get into ClockworkMod Recovery via the trick that I used before. The version that I used is v4.0.0.2 which I believe may have been installed when I installed the new kernel a few days ago.
     
  20. borgmanjayce

    borgmanjayce Newbie
    Thread Starter

    After much difficulty (I asked the guys in the VillainROM thread at XDA-Developers for advice) in installing the damn bloody ROM as for some reason the ROM wasn't in the internal SD card root that the likes of Titanium usually keep their backups in even though I had put a copy of the relevant zip file there, I finally managed to fix it by having a copy of said zip file on the external SD card and installing it although I had to wipe the internal memory, plus both caches over and over to do so.

    I didn't think it would be so difficult to install a custom ROM, but at least I got there in the end.

    I truly want to thank you guys for helping me out and even though VillainROM fixed my issue with Flight Mode, for some reason it hasn't fixed my problem with the 3G not being available for use even though I cleaned the gold contacts on the SIM card with contact cleaner.
     
  21. borgmanjayce

    borgmanjayce Newbie
    Thread Starter

    UPDATE: I took my phone to my local Vodafone store in Liverpool being careful not to show them the VillainROM logo and they tested the SIM in another phone and it worked fine there. I'm wary of sending it away to be fixed after doing a full backup to my external hard drive and waiting weeks or a month or more as well as paying an excess on my insurance if it was working perfectly fine.

    Basically, it was working fine at the beginning of the month until I used it at the cinema to check some email then suddenly it stopped working, 3g-wise. i'm still puzzled as to why the 3g isn't working any more as I've only dropped the phone once or twice and it shouldn't have affected the phone signal if it can pick up a wifi signal.

    I've just checked the efs folder which it was advised to do by XDA-Developers and it said that it's not accessible. I'm just curious as to how it became corrupted including the files that deal with IMEI information.

    If I reflashed the kernel, would that work?
     
  22. Slug

    Slug Check six!
    VIP Member

    The only time I've heard of this happening was due to a bad flash. :thinking:

    Try booting to recovery and from the Advanced menu select Fix permissions. Reboot and see if that makes a difference.

    Can you check Settings/About phone and confirm the current baseband version? Enter *#06# in the phone dialer - does it display your IEMI number?

    Not if /efs is borked, but we don't know that for sure yet.
     
  23. borgmanjayce

    borgmanjayce Newbie
    Thread Starter

    I entered the code that you mentioned and all I got was the word "IMEI" as well as a "OK" button.

    I'm truly puzzled as to how the efs files got deleted as I definitely didn't do anything to them and I definitely didn't know I needed to back them up because nobody said you needed to back them up when installing a custom ROM.

    I've tried fixing permissions without a SIM in the phone and it didn't work.
     
  24. Slug

    Slug Check six!
    VIP Member

    You installed VillainROM 2.4.2, didn't you? What baseband is installed?
     
  25. borgmanjayce

    borgmanjayce Newbie
    Thread Starter

    I actually installed VillainROM 2.5 not 2.4.2


    It's saying that the baseband is unknown.
     
Loading...

Share This Page

Loading...