1. Are you ready for the Galaxy S20? Here is everything we know so far!

Problem gaining some root permissions? ??

Discussion in 'Android Devices' started by srs731, Feb 7, 2011.

  1. srs731

    srs731 Lurker
    Thread Starter

    Hey guys, having some problems with my liberty 1.5 rom I downloaded last night. I am rooted obviously with z4 root. I have some SU permissions dx bootstrap is allowed rom manager and titanium backup all gain super user permission. Wireless teather and DX overclock will not even ask for root rights it just says my device is not rooted. Worked fine when I was running apex and as well when I downloaded liberty without doing a data wipe /factory reset. However when I did that and started from scratch I couldn't get into DX overclock by can gain permissions for some root programs. Have done a battery pull and unroot/re root. Nothing works to gain permissions for DX overclock
    Thank you
    Stefan
     



    1. Download the Forums for Android™ app!


      Download

       
  2. tom108

    tom108 Android Expert

    Have you tried uninstalling and reinstalling the apps from fresh and not from TIBU?
     
  3. srs731

    srs731 Lurker
    Thread Starter

    Yes, I have uninstalled droid overclock multiple times then re-installing it. I also have SetCPU(dont ask why) and that will not gain root access either. Same thing goes for wireless teather, uninstalled and re-installed from the market and still says "unable to start teathering is your device rooted?" This is very strange because the SU box never appears asking me for root rights? However i can get into Titanium backup, bootstrap, and rom manager no problem...
     
  4. k0smo86

    k0smo86 Android Enthusiast

    Open up the Superuser in your app drawer, see if anything is denied in there. This has happened to me before.
     
  5. srs731

    srs731 Lurker
    Thread Starter

    Okay maybe I am not able to use z4 root anymore? However i downloaded a "root checker" and it says i do not have root permissions. I also get the $ sign in the Terminal Emulator and says SU denied.

    When i go int SUPERUSER it says bootstrap, rom manager and titanium backup are all acceptable applications that are running fine. This is what i do not understand. How do i have root privileges for these applications but not for overclock/it says on the root checker i do not have privileges?
     
  6. srs731

    srs731 Lurker
    Thread Starter

    Please delete thread, Everything has been resolved. I did multiple uninstalls combined with battery pulls on z4 root and it eventually worked. Also force stopped super user in my applications menu(for people having problems with this who are searching google as i was)
     
  7. tom108

    tom108 Android Expert

    no reason to delete. this may be helpful to someone else. ;)
     
  8. dragonbro

    dragonbro Android Enthusiast

    I was having issues too and found this thread :) I removed permission on wireless tether and I was able to reroot with Z4root. After a reboot I went back to SU and added wireless tether to the list, all is working again.
     
  9. colchiro

    colchiro Extreme Android User

    Liberty or any rom other than stock, should already be rooted. No need to reroot.
     
  10. dragonbro

    dragonbro Android Enthusiast

    Agreed, but there were applications that were not working properly with an error message saying "your phone is not rooted". Obviously the phone is rooted if running a different ROM, selecting re-root on Z4root seemed to fix the issues for me.
     
  11. colchiro

    colchiro Extreme Android User

    Ok, thanks for the clarification.
     
  12. I had an odd issue with Liberty 1.5... Before installing, I had done a system wipe as recommended and all seemed great. But at some point I seemed to had lost root (su in terminal gave me access denied, and certain apps said I didn't have root access), but still had the superuser app. Apps like bootstrap and droid o/c that had already been given su permissions and were listed in the su app still worked like normal. I tried uninstalling the nonworking apps and re-installing, tried re-rooting with z4root several times, tried booting into recovery and wiping cache, nothing worked. Last thing I tried was booting into recovery, doing a factory reset and re-installed Liberty 1.5 and let google re-install my apps for me rather than using TiBU. That finally worked and gave me back my su access for all needed apps. Hope this might help someone...
     
  13. DesertDude

    DesertDude Lurker

    After reading this thread, I got the idea of just going into Settings_Applications. Found Superuser and tapped Clear Data. voila! Check Root app now shows full root.
     

Motorola Droid X Forum

The Motorola Droid X release date was July 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, TI OMAP3630 processor, and 1540mAh battery.

July 2010
Release Date
0
Reviews
Loading...

Share This Page

Loading...