1. Download our Official Android App: Forums for Android!

Support Problem: Network Signal Reception

Discussion in 'Android Devices' started by alpha9ner, Oct 20, 2013.

  1. alpha9ner

    alpha9ner Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Oct 19, 2013

    Oct 19, 2013
    7
    0
    5
    My S4 tends to lose network signal quite frequently and I get a message "Not Registered on Network" its really frustrating as important calls are often missed.

    I must restart the phone to regain my signal back. I have also gotten a replacement sim from my provider but that doesn't seem to have helped at all.
    The issue still persists.

    Last night I have upgraded my firmware to 4.3 in hope that would clear the issue but it just has happened again.

    I do not think there is anything wrong with the handset before anyone suggest that.

    How can this be solved?

    Thank you,
    alpha9ner
     

    Advertisement

  2. Rukbat

    Rukbat Android Expert
    Rank:
    None
    Points:
    843
    Posts:
    10,392
    Joined:
    Jan 16, 2012

    Jan 16, 2012
    10,392
    2,893
    843
    Male
    Being retired and writing Tasker tasks.
    Fayetteville, NC, USA
    Go to a place that's near one of your provider's towers. (They can tell you where the nearest one is.) If that solves the problem, it's that the place where you keep losing the connection has a very poor signal from that carrier. The only solution to that problem is to change carriers.
     
  3. alpha9ner

    alpha9ner Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Oct 19, 2013

    Oct 19, 2013
    7
    0
    5
    Hi thanks for the reply.. I have tried different carries and areas of very coverage, still tends to lose signal. Also I've tried the sim with my galaxy s2 and there is no signal loss.
    Someone suggested to reflash the modem? I'm not sure how to go on about doing that.

     
  4. lotus49

    lotus49 Android Expert
    Rank:
    None
    Points:
    153
    Posts:
    1,513
    Joined:
    May 9, 2011

    May 9, 2011
    1,513
    232
    153
    Male
    Yorkshire
    In that case, don't.

    I asked about exactly this in the All Things Root sub-forum and I decided against it. Some people who have flashed a different modem have had serious problems including loss of sound or ability to send texts and even a full wipe and restore has not fixed the problem. If you are not sure how to go about it, that makes the risk even greater. This shouldn't be necessary and I strongly advice caution as regards modem flashing.
     

Share This Page

Loading...