1. Are you ready for the Galaxy S20? Here is everything we know so far!

Problem rooting

Discussion in 'Android Devices' started by macktns, Aug 7, 2010.

  1. macktns

    macktns Member
    Thread Starter

    running ota froyo

    i couldn't get my computer to read the sd card through the phone on step 20 of the guide, so i took the battery out again put the sd card into a card reader and placed the update.zip in. Then i put the sd card back in the phone and tried to install it, but i got this error:

    -- Install from sdcard...
    Finding update package...
    E:Can't mount /dev/block/mmcblk0p1 (or /dev/block/mmcblk0(
    (No such file or directory)
    E:Can't mount SDCARD:update.zip
    Installation aborted

    i now am realizing that if i mount the sdcard through the mount options that it auto reverts back to unmounted, same thing with enabling usb mass storage. i know it is not my computer now because as soon as i enable USB mass storage, go back to main menu then go back into mount options it has changed back to "Enable USB Mass Storage"

    I have taken out the battery and sd card many times by now and i know that it is not seated wrong.
    please please please help if you have any ideas

    Edit: how do i know if rsd lite is on my phone? also should rsd lite be open on my computer if my phone is plugged in? does it even matter?
     


  2. macktns

    macktns Member
    Thread Starter

    wtf mate!!!!! took out battery, made some popcorn came back put battery in and success!! i think popcorn was the magic touch lol
     
  3. glitch32

    glitch32 Well-Known Member

    I had a similar issue. When I downloaded a ROM, I renamed it after transferring it over to the SD card. Then I unmounted it (all while in SPRecovery) and it wouldn't remember the name change. It's best to mount, change the name, then safely remove device from Windows or Linux, then unmount. I hope that helps someone.
     
  4. digdug1

    digdug1 Android Expert

    Congratulations
     
  5. blong4life

    blong4life Newbie

    I had the same problem, just keep rebooting and trying to mount /sdcard it'll work eventually. My heart sank the first time I ran it and it said that I was like what the and then I started messing and it worked. Came here after it was the general theme of a problem.
     
  6. Barkleyfan

    Barkleyfan Well-Known Member

    Back when I used SPrecovery, I would drop the rom on the card, then rename it while it was on the card with windoz. Clockwork eliminated the need to rename. This is nice for storing multiple roms, kernels, etc on the sd card.
     
  7. glitch32

    glitch32 Well-Known Member

    I have heard Clockwork can be a little unstable. is that true or is it just as stable as SPRecovery?
     
  8. yufice

    yufice Well-Known Member

    I made the switch to clockwork after being real stubborn about it.
    I don't know why I was stubborn, clockwork is just better.
     
  9. Barkleyfan

    Barkleyfan Well-Known Member

    It's had a few glitches here and there, but @koush keeps it constantly updated. It's also painless to reinstall. Just grab Rom Manager off the market. If you don't like it, he includes SP Recovery in there as well. Doesn't even require a reboot to flash recoveries.
     
    glitch32 likes this.
  10. glitch32

    glitch32 Well-Known Member

    That's a good point. I guess I always think of it as a BIOS update, so it seems to worry me just a little.
     
  11. anderson620

    anderson620 Well-Known Member

    I'm having exactly the same problem but the popcorn trick didn't work....any other ideas?

    I've also tried manually updating to the 2.2 but that didn't take either. I either get the same error as the OP or a "cannot mount SD" error. I think there was an error 31 and 30 in there, too.
     
  12. Barkleyfan

    Barkleyfan Well-Known Member

    I was worried the first time it acted up as well. I did some searching, found the fix for my glitch, and all was well. If your recovery glitches, your flash just won't take. It's not like it will do a partial flash and leave you stranded. It just says installation aborted, and requires reboot. No danger, just a minor annoyance.
     
    glitch32 likes this.
  13. glitch32

    glitch32 Well-Known Member

    Ok, that does make me feel better. Thanks Barkleyfan!
     
  14. Barkleyfan

    Barkleyfan Well-Known Member

    sure thing bud.
     

Motorola Droid Forum

The Motorola Droid release date was November 2009. Features and Specs include a 3.7" inch screen, 5MP camera, 256GB RAM, processor, and 1400mAh battery.

November 2009
Release Date
0
Reviews
Loading...

Share This Page

Loading...