1. Check out our companion app, Forums for Android! Download from Google Play

Problem using Latitude

Discussion in 'Android Apps & Games' started by PMG, Sep 27, 2010.

  1. PMG

    PMG Active Member
    Thread Starter

    May 3, 2010
    North Central Texas
    I've got a droid incredible running Froyo (2.2). My phone has the latitude app, but it wont set up. When i launch it, it says it wants to set up, then asks me to create a new gmail account or log-in using a an existing one. So I select sign in as existing, and I type in my gmail account & password and it says "There is already a xxx@gmail .com account on this phone". But it wont frikkin sign in!

    What gives?:thinking:


  2. w_bovine

    w_bovine Well-Known Member

    Jul 19, 2010
    I'm not completely sure, having never done it, but perhaps you could clear the phone's user data and try signing in again? You might check on the Incredible forum as well, if you haven't already, for more specific information since I have a Vibrant.

    HTC Incredible - Android Forums
  3. freakqnc

    freakqnc New Member

    Sep 28, 2010
    This really suxx. I am experiencing the same problem. Very disappointed with the experience but not disappointed enough to go iCraPple! I have to say though that Android lately is pushing all my wrong buttons. Recently also the "searching for GPS" problem popped up and searching the web I am not alone. Now I tried to reinstall the Google Maps Application as some suggested that will likely fix the problem (with no need to hard reset or re-flashing) and upon launching Maps said login failed... I wonder why since the friggin phone has already a gmail account working on it... so I went ahead and started a sign in process.... where it asks if you want to create a new account or want to sign in with an existing one... so needless to say I want to friggin sign in with the existing one! I try to do that and guess what the genius application tells me? Yep, you guessed it! The application tells me that very same thing "There is already a [myusername@gmail.com] account on this phone"... at which point I could only say: "No shit genius!!" Now I have no idea which team of brains coded this thing for Android... but how about doing some debugging and offering to lend a ear to the millions buying phones powered by your system? I am making an effort here to stay off iSteve hegemony... I'd expect Google to be a bit more involved with the end users!

    If anyone ever finds a fix please post it/PM... much appreciated. If I happen to find a fix that works form me i will come back and post it here.


    PS: forgot to add that I am running Sapphire ROM 1.1.0 (love that rom!)
  4. tridarsa

    tridarsa New Member

    Dec 5, 2010
    I have a diferent problem, I cannot change my latitude acc (having 2 gmail acc), it will always automaically log in using the previous acc. now How can I 'unremembered' log ins?
  5. UKseagull

    UKseagull Well-Known Member

    May 30, 2010
    York UK
    I think you may need to clear your browsers cache/cookies.
  6. iantresman

    iantresman Member

    Aug 25, 2010
    This worked for me (Samsung Galaxy Ace with Android 2.2):

    1) Sign out of Latitude (Privacy > Sign out)
    2) Clear Maps data(Settings > Applications > Maps > Manage applications > tap Maps > Clear data)
    3) Reboot phone
    4) Re-join Latitude from the Maps menu

Share This Page