1. Download our Official Android App: Forums for Android!

problem with auto-sync

Discussion in 'Android Devices' started by mreortiz, Jun 12, 2010.

  1. mreortiz

    mreortiz Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    54
    Joined:
    Jun 5, 2010

    Jun 5, 2010
    54
    2
    16
    teacher
    Whitehall, PA
    I have background data checked, auto-sync checked and my gmail (I only have one account set on my phone) set checked to sync. So, correct me if I'm wrong but when I get an email sent to my gmail account shouldn't it show up in my stock gmail app within a few minutes. I checked my email at 10:07 AM and I was expecting an email. I manually refreshed my gmail and pop, there is the email that was sent at 9:02 AM!!!! WTH?? I thought the phone was suppose to auto sync...it shouldn't be taking an hour to show up in my email on my EVO. I'm a little frustrated with this. If the option is there to auto sync then it should! anyone else experiencing this type of mini problem?
     

    Advertisement

  2. RoboMonkey

    RoboMonkey Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,194
    Joined:
    May 12, 2010

    May 12, 2010
    1,194
    114
    143
    I think stock gmail email app is receiving email via a push operation, so there is no way to change the interval.

    I just tried and sent myself a test email from my outlook on my desk top and it showed up in my EVO like immediately.

    Do you have your notifications enabled?
     
  3. mreortiz

    mreortiz Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    54
    Joined:
    Jun 5, 2010

    Jun 5, 2010
    54
    2
    16
    teacher
    Whitehall, PA
    No I don't have notifications for my email enabled. Why would that make a difference? I don't need to know exactly when I get my email, I just want it to be there when I open up my inbox...I shouldn't have to refresh my email manually when auto sync is on. It doesn't happen all the time, but it happens and it shouldn't
     
  4. RoboMonkey

    RoboMonkey Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,194
    Joined:
    May 12, 2010

    May 12, 2010
    1,194
    114
    143
    Well don't know what to tell you. Take it back maybe.
     
  5. RoboMonkey

    RoboMonkey Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,194
    Joined:
    May 12, 2010

    May 12, 2010
    1,194
    114
    143
    Oh and if the Google Talk Service is not running you wont receive any new emails even if you have the auto sync option enabled for gmail.
     
  6. mreortiz

    mreortiz Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    54
    Joined:
    Jun 5, 2010

    Jun 5, 2010
    54
    2
    16
    teacher
    Whitehall, PA
    Hmm...that is probably it. I thought we didn't need that on so I would stop that from running...thanks for the tip...I have hope again!
     
  7. htcevolee

    htcevolee Android Enthusiast
    Rank:
    None
    Points:
    73
    Posts:
    255
    Joined:
    Jun 10, 2010

    Jun 10, 2010
    255
    56
    73
    IT Engineer
    Cali
    Go to SETTINGS
    then Uncheck AUTO SYNC
    Uncheck BackGround Data

    Then Re-check Background Data
    and Recheck Autosync

    Then under Manage Accounts choose your Google email
    Make sure Sync Gmail is Checked
    I have contacts and calendar unchecked because i sync with my Exchange account at work.

    Let me know if this works.
     
  8. mreortiz

    mreortiz Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    54
    Joined:
    Jun 5, 2010

    Jun 5, 2010
    54
    2
    16
    teacher
    Whitehall, PA
    U mean the gtalk service that I see under "running settings"....if so...just curious, why would that need to be on?
     
  9. htcevolee

    htcevolee Android Enthusiast
    Rank:
    None
    Points:
    73
    Posts:
    255
    Joined:
    Jun 10, 2010

    Jun 10, 2010
    255
    56
    73
    IT Engineer
    Cali
    I dont think that Gtalk needs to be running to make GMAIL work as its a Native APP to Android.

    I had the same issue where GMAIL PUSH was not working. I did the following with the disable and enable of the syncing properties and it worked immediately for me. Its resetting the Sync properties.
     
  10. RoboMonkey

    RoboMonkey Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,194
    Joined:
    May 12, 2010

    May 12, 2010
    1,194
    114
    143
    :cool:

    If you want the phone to receive instant emails.
    Yea it kinda does need to be on. Gmail is not a "sync" operation. It is a push service.
     
  11. htcevolee

    htcevolee Android Enthusiast
    Rank:
    None
    Points:
    73
    Posts:
    255
    Joined:
    Jun 10, 2010

    Jun 10, 2010
    255
    56
    73
    IT Engineer
    Cali
    I thought GTalk is "Google Talk" which is not a native app but one you have to download. Android comes with GMAIL natively which is PUSH email. I dont have GTalk service running and still get GMAIL within seconds.

    I checked to make sure GTalk was NOT running under the "Running Services".

    If you setup your GMAIL using the Native GMAIL app it will PUSH.
     
  12. RoboMonkey

    RoboMonkey Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,194
    Joined:
    May 12, 2010

    May 12, 2010
    1,194
    114
    143
    Good grief, no it wont if you shut down the gTalkService.

    Gmail auto sync issues
     
  13. htcevolee

    htcevolee Android Enthusiast
    Rank:
    None
    Points:
    73
    Posts:
    255
    Joined:
    Jun 10, 2010

    Jun 10, 2010
    255
    56
    73
    IT Engineer
    Cali
    Then I must be crazy because I stopped the gtalk service in running services and I still get gmail instantly. ;)
     
  14. RoboMonkey

    RoboMonkey Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,194
    Joined:
    May 12, 2010

    May 12, 2010
    1,194
    114
    143
    Well...:rolleyes:
     
  15. htcevolee

    htcevolee Android Enthusiast
    Rank:
    None
    Points:
    73
    Posts:
    255
    Joined:
    Jun 10, 2010

    Jun 10, 2010
    255
    56
    73
    IT Engineer
    Cali
    I signed into gtalk then signed out and went to running services and stopped the gtalk service and I'm still getting gmail from my gmail icon instantly. How can you not understand they are 2 separate apps and don't need eachother to work?
     
  16. MisterEd

    MisterEd Android Expert
    Rank:
    None
    Points:
    93
    Posts:
    773
    Joined:
    Apr 15, 2010

    Apr 15, 2010
    773
    117
    93
    New Joisey
    I have had TALK disabled since day 1 and haven't missed a single gmail message on 5 gmail accounts. They arrive within seconds of being sent. Gmail and Talk are 2 separate push services.
     
Tags:

Share This Page

Loading...