1. Are you ready for the Galaxy S20? Here is everything we know so far!

Problem with boot animation

Discussion in 'Android Devices' started by greg4501, Aug 8, 2010.

  1. greg4501

    greg4501 Newbie
    Thread Starter

    ugh..been trying to get this all day. :thinking:
    i'm just trying to change my boot animation to go along with a theme i have for bugless beast 0.4...i was told to put the bootanimation.zip in the data/local folder which i did..then i used terminal to load it up and it says no such directory or something.

    so to be clear i was supposed to create the local folder myself right?
    data is in the root, then i make the local folder inside the data? it seems i'm doing everything right but when i power on the phone i dont even have an animation..it just goes from the M symbol to the phone on.

    please helppp
     


  2. johnlgalt

    johnlgalt Antidisestablishmentarian

    you need root privileges to do that.

    In terminal, be sure the first thing you do is
    Code (Text):
    1. su
    Once the prompt changed from
    Code (Text):
    1. $
    to
    Code (Text):
    1. #
    In my \Data there is already a local folder - you should not have had to create it.
     
  3. greg4501

    greg4501 Newbie
    Thread Starter

    Well..i am rooted.

    and i do know about the su and the # and all that...it just hasnt worked in the end.
    and i didnt have the local folder inside my data, not sure why, if you already did.

    it seems so simple but it's just not working. O__O
     
  4. istolvampire

    istolvampire Android Enthusiast

    Why not just use root explorer. That way is simple enough.
     
  5. johnlgalt

    johnlgalt Antidisestablishmentarian

    But the fact that you had to create the folder is worrisome. And sorry for re-hashing what you already knew, but I had no idea that you knew that, so I was making sure.

    As for it not working, not sure what else it could be. Have you checked the other forums to make sure there aren't alternate instructions to make it work?
     
  6. greg4501

    greg4501 Newbie
    Thread Starter


    No worries about mentioning something i already knew..i didnt start doing this stuff tilll yesterday though lol. i just rooted yesterday, i'm on bugless beast with froyo 2.2..

    i havent really checked the other forums..i did ask on droidforums.net but noone answered yet. i'm stumped too about not having the local folder..no idea why that could be.
     
  7. Lock-N-Load

    Lock-N-Load Android Expert

    I am rooted and I am getting a "permission denied" message?

    any thoughts?

    this seemed to have worked

    su
    # mount -o rw,remount -t yaffs2 /dev/block/mtdblock4 /system
    # busybox cp -R /sdcard/bootanimation.zip /data/local
    # mount -o ro,remount -t yaffs2 /dev/block/mtdblock4 /system
    # sync
    # reboot

    interesting that Astro will not show you /local/ inside /data/ but you can see /data/ and in fact Root Explorer will show you it all and it was Root Explorer that showed the files made it into /local/
     

Motorola Droid Forum

The Motorola Droid release date was November 2009. Features and Specs include a 3.7" inch screen, 5MP camera, 256GB RAM, processor, and 1400mAh battery.

November 2009
Release Date
0
Reviews
Loading...

Share This Page

Loading...