1. Download our Official Android App: Forums for Android!

Apps Problem with Emulators

Discussion in 'Android Development' started by purnachandrarao, Aug 20, 2010.

  1. purnachandrarao

    Thread Starter
    Rank:
    None
    Points:
    25
    Posts:
    8
    Joined:
    Jul 20, 2010

    Jul 20, 2010
    8
    0
    25
    programmer
    india
    hi
    i have some problem with running my application.
    my application was developed using android 2.1 updated (api level 7).
    The application running on api level 8 emulator perfectly but not running properly on api level 7 emulators. the problem will be occurring on forward and rewind cases.
    the problem will be "The application stopped unexpectedly.please try again"
    please any one guide me to rectify the problem.
     

    Advertisement

  2. 93interactive

    93interactive Newbie
    Rank:
    None
    Points:
    15
    Posts:
    13
    Joined:
    Aug 15, 2010

    have you tried running it through debugger (that bug icon left of the run icon if you use eclipse)... even if you do not set up any breakpoints or such, you (usually) get much more info what happened, e.g. any exceptions occured.

    you should also make sure to output any occuring exceptions in try/cach blocks... e.g.

    Code (Text):
    1.  
    2. try {
    3.   // some code
    4. } catch (Exception e) {
    5.   Log.v("exception", e.toString());
    6. }
    7.  
    you'll see it printed out then on the debug output window
     

Share This Page

Loading...