1. Check out our companion app, Forums for Android! Download from Google Play

Problem with error messages with acer liquid s100

Discussion in 'Android Devices' started by thamemdmc, Jan 9, 2012.

  1. thamemdmc

    thamemdmc Member
    Thread Starter

    Dec 6, 2011
    New ROM of Android 2.2 (Froyo) for Liquid

    i m using Acer LiquidE S100 with android 2.2 installed init Version 1.100.92.EMEA.CUS4_A21E_A. I have tried to download android 2.2 froyo from Canada Website version 4.001.17.PA.ROG_A22F_A and after starting flashing as per the instruction in the startup i m getting the error message unable to upgrade to new OS phone will start in recovery mode to upgrade new OS in 5 sec and i m getting the error msg now displays the triangle with the ! in the middle and the little android guy.i have tried to roll back and install the same old version but again i m unable to do it.
    Please help me to solve this problem. My phone is not working.


  2. HustlinDaily

    HustlinDaily Well-Known Member

    Apr 6, 2010
    Sugar Land, TX
    Do not install the Canadian version, had it worked, your phone would have been simlocked to Rogers or Fido (depending on the version you installed).

    Unfortunately, Acer did not release Froyo for EMEA_CUS4 (lazy?). Also, this is the only ROM which has native Arabic support (so if you need Arabic, you are stuck on Eclair ).

    There is a way you can update it but it does void the warranty (it does not require root nor does it root your device, it requires using the Acer Download Tool).

    Just download a .bin file from here- Acer Liquid and Liquid E ALL ROMs bin extract collection - Android @ MoDaCo (I'd reccomend 4.002.14.EMEA.GEN1 or 4.008.08.EMEA.VFIT. Note, the newer ROMs are on the bottom. If you have a 256MB RAM Liquid choose "Liquid 256MB" if you have a 512MB RAM Liquid, choose "Liquid 512MB")

    And follow these directions- [TUTORIAL] How to flash .bin files on Acer Liquid/E - Android @ MoDaCo

    And if anything goes wrong, refer to this thread- [TIP] Dont try to restart phone during flash if it looses connection, or u will have a bricked liquid! [MOD PLEASE STICKY!] - Android @ MoDaCo

    Furthermore, if you install EMEA_GEN1 (or any AAP), the OS will look VERY different. This is because Froyo for the Liquid uses Acer UI. Play around with it, see if you like it (some do, some do not). If you do not like it, go into Settings-->Development-->User Interface-->Android UI and it will boot into a vanilla Android user interface (which you are used to).

    Hope that helps. Ask if you need anything.

    Btw, the Acer Download Tool CAN be used in recovery (Android robot with !). If you need Arabic, re-install your original Eclair ROM (1.100.92.EMEA.CUS4, it is in that list of bins).

Share This Page