1. Are you ready for the Galaxy S20? Here is everything we know so far!

problem with ethernet on android

Discussion in 'Android Lounge' started by androidnewbie12, Sep 28, 2020.

  1. androidnewbie12

    Thread Starter

    Hello..

    I have a POCO phone F2 Pro and I need to be able to connect through ethernet and set Static Ip for ethernet connection..

    I am using a usb c to ethernet adapter. WHen i plug in the ethernet cable on the adapter I have internet without problems out of the box.. I didn't need to do anything as it worked directly..
    The problem is that once i connect the ethernet cable to my phone, I don't see any ethernet option in the settings menu of the phone.. I have searched all over the phone settings, i have enabled developer options but nothing...

    Please could someone help me on this ? How can i make the ethernet option appear on the settings menu so that I can then set static Ip on the ethernet connection???

    THanks a lot..
     


  2. lunatic59

    lunatic59 Moderati ergo sum
    Moderator

    It would probably be easier to set a MAC reservation on your router so that adapter will always be assigned the same IP.
     
    MrJavi and Dannydet like this.
  3. androidnewbie12

    Thread Starter

    Hello, i will not have a router.. I am just tryint to connect an ethernet cable that connectes the phone with the OBD port of a car...When i use the usb c to ethernet adapter i can browse the internet and there is internet connectivity, so the ethernet adapter works ok with my phone.. My problem is that i can't see the ethernet as an option in android setting so that i can set up the connection as required and mentioned further below..

    My goal is to use an android app that programs several functions of a car, and according to the manual of the app https://bimmercode.app/manual/ i am following the options as mentioned below :

    ENET cable connection
    Please make sure your Android device supports an ethernet connection and allows to use a static IP address. Otherwise this connection type is not supported.

    1. Connect the ENET cable with your Android device using an appropriate USB to Ethernet adapter.
    2. Connect the cable to the OBD port in the footwell on the driver side in the car.
    3. Enable “Static IP“ in the Android Ethernet settings(“Connections“ > “More connection settings“ > “Ethernet“ > “Configure Ethernet device“ > “Static IP“) and make the following entries:
      • IP Address: 169.254.250.250
      • Netmask: 255.255.0.0
      • Default gateway: 0.0.0.0
      • DNS address: 0.0.0.0
    4. Disconnect the cable and connect it again to make the changes take effect.
    5. Open the settings in the BimmerCode app and make sure the correct adapter type is selected.
    6. Tap “Connect” on the start screen in the BimmerCode app.
    7. Upon first use a dialog is displayed and you have to allow BimmerCode access to the UBS device. Please confirm with “OK“ and then tap “Connect” again.

    so why is that damn ethernet does not appear anywhere in the settings ??

    thanks
     
  4. Alexenferman

    Alexenferman Member

    I don't think there is any Ethernet settings available. I also connected my phone to Ethernet once and there was no setting for this on Lineage or AOSP.
     
Loading...

Share This Page

Loading...