1. Are you ready for the Galaxy S20? Here is everything we know so far!

Problem with flashing

Discussion in 'Android Devices' started by zic68, Dec 30, 2009.

  1. zic68

    zic68 Lurker
    Thread Starter

    Hi.. all inc kam187

    Here is my galaxy bought from ebay.

    I realised my Galaxy does not recognise the internal memory(8GB), it says only 31mb left.
    However, if I connect to PC, I can access the internal memory as a mass storage. (Thank you kam187, I formatted the internal memory on my pc, but no joy :( )

    I brought Samsung repair centre, but they refused it with funny reason.

    I checked its firmware it says I7500XXID3, not sure how come... [​IMG]

    I thought it might be a firmware..so I tried to flash with Odin
    but not successful as it says <1> e - big partition size!!
    I tried 4 different PCs with different firmwares as some suggest but no joy..

    Also, I tried fastboot flash but I stuck at

    C:\tools>fastboot flash recovery recovery.img
    sending 'recovery' <2966 KB>...OKAY
    writing ' recovery'.... FAILED <remote: flash write failure>

    I am wondering whether you can help me.....?? please.


  2. Rastaman-FB

    Rastaman-FB Extreme Android User

    that firmware version is very early, earliest ive seen tbh
    this might be a pre release model (non production)

    are you using the original samsung cable (actually says samsung on it)
  3. zic68

    zic68 Lurker
    Thread Starter

    Yes, I am using samsung genuine cable..
  4. adamedoe

    adamedoe Newbie

    Any news? is it possible to flash a pre release model?
  5. zic68

    zic68 Lurker
    Thread Starter

    Still no solution so far..

    Anyone has got any idea? Anyone want to have a go??

  6. Rastaman-FB

    Rastaman-FB Extreme Android User

    the issue is that youve ruled out the flashing problem is not machine specific, not the version you are trying to flash as you have tried multiple so its got something to do with the device itself
    fastboot will not let flash the recovery either

    im not sure why if youve formatted the sd partition of the internal storage you are only seeing 32mb
    did you format it as fat32? it should not be NTFS
  7. adamedoe

    adamedoe Newbie

    I've personally tried all format possibilities... fat16, fat32, even ext2, but still the same. It give only 30Mo or so when you brows it from the device.

    Is there any possibility to force flashing the ROM? can't it be locked or something?

    Though, the errors given by Odin and the fastboot flash are not the same. Odin talks about partition table error and fastboot talks about accessibility to the ROM.

    Any help around these issues?

  8. Andronix

    Andronix Android Enthusiast

    the phone doesn't boot into OS? install busybox and paste output of 'mount' and 'df' commands.
  9. adamedoe

    adamedoe Newbie

    Thanks for your answer.

    I tried to install the busybox, so I can get you the needed results from your requested commands. The process needs to get to the recovery mode right... When I tried to access it, the phone crashes and force factory reset!

    Does this mean that this phone doesn't have a recovery mode? which will explain why the recovery ROM won't flash!
  10. adamedoe

    adamedoe Newbie


    I succeeded to extract the current recovery.img (was actually on the /system folder waiting for me!). I've tried to flash with God knows how many recovery.img, but without any success. It always refers to insufficient memory space (guess it's the ROM's size), but when I flash with the founded recovery.img, it works! I mean, I can flash it without any prob.

    My idea is to have the need recovery.img (HDblog.it like) but in a smaller size ~ 2.2 MB (2285568 bytes). I'm sure it's gonna work, but still, I need to get hold of such a recovery.img :(

    Can you help me guys? please!

  11. spottyelephant

    spottyelephant Android Enthusiast

    Where did you buy the phone? It sounds to me like there is a hardware problem which cannot be fixed by flashing or anything. I would look into returning the phone, or having the repair centre sort it out. Don't accept no for an answer!

    Edit, i think there's a 2.9mb recovery image here. Might be still to big though (also, im in work and didnt read the whole thing, just make sure it's what you need!)
  12. adamedoe

    adamedoe Newbie

    Thanks for your answer.

    I already tried this one too. Here's a link to the img that can be flashed so far ~ RapidShare: 1-CLICK Web hosting - Easy Filehosting

    As you can see, it's 2.2 Mb, so, if I can have a working one with that size, it should work.

  13. zic68

    zic68 Lurker
    Thread Starter

    Hi Adame

    Any success??

  14. adamedoe

    adamedoe Newbie

    None. Still waiting for a light version of the recovery image.

Share This Page