Root Problem with FlashRec


Well-Known Member
Step 4: Type into the text box, "/sdcard/cm-recovery.img" or whatever you renamed MoDaCo's recovery image to, and hit Flash.

In this step#4, after entering /sdcard/cm-recovery.img in the text box, there are two buttons: 1.


Well-Known Member
Thread starter
Slug, even I did think in that way but further following those steps (mentioned in that procedure), there is another nandroid backup. So I got confused.

Step 6: You should now be in the custom recovery mode. Select the Nandroid Backup option in order to create a backup of your current ROM.

Are those two backups different?


Check six!
Are those two backups different?

Oh yes! :)

A Nandroid backup is the best insurance against mishap, as it is a complete image of your handset at the point of backup. The ROM, apps, data, recovery image.... everything is saved in this. Restoring it returns your handset to the exact state it was in when th backup was made.

In contrast, the FlashRec backup is only of the standard (or current) recovery image.
I had this problem and solved it in a cunning way (well not really that cunning at all really.)

1. Rename "recovery-RA-hero-v1.3.2.img" or whatever you're using to "recovery-backup.img"

2. Select "flash recovery image"

It worked for me.


Well-Known Member
Thread starter
Here for me, "Flash Recovery Image" button is disabled (grayed out) and I can not hit it. That is the issue!!!
Was your trick: Rename "recovery-RA-hero-v1.3.2.img" or whatever you're using to "recovery-backup.img" instead of "cm-recovery.img"?
Do I need to Root my phone prior to do this?



If you're feeling ballsy you can hit the invisible button the right of the backup button, which allows you to bypass the requirement for a backup before flashing.

This is only way I found that worked - admittedly I didn't look for an alternative option for long!