1. Download our Official Android App: Forums for Android!

Problem with Gmail app

Discussion in 'Android Apps & Games' started by allanNZ, Nov 3, 2011.

  1. allanNZ

    allanNZ Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Nov 3, 2011

    Nov 3, 2011
    6
    0
    5
    Gmail app is running on Android 2.2 on my phone.

    When I select the 'Inbox' label, it always says "No conversations.", even if there are emails in my inbox. I have to select the 'All Mail' label to read them.

    What am I doing wrong?
     

    Advertisement

  2. chrlswltrs

    chrlswltrs Android Expert
    Rank:
    None
    Points:
    333
    Posts:
    6,728
    Joined:
    Nov 12, 2009

    Nov 12, 2009
    6,728
    1,791
    333
    Male
    Private Security
    Seattle
    Do you have your mail going to your priority inbox and not your inbox? I really am not sure how that works as I try to keep my inbox cleaned up and never set up the priority inbox that gmail started recently.

    The more basic things to check:
    1. In settings do you have background data and sync enabled?
    2. In your Gmail app settings do you have the proper folders and time range set to sync?
     
  3. allanNZ

    allanNZ Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Nov 3, 2011

    Nov 3, 2011
    6
    0
    5
    The priority inbox also comes up "No conversations".

    When I list the labels, there is a '4' beside inbox, presumably meaning that there are 4 unread messages, but when I select inbox i get: "No conversations".

    When I select "All Mail" it lists my messages, and 4 of them are labelled "inbox". So why don't they appear in my inbox??!

    Inbox sync is set to last 4 days. These are emails received today.

    Very frustrating.

    Gmail version 2.3.5.2
     
  4. chrlswltrs

    chrlswltrs Android Expert
    Rank:
    None
    Points:
    333
    Posts:
    6,728
    Joined:
    Nov 12, 2009

    Nov 12, 2009
    6,728
    1,791
    333
    Male
    Private Security
    Seattle
    Try to go to settings-> applications-> manage applications-> gmail, then clear data. Then open the gmail app and try setting up everything again and see if that helps.

    Also after you set up the app, log into gmail on a computer and make sure you have no unread messages, sometimes that can cause a problem initially with the app syncing properly for some reason.
     
  5. allanNZ

    allanNZ Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Nov 3, 2011

    Nov 3, 2011
    6
    0
    5
    I 'cleared data' for Gmail, but it did not seem to delete my account details - I did not have to re-enter my email or password again.

    I sent a test email, and Inbox and Priority inbox both have a '1' (ie one message) but both show 'no conversations'.

    But the email does show up in 'All mail'.

    So, still not working for me.
     
  6. NoMoreSymbian

    NoMoreSymbian Member
    Rank:
    None
    Points:
    38
    Posts:
    72
    Joined:
    Dec 5, 2010

    Dec 5, 2010
    72
    11
    38
    Twin Cities, MN
    Not sure what phone you have but press the menu button then refresh, does it then put your mail in the inbox?
     
  7. allanNZ

    allanNZ Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Nov 3, 2011

    Nov 3, 2011
    6
    0
    5
    Weird, today it suddenly started working. Maybe to do with the 4 day sync? (Been about 4 days since I set it up).

    Anyway, thanks for you answers.
     
  8. CodeMonkey

    CodeMonkey Android Enthusiast
    Rank:
     #243
    Points:
    93
    Posts:
    571
    Joined:
    Dec 13, 2008

    Dec 13, 2008
    571
    110
    93
    Software Developer
    On the sofa
    There was a brief issue a few days back with some Gmail accounts where mail went straight to the All Mail folder and bypassed the inbox; this affected one of my auxiliary accounts and I had an email from Google about it. It showed the same behaviour on my phone as you were experiencing.
    Sounds like your account was also affected and is now fixed.
     
  9. GalaxyS2Kent

    GalaxyS2Kent Well-Known Member
    Rank:
    None
    Points:
    58
    Posts:
    200
    Joined:
    Sep 2, 2011

    Sep 2, 2011
    200
    14
    58
    Female
    homemaker
    England
    Don't have an answer because I have the exact same problem. I've done everything suggested but still no joy! Like you, I get something like "Inbox (2)" but "No Conversations" -- yet the mail is definitely there under "ALL Mail". I suppose at least THAT works but it's a bit of a hassle. Hope someone comes up with a solution. I've changed settings in both my phone and (when using the browser) changed mail settings.
     

Share This Page

Loading...