1. Are you ready for the Galaxy S20? Here is everything we know so far!

Problem with read and write permissions.

Discussion in 'Android Devices' started by SpartanLOL, Nov 4, 2011.

  1. SpartanLOL

    SpartanLOL Newbie
    Thread Starter

    I was trying to uninstall some carrier apps through ADB on Windows, via CMD. I wasnt unable to do so, and investigating about my problem, I found that I can uninstall through Titanium Backup [​IMG]. Now I dont have anymore the vodafone apps and trial games that came with my Samsung Galaxy I5510!.
    But for what I am writing this, is that for unknown reasons to my, when trying to uninstall through ADB, I always have the problem of READ ONLY FILE SYSTEM. I tried to remount through this command:
    mount -o rw,remount /dev/block/stl9 /system
    that I found here: GUIDES & FAQs [Android]: ADB Workshop by Adrynalyne and Guide by Captainkrtek - xda-developers , at the ADB Workshop, at deleting files.
    this command:
    # mount -o rw,remount -t yaffs2 /dev/block/mtdblock3
    # chmod 777 /system
    from here: Write on the Android Read-only file system « PocketMagic
    I was forgetting other thing, the first time I used ADB was guiding myself with this guide: http://www.thedroiddemos.com/2010/08...-from-android/

    Maybe in the future I need to use ADB again, so thats why I am writing this, even though my problem with the carrier apps is solved.
    And I have the stock Android 2.2 Froyo rooted with SuperOne Click.
    And (again), I dont know where to place this post, my smartphone doesnt have a subforum, and I also ask for the admins to add the subsection [​IMG]
    Thanks in advance! [​IMG]
     


  2. karandpr

    karandpr Android Expert

    The toolbox mount is pretty ineffective .You need to add the busybox prefix

    Run these commands instead
    #busybox mount -o rw,remount /system
    #chmod 777 /system
     
    SpartanLOL likes this.
  3. SpartanLOL

    SpartanLOL Newbie
    Thread Starter

    Thanks for the answer, I will try it when I have some free time :)
    But, anyway, I found an app, hope it is useful for someone, its called Ghost Commander. If you give root permission, you can mount the directory in which you want to work. The main use of the app is file exploring, but it has this extra feature.
     
  4. karandpr

    karandpr Android Expert

    Haha .Thats not the only app :D
    Root Explorer(Paid) ,Super commander ,FileXpert,ES File Explorer , (All free) also can mount in r/w mode ;)
     
    SpartanLOL likes this.
  5. SpartanLOL

    SpartanLOL Newbie
    Thread Starter

    I thought it was the only one lol
    Thats why I read everywhere about Root Explorer :D
     

Samsung Galaxy 551 Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...

Share This Page

Loading...