1. Are you ready for the Galaxy S20? Here is everything we know so far!

Problem with Samsung GT-I9003 SuperLCD switch itself off automatically at night

Discussion in 'Introductions' started by Penney1, Aug 10, 2012.

  1. Penney1

    Penney1 Lurker
    Thread Starter

    Can someone help me resolve this problem? I upgrade firmware to Gingerbread 2.3.6 on my Samsung GT-I9003 Super LCD and since then every night the phone keeps switched off and really drain the battery. I have turned off GPS and wireless etc. Use only my mobile network. I also upgraded Myandroid Protection.
    If you know how to fix this problem please help.

    1. Download the Forums for Android™ app!


  2. AntimonyER


    Welcome to AF, Penney1! In order to help you, we need to find out what is draining your battery. Go into settings, and then choose the battery option. THat will list what is using your battery, and we can go from there :)
  3. DonB

    DonB ♡ Truth, Justice and the American Way !! ♡ ™

    Penney, sorry to hear about your issues, also try a battery pull to make sure nothing is not running in the background, good luck

    Welcome :ciao: ,we are glad to have you, hope you enjoy the site.

Share This Page