1. Download our Official Android App: Forums for Android!

Problem with updating android

Discussion in 'Android Devices' started by Tete_360, Dec 21, 2013.

  1. Tete_360

    Tete_360 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Dec 21, 2013

    Dec 21, 2013
    3
    0
    5
    Male
    SA
    Hello everyone, All I'm trying to do is to update my android, it's Xtouch X405 (My first smartphone), I tried to update it via Settings/About phone/System updates, but it occurs this error every time: "Network connection failed" whilst my network connection is fine as i can browse the internet and download apps via playstore very normal, please i need a solution to do a successful update, thanks in advance.

    Current version: 4.0.4
     

    Advertisement

  2. breadnatty08

    breadnatty08 pain rustique
    Rank:
    None
    Points:
    1,413
    Posts:
    19,889
    Joined:
    Nov 8, 2009

    Nov 8, 2009
    19,889
    6,121
    1,413
    District of Columbia
    Welcome to the forums, Tete!
    You may be out of luck. Their website lists it as shipping with 4.1, have you tried contacting them?
    With the amount of RAM and processor, I'd be concerned even trying to run Jelly Bean.
     
    Tete_360, funkylogik and argedion like this.
  3. argedion

    argedion The TechnoFrog
    Rank:
    None
    Points:
    953
    Posts:
    6,360
    Joined:
    Jun 20, 2011

    Jun 20, 2011
    6,360
    6,294
    953
    The Infernal Swamp
    Network Connection Failed does not mean that its on your end it could be the carriers server connection that is failing.
     
    Tete_360 and funkylogik like this.
  4. funkylogik

    funkylogik share the love peeps ;)
    Rank:
    None
    Points:
    1,443
    Posts:
    21,404
    Joined:
    Sep 15, 2011

    Sep 15, 2011
    21,404
    7,248
    1,443
    Male
    monkey
    Paisley, Scotland, Western Europe
    Welcme to the community.
    Theyve probably just switched their update servers off tbh :(
    If the manufacturer has stopped supporting it then your only hope is that someone is building custom roms for it
     
    Tete_360 likes this.
  5. Thom

    Thom  
    VIP Member
    Rank:
    None
    Points:
    1,618
    Posts:
    12,114
    Joined:
    Feb 16, 2011

    Feb 16, 2011
    12,114
    5,021
    1,618
    Male
    Software Developer
    Keene, NH USA
    I moved this thread from Android Lounge to the forum for discussing phones taht don;t have a dedicated forum. Perhaps other users of this phone will find you here.

    ... Thom
     
  6. Tete_360

    Tete_360 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Dec 21, 2013

    Dec 21, 2013
    3
    0
    5
    Male
    SA
    Hello again, and thanks for each one of you who replied and tried to help me on my topic, i think i found a way to update it, by downloading it's updated firmware and install it, this is the link where i downloaded the firmware: Download_Xtouch | touch the world, I've downloaded X405 (with "C" near IMEI lable) firmware, which is v4.1.2, I've followed the instructions of the installation and used the tools provided with the firmware, but it didn't install successfully as it should ( i can record a video of this and upload it if needed ), So if you know any way to install it with an alternate working method, I'd be so glad and thankful.
     
  7. Tete_360

    Tete_360 Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Dec 21, 2013

    Dec 21, 2013
    3
    0
    5
    Male
    SA
    Bump,

    Hello?, anyone?.
     
  8. YazanAlHabal

    YazanAlHabal Member
    Rank:
    None
    Points:
    56
    Posts:
    91
    Joined:
    Mar 9, 2015

    Mar 9, 2015
    91
    4
    56
    Male
    Welcome Tete_360 to Android Forums!

    I would like you to have your Computer, USB Plug, not OTG, and Xtouch phone.

    If you would like to flash it via PhoenixSuit (A convinced flash firmware tool) or Live suit (A normal), Then download the flash firmware: http://pan.baidu.com/s/1nt0q7Lv and http://pan.baidu.com/s/1c0GOnc8

    Older: http://pan.baidu.com/s/1qWDHFQW

    Then I would like you to have the PhoenixSuit or Livesuit installed on your PC, I am not sure whether the older version or newer version of flash.zip have Android 5.

    This problem that you have faced is the poor network signal or Google can't reach it.

    You open PhoenixSuit, enable USB debugging, in Developers tab after you have clicked the Build number 7 times on About phone.

    You plug your USB to your computer that recognizes it, then put the jack of charger inside the charging port, then PhoenixSuit recognizes it.

    You click Browse, then navigate to your downloaded ROM for Xtouch device, and press the volume down and holding it, then press the power button 15 times after you shutoff your tablet, then you should have prompted that you have to format or not, Maybe click Yes and your data would be wiped, putting the new OS into your phone.

    If formatting doesn't prompt, turn on your phone then wait for few minutes, to boot, then click and hold the volume down button, then press the power button 15 times as your screen is not turning on.

    After your ROM have been succeeded, you must restart your device, then your OS have been updated.

    How to download from pan.baidu:

    [​IMG]

    This tutorial shows you how to download the file.

    Glad your OS should not bootlooped.

    Cheers, Yazan .
     

Share This Page

Loading...