1. Are you ready for the Galaxy S20? Here is everything we know so far!

Problem with USB connection

Discussion in 'Android Devices' started by ChunkyMunky, Apr 19, 2012.

  1. ChunkyMunky

    ChunkyMunky Newbie
    Thread Starter

    I've tried connecting my phone (to update via Kies to 2.3.5) via USB, but it won't connect at all, and both my Mac and my friends PC don't recognise the phone. I can connect wirelessly but I can't update so this isn't useful.

    Do I need a special cable to connect to USB? (I'm using my friends Blackberry cable, just a normal USB to Micro USB. I've used various Micro USB to USB cables, and no change)

    I couldn't find any drivers on the Samsung support site, just the Kies software. I downloaded this version and it still won't connect.

    I've tried using a toothbrush and a cotton bud to clean the Micro USB, the phone acted differently (went to a different lock screen with weather etc on it, and kept changing between MTP initialised to scanning sd card and back)

    Not using USB debugging will say it's connected in MTP mode, but it doesn't show anything on my computer (and just charges). Connecting via USB debugging mode doesn't do anything on my phone (doesn't give me that drag down option to connect via USB you're meant to get), but just charges.

    Apologies for the long post, I'm at my wits end.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. mustfly

    mustfly Lurker

    I'm having the exact same issue. Problem is, just a couple of weeks ago, I can clearly remember the last time I was able to obtain a USB connection, complete with the little Android bot holding up his left USB hand...and then connecting. My S2's memory always popped right up on my Mac desktop like any other USB storage device. Now it when I go to settings, USB utilities it first tells me to plug in the USB cable, then it tells me it can't connect BECAUSE the USB cable is plugged in, and so on. I gave up, but previously it was a breeze. Don't know what to think about this...haven't changed anything on my phone, as it's set up just the way I want it. Even if I try and go through Kies, Kies, like my Mac doesn't 'see' my phone. Very frustrating. Has some kind of OTA update changed the USB accessibility? Is this perhaps some type of prep for ICS OTA upgrade. I will wait for an answer to YOUR query, and I will by default get my own question answered. :mad:
     

Samsung Galaxy S2 Forum

The Samsung Galaxy S2 release date was April 2011. Features and Specs include a 4.3" inch screen, 8MP camera, 1GB RAM, Exynos 4210 Dual processor, and 1650mAh battery.

April 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...