1. Are you ready for the Galaxy S20? Here is everything we know so far!

Problem with your forums method to root my Samsung Epic G

Discussion in 'Android Devices' started by ferrel, May 25, 2011.

  1. ferrel

    ferrel Newbie
    Thread Starter

    I've tried your forum recommended method for rooting my phone. I use a Macbook Pro, not a Windows PC (I have one at work, but I'm not the admin, and it's none of their business anyway).

    Downloaded the files to a directory on my mac, extracted what needed to be extracted. Ended up with one executable for drivers, called Samsung_Mobile_USB_Driver_V1.3.800.0.msi,
    and another directory with an executable for more drivers, called USB Drivers, and a directory for your root method, called one.click.root.exploitv2.5.5. The file run.sh was already executable for the owner, but I did chmod +x run.sh just for the record.

    None of the driver executables will run on my mac. There's no program that I have that will open them. Not knowing what else to do, I ran the root method just to see what would happen. Below is the output to a
    terminal:

    dr-general-1-125:eek:ne.click.root.exploitv2.5.5 hughbowen$ ./run.sh
    Original one click made by joeykrim and one click installer made by noobnl and firon
    busybox by skeeterslint
    Press any key to continue...
    Starting adb server
    ./run.sh: line 23: adb: command not found
    ./run.sh: line 26: adb: command not found
    ./run.sh: line 33: adb: command not found
    ./run.sh: line 35: adb: command not found
    Phone is not connected. Press any key to continue.\n

    I need help with this. I previously tried to use Z4root, another so-called
    fool-proof method to root, and it didn't work. I posted a query to the Samsung Epic G forum earlier today, on that but when I look for it, I can't find it. I need this to use the app Copy Paste It, which requires root. I can't believe Android doesn't have this built into it.
    Help please!
    Best, Ferrel
     



    1. Download the Forums for Android™ app!


      Download

       
  2. icecold

    icecold Android Enthusiast

  3. ferrel

    ferrel Newbie
    Thread Starter

    I followed the instructions, etc. Ran it. Here's the final output.

    GingerBreak

    Not sure what happened here. Either the exploit failed or the
    reboot failed. Please reboot manually and see if you have
    superuser.

    I rebooted (battery out - in). No superuser.
     
  4. ZiggSVO

    ZiggSVO Well-Known Member


    Only thing I can suggest is trying it again...Tschofield7 has some great How to's on here that will walk you through it step by step
    His link is in my Sig and he has a video for rooting without a computer
     

Samsung Epic 4G Forum

The Samsung Epic 4G release date was September 2010. Features and Specs include a 4.0" inch screen, 5MP camera, 512GB RAM, Hummingbird processor, and 1500mAh battery.

September 2010
Release Date
0
Reviews
Loading...

Share This Page

Loading...