1. Check out our companion app, Forums for Android! Download from Google Play

Root problems installing busybox , terminal emulator......

Discussion in 'Android Devices' started by MozyMoe, Jan 2, 2010.

  1. MozyMoe

    MozyMoe Active Member
    Thread Starter

    Dec 2, 2009

    i am expanding my horizons with modding the behold 2, i have followed directions to a tee and still cannot get busybox installed,

    i followed instructions from this website -->> AllDroid.org - View topic - [Script] BusyBox works on Behold 2 V1.0 Updated 12/20 -fixed

    i have root and followed all the instructions but i keep getting an error "adb server is out of date..killing.... " ??

    what does that mean ?

    i put the busybox file into c:\Androisdk\tools and then ran the setup... but no luck, i DO have root also.

    any tips ?
    i have busybox version 1.0 , i found version 1.15 too but i cant seem to get it working either with that. help.


  2. Mastermind278

    Mastermind278 Well-Known Member

    If you use the ADB in your androidsdk/tools it should work. I was getting the same error using the ADB from the Busybox file. Alternatively if it isn't working, copy the ADB from the SDK (the one you get from google) and then paste and replace the adb in the folder with the busybox script, and it will work.

    http://www.megaupload.com/?d=W4X9IZUD << I re-zipped the original Busybox script from alldroid and replaced the ADB with the newest one from my SDK. It worked for me...
  3. MozyMoe

    MozyMoe Active Member
    Thread Starter

    Dec 2, 2009
    ok , so i got it to stop saying that the adb server is out of date...

    now this is where i am at.

    i press option 1 to install and it sez:
    pushing busybox to /sdcard
    1211 KB/s (1745016 bytes in 1.406s)
    Push complete
    Pushing busyhold script to phone
    5 KB/s (532 bytes in 0.093s)
    push complete
    dont forget to follow the instructions above,make sure u su first
    $ su
    # sh /data/local/bb2.sh <<-----------should be in caps like -->> BB2.sh

    ********UPDATE = i figured it out, i had lower caps when i entered BB2.sh. i wuz entering it bb2.sh make note

    *****UPDATE # 2 = if you get an error saying that your adb server is out of date then just replace the adb file that came in the busybox folder with a copy of the one in the androidsdk. thats how i did it . peace people.

    Thanx Mastermind.

Share This Page