1. Check out our companion app, Forums for Android! Download from Google Play

Root Problems rebooting after 2.2 install

Discussion in 'Android Devices' started by moldymonte, Aug 21, 2010.

  1. moldymonte

    moldymonte Member
    Thread Starter
    6

    Aug 14, 2010
    6
    1
    6
    I got froyo installed fine but when i reboot my phone it gets stuck @ the motorola logo and does not load up the rest of the way but if i pull the battery and try again it starts up fine anybody else having this problem or know how to fix it thanks
     

    Advertisement

  2. sodaboy581

    sodaboy581 Well-Known Member
    38

    May 8, 2010
    105
    18
    38
    You probably attempted a edit of a system file and failed it. You could try wiping your cache and doing factory reset. (Turn off phone, hold power+home and select both options...)

    If that doesn't work, you're going to have to start over as I'm assuming you didn't install the Droid X Bootstrapper and do a Nandroid backup.

    Go here: http://androidforums.com/all-things...leased-now-you-can-unbrick-5.html#post1419764

    Enjoy!
     
  3. xdanvitox

    xdanvitox New Member
    6

    Jul 17, 2010
    3
    1
    6
    nah i have the same problem and i did install teenfaces black taskbar for 2.2 but this was happening before that. i can still boot up but i have to let it sit at the M logo for a moment after a power on and off or terminal reboot and then do a battery pull..
     
  4. ECFfighter7232

    ECFfighter7232 Well-Known Member
    163

    Jul 21, 2010
    1,493
    336
    163
    Maryland
    yeah I ran into the same problem last night. I did a reboot and it stuck on M logo... i was a little worried at first so I gave it like 10 minutes then pulled the battery, it booted up fine after that. Im worried to try a reboot again... So, I wont reboot unless I have to.

    Hey, do you have a link to where you got the black bar for 2.2 from? I've been looking to get it back. I had fab's from the nextheme and loved it.
     
  5. banshee2008

    banshee2008 Active Member
    16

    May 29, 2010
    25
    1
    16
    This happened to me as well. Battery pull consistently allowed boot. May be coincidence, but it fixed itself after I downloaded koush's latest bootstrap and I granted out root access.
     
  6. xdanvitox

    xdanvitox New Member
    6

    Jul 17, 2010
    3
    1
    6
    it's teenfaces' Froyo 2.2 Dark Gray StatusBar - xda-developers

    did you actually install the bootstrap again or just the apk? and can you still boot into recovery after 2.2 is installed? I'm scared to try haha
     
    moondrius likes this.
  7. banshee2008

    banshee2008 Active Member
    16

    May 29, 2010
    25
    1
    16
    Just the apk. And yes I can still get into recovery.
     
  8. ECFfighter7232

    ECFfighter7232 Well-Known Member
    163

    Jul 21, 2010
    1,493
    336
    163
    Maryland
    Ok, so I tried another "soft reboot" (power off then power back on) and got stuck on the M logo again... Tried a battery pull, no help. Still stuck on the M... So I had to pull the battery again, then turn on holding power and home buttons. Then clicked on the reboot phone option. That lets me boot up right. Anyone have an idea of what may be wrong?
    And thanks for the link to the black status bar!
     
  9. ECFfighter7232

    ECFfighter7232 Well-Known Member
    163

    Jul 21, 2010
    1,493
    336
    163
    Maryland
    Further information so maybe I can get some help... I get this on the bottom of the recovery screen when I reboot it into recover

    E: Cant Open /cache/recovery/command

    Anyone have any clues for me?
     
  10. D13

    D13 Well-Known Member
    143

    May 28, 2010
    2,088
    234
    143
    Elkridge, Maryland
    does it affect what you are able to do, is there something that you can't do
     
  11. ECFfighter7232

    ECFfighter7232 Well-Known Member
    163

    Jul 21, 2010
    1,493
    336
    163
    Maryland
    yeah. I cant just turn my phone off then back on. I have to start my phone by pressing the home and power button, then click on reboot phone.

    If I dont start it this way I just get stuck on the moto logo on the boot up
     
  12. D13

    D13 Well-Known Member
    143

    May 28, 2010
    2,088
    234
    143
    Elkridge, Maryland
    well unless you want to do a fresh install of 2.2, I would just say wait it out until custom roms or vanilla 2.2 come out and see what happens then. Because that will give you a new system
     
  13. ECFfighter7232

    ECFfighter7232 Well-Known Member
    163

    Jul 21, 2010
    1,493
    336
    163
    Maryland
    ok... was there something I did wrong with the install then? I'm just trying to find out what this issue is and what caused it thats all... If theres a fix, great, if not, well that kinda blows but atleast my phone still works ya know? I wasnt planning on installing any custom roms or vanilla 2.2, I only installed this to get the version of 2.2 running before the offical release from verizon comes (cause im impatient)
     
  14. D13

    D13 Well-Known Member
    143

    May 28, 2010
    2,088
    234
    143
    Elkridge, Maryland
    come on how could you not want custom roms and kernels. I don't think you did anything wrong though.
     
  15. ECFfighter7232

    ECFfighter7232 Well-Known Member
    163

    Jul 21, 2010
    1,493
    336
    163
    Maryland
    lol I know, I may change my mind... hell i said I wasnt gonna root my phone when I first got it either... lol
     
  16. D13

    D13 Well-Known Member
    143

    May 28, 2010
    2,088
    234
    143
    Elkridge, Maryland
    you cannot resist:p
     
  17. ECFfighter7232

    ECFfighter7232 Well-Known Member
    163

    Jul 21, 2010
    1,493
    336
    163
    Maryland
    friggin dark side and their cookies gets me every damn time! lol
     
  18. SacNutz

    SacNutz Well-Known Member
    16

    Dec 28, 2009
    81
    6
    16
    I had the same problem. I didn't edit any files. I also got the E: Cant Open /cache/recovery/command

    Looks like it restarts fine sometimes. I had to pull the battery twice, but since then it does fine.

    It seems that I'm experiencing EVERY single bug with 2.2 which sucks. With my old Droid I used to be the guy that had no problems with anything.
     
  19. Airmaxx23

    Airmaxx23 Well-Known Member
    313

    Jun 21, 2010
    3,142
    1,039
    313
    I had the same problem so I decided to flash it again, going through the routine of getting stuck in the boot loop, pulling the battery, doing the factory reset, and then rebooting into 2.1. Rather than install 2.2 at that point I flashed it a second time, which was completed (100% - Done) and it booted directly into 2.1. Since installing 2.2 I have yet to have any bugs pop up, this could be a coincidence but who knows.
     
  20. ECFfighter7232

    ECFfighter7232 Well-Known Member
    163

    Jul 21, 2010
    1,493
    336
    163
    Maryland
    I should also note that I had kouchs bootstrapper installed and used the link I was givin to get his 2.2 update that was rooted already (I was also already rooted)

    Yeah Im thinking about flashing back to 2.1 but I think I'm gonna need a detailed step by step on how to do that... I'm a little worried on trying it by myself. Would that get rid of bootstrapper too?
     
  21. GTPprix

    GTPprix Well-Known Member
    36

    Apr 27, 2010
    62
    1
    36
    Macomb, MI
    I was able to reboot past that by using adb reboot bootloader however that had to be done EACH time. I went back to SBF, honestly the leak is jacked.
     
  22. Travisimo

    Travisimo Well-Known Member
    53

    Jul 7, 2010
    455
    88
    53
    USA
    I got the "E: Can't open /cache/recovery/command" error message as the first line when applying the update.zip file when upgrading from 2.1 to 2.2. However, I never have had any problems booting the phone and I've been using the 2.2 update for a couple of days now without issue (except for the force close when viewing the battery icon info). So I'm not sure if that error message is the directly related to your boot problem.
     
  23. zeldalink

    zeldalink New Member
    5

    Aug 25, 2010
    2
    0
    5
    I read the forum and I'm having the same problems. I'm running a DX 2.2 rooted. Everything works great except for rebooting. It gets stuck at the "M" every time. A battery pull fixes this and it boots up fine. I also get the "E: Can't open /cache/recovery/command" not really too concerned about this but would love to getting it rebooting without a battery pull. reading the forum I didn't see any fixes for this or did I miss something?
     

Share This Page

Loading...