1. Check out our companion app, Forums for Android! Download from Google Play

Support Problems turning on Nexus 7 after update

Discussion in 'Android Devices' started by nexusnewbie177, Oct 20, 2012.

  1. nexusnewbie177

    Thread Starter

    Oct 20, 2012
    London, England
    I am on my second Nexus 7 in 4 weeks. The first one worked fine until the automatic update, then it would not turn on. I took it back to Comet. They replaced it with a new one, after showing me how to reboot it holding down all the buttons. The second one updated about 5 hours after I bought it, and now that too sometimes will not switch on and I have to press all the buttons, then the power button.

    Has anybody else encountered this problem?

    I also am having problems screaming videos from a USB stick with NMI. I have tried various video players but playback and audio is very fragmented. Any ideas?


  2. pompey7474

    pompey7474 Well-Known Member

    Aug 20, 2010
    team leader
    Hi yes I had same problem with my nexus 7 you can hold just the power button down for 30 seconds to turn on nexus if having problems turning it on you don't need to reboot it every time .but best to take it back I had to ,my new one has been fine by the way.
    nexusnewbie177 likes this.
  3. Esha77

    Esha77 Member

    Nov 20, 2012
    Also started having the same problems. Although when it happened, it was turning on ok if holding down for 30 seconds, but rather tedious after a while I'm sure you will agree. I got to thinking :thinking: that for me anyway, the problem seems to mainly occure after a charge which indicated to me that maybe there was a link with the usb port, so this is what I did and (touch wood) the problem has not happened again:

    1. Click on 'Settings'
    2. Scroll down and click on 'about tablet'
    3. Click on 'Developer' *
    4. Scroll down to 'USB Debugging' and tick the box to enable it.

    Since doing the above I have not had a re-occurance of the problem.

    * Note that sometimes 'Developer' cannot be seen, if this is the case do the following:

    1. Click on 'Settings'
    2. Scroll down and click on 'about tablet'
    3. Scroll down and tap on 'build number' several times in quick succession.
    4. Go back to previous page, and when you scroll down you should now see '{} Developer' click on this, scroll down and enable 'USB Debugging'

    Hope this helps you as it did me.

    Happy Xmas all! :)

Share This Page