1. Check out our companion app, Forums for Android! Download from Google Play

Support Problems Updating my X10i

Discussion in 'Android Devices' started by Gunnie, Sep 15, 2010.

  1. Gunnie

    Gunnie New Member
    Thread Starter

    Jun 8, 2010
    I bought an X10i a few months ago and I was installing PC Companion on my mothers PC when it told me there was an update to the firmware.
    When I came home on my own PC it told me I was up to date. I uninstalled companion and reinstalled it and was told of the update.
    Now here is my problem. When I try to update it goes through the first 2 steps and then tells me to unplug the USB cable from both the PC and Phone, make sure it is charged to 50%, turn off the phone for 5 seconds and plug it back into the PC and while holding the back button plug the USB cable into the phone. When i do this nothing happens the update just sits there.
    I've tried this with both PC companion and SEUS and then same thing happens on both.
    I've also tried updating from the phone but it says it's up to date.
    I'm in Ireland on O2 and my firmware is 1.6 and build is R1FA016.

    Any help would be appreciated


  2. rosered

    rosered Well-Known Member

    Jul 4, 2010
    My advice when this happens is to try a different PC/laptop. Not a great solution but for some reason it works.

    The other option is to use the repair option which pushes through new firmware but it is like a factory reset so you will lose data on your phone. You need to back you numbers up via sync or copy to SD card. If you have the Backup and Restore option which I'm not sure you will have due to your firmware number, obviously use that. You can reinstall any apps from the market after you have set your phone back up.

    Although at the moment as long as your phone is working Ok I might be tempted to leave it til the new firmware release coming out very soon.
  3. lavinius

    lavinius Active Member

    Sep 14, 2010
    i think you have to take the battery out if i remember correctly, i think i pull the battery out, put the cable in, hold the back button and put the battery in while i hold the back button .... windows installed some drivers then SEUS came up with something to release the back button and away it went

Share This Page