1. Are you ready for the Galaxy S20? Here is everything we know so far!

Problems updating SU binaries

Discussion in 'Android Devices' started by rkt739, Jan 5, 2013.

  1. rkt739

    rkt739 Lurker
    Thread Starter

    I recently got an HTC DNA, and decided to have a go at unlocking the bootloader and rooting the phone. Well, I think I managed to do that (the phone isn't even bricked or anything!). However, now that I have this SuperSU app that the Hasoon2000 All-In-One tool put on my phone, it says it has to update its binaries. Whenever I press Continue to let it do that, it just says "Installing, please wait" for about a second and then reboots. No error message, no "installation failed", just a reboot. But of course the installation did fail, because it does the exact same thing if I try to open SuperSU again. Any ideas?

  2. scotty85

    scotty85 Extreme Android User

    if you happen to be running the "write to system while booted" kernel,you can try updating supersu from the market. if youre on the stock kernel,that actually is prolly why superuser cannot update its binary.

    failing that,prolly the easiest thing to is just reflash superuser in recovery. download the most current version(v99 currently) from here: http://forum.xda-developers.com/showthread.php?t=1538053

    the dlownload link you want is labled CWM-SuperSU-v0.99.zip i dont want to link it directly,since it breaks when he updates the attachment.

    just download,put on pretend sd card(;)),boot to recovery,and wipe dalvik and cache,then flash :)
  3. rkt739

    rkt739 Lurker
    Thread Starter


    I did something rather like that and it fixed the problem.
    scotty85 likes this.
  4. n8rzzi

    n8rzzi Lurker

    What exactly did you do (rkt739)? I tried doing exactly what scotty85 said and it didn't work.
  5. scotty85

    scotty85 Extreme Android User

    Did you use the latest superSU? Was the recovery flash successful?

    We have used the superSU to root many stock roms,including the DNA,so there's no reason it wouldn't work. What troubles are you having?
  6. n8rzzi

    n8rzzi Lurker

    Well, I flashed cwm touch successfully and then i flashed a non-updated version of supersu. I have root, but there's some type of glitch in the binaries (I think).

    I tried downloading an updated supersu from the playstore and there was no change. Then I tried updating with the link and reflashing (after wiping the caches and still no luck)

    - Every time that I open supersu, it asks "The SU binary needs to be updated. Continue?". If I hit continue, it says "installing" briefly and then reboots the phone. (and if I open supersu again, it repeats) Same as rkt739
    scotty85 likes this.
  7. scotty85

    scotty85 Extreme Android User

    Was the recovery flash successful? I.e. were there any error messages?

    I have superuser v99 running on my stock one X,with no issues(android 4.1.1). If you're using v99 and are having what appears to be a succesful flash,you might try with twrp recovery,maybe there are still some bugs in cw.

    Other than that,you might try a kernel that let's you write to system when booted,as the binary should be able to update itself thenv:)

HTC Droid DNA Forum

The HTC Droid DNA release date was November 2012. Features and Specs include a 5.0" inch screen, 8MP camera, 2GB RAM, Snapdragon S4 Pro processor, and 2020mAh battery.

November 2012
Release Date

Share This Page