Problems with changing install location and some other


Hello to all, as I'm new here.

I have a Arnova 10d G3 tablet(not rooted) which has 4GB of built-in memory. It is divided into 2 partitions - one called System and the other by the default file explorer called Rom(2GB in size each) but e.g. Total Commander display it as SDCard thus naming the SDCard I use "SDCard(2)".

All the applications are installing to System partition, and I have tried to change the install location via Android SDK, but even though it seemed to work and when I type in pm get-install-location in Terminal Emulator it shows 2(external) the apps are still instaling onto System partition. What is more, I seem not to have the option to move my apps from internal memory to SD card - the button is not there at all.

The other problem I have is that I have tried to update tablet's software. I downloaded it from the official site and following the instruction I copied it to the internal memory. Then by the System Update option I was supposed to choose this software but it does not show up on the list. So I tried to copy it to the System(because when I plug in the tablet to the computer only external and this internal SD Cards show up), but I'm unable to do so. Total Commander tells me that there is no enough memory even though I have ove 700MBs of free space and the update weighs only 140MBs.

Is there any solution to this without rooting the tablet? I would like to keep my warranty if possible.


share the love peeps ;)
Im not sure about most of what youre askin sorry but to write to the system partition youll need root access im afraid :thumbup:


Thread starter
Sorry if I was not clear enough, English is not my native language. You have answered my second question, but the first one(writing it more clearly I hope) was: why, even though I have used Android SDK to change apps install location, all apps are still installing onto System partition, even though they should install to external SDCard with that change. But I guess, not having root rights is the main problem. Again, sorry for not being clear enough.