1. Are you ready for the Galaxy S20? Here is everything we know so far!

Problems with Encrypting SD Card

Discussion in 'Android Help' started by Android Question, Oct 26, 2014.

  1. Android Question

    Thread Starter

    Phone: Verizon Samsung Galaxy S4
    Android: 4.4.2
    SD Card: SAMSUNG Plus 32GB Micro SDHC Class 10 Flash Card Model MB-MPBGC/AM

    Problem: I cannot seem to encrypt my SD card. If I format the card and have 0 files on it, and then start the encryption process, it will either say "Encrypting SD card..." with no progress meter, or "Encrypting SD card: 0%". It will just stay at 0% forever.

    If I put files on the card and then start the encryption process, the progress meter will reach either 65% or 99%, and then be stuck there forever. I've left the phone on for 2 full days on my charger while it was at 99%, and it just remained stuck and never finished.

    For reference, I'm using "Settings > More > Security > Encrypt external SD card". I've tried factory resetting my phone, doesn't make a difference. The SD card works fine without encryption, both on the phone and in Windows. I've done a chkdsk on it and the card was fine. I've tried both FAT32 and exFAT filesystem, and I've also just formatted the card via the phone itself. Any help would be greatly appreciated.
     



    1. Download the Forums for Android™ app!


      Download

       
Loading...

Share This Page

Loading...