1. Are you ready for the Galaxy S20? Here is everything we know so far!

Problems with firefox

Discussion in 'Android Devices' started by kenboyles72, Apr 26, 2019.

  1. kenboyles72

    kenboyles72 Well-Known Member
    Thread Starter

    Ever since I had this phone, I think, firefox will not run on it. Is there something different about this phone that wont allow firefox to run? I have tried it on pure stock, lineageos and aokp and firefox just wont run, no matter what version I install.

    Edit:
    Here's a log for when i try and open the app.
    https://pastebin.com/u5CkqSzA
     


    #1 kenboyles72, Apr 26, 2019
    Last edited: Apr 26, 2019
  2. JAy3001

    JAy3001 Android Expert

    Contact Firefox on Twitter @FireFox as they are very responsive and should be able to assist.
     
  3. lvt

    lvt Android Expert

    Maybe Firefox is not compatible with your current ROM.

    Do other browsers like Chrome and Opera work fine?
     
  4. kenboyles72

    kenboyles72 Well-Known Member
    Thread Starter

    I have tried about 15 versions of firefox and none will run on this phone, any other browser works fine. Just don't understand why FF just won't run.
     
  5. svim

    svim Extreme Android User

    Just glancing through that log posting brings up some questions:
    -- There are several error messages pertaining to permissions issues, was the app installed using the Play Store or was it side-loaded using an APK?
    -- If the latter, where did you obtain the APKs that you've tried to use?
     
    ocnbrze likes this.
  6. kenboyles72

    kenboyles72 Well-Known Member
    Thread Starter

    Current version of FF installed via playstore

    The earlier version apk(s) that I side loaded came from https://firefox.en.uptodown.com/android/old

    The current installed rom, is AOKP 7.1.2 from this forum
     
  7. svim

    svim Extreme Android User

    Try installing the apk again, but before even starting the app up, use the 'Clear data' button to wipe any old config/settings files. Just wondering if there's some corrupt, old config file that's the cause behind those permissions errors.
     
    Dannydet likes this.
  8. kenboyles72

    kenboyles72 Well-Known Member
    Thread Starter

    Forgot about this thread. Anyways, I finally fixed my issues. It wasn't the app or the phone, but permissions. Got to looking at the permissions of Firefox and none of them were set for some reason. After turning on all the permissions, Firefox ran as normal. Thought I would update this, just in case someone else had the same issues.
     
    svim likes this.
  9. lvt

    lvt Android Expert

    Glad to hear you solved it.

    It could have been some issues with your custom ROM.
     
    racibennett likes this.

ZTE Zmax Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...

Share This Page

Loading...