1. Are you ready for the Galaxy S20? Here is everything we know so far!

Pulling android memory

Discussion in 'Android Help' started by mariyamjohn25, Mar 10, 2016.

  1. mariyamjohn25

    mariyamjohn25 Lurker
    Thread Starter

    I was following a tutorial video in youtube to pull the android RAM using LiME tool...I installed jdk ,android studio and LiME in my ubuntu...I used a command - sudo ./adb pull /proc/config.gz .but I am getting an error message remote object '/proc/config.gz' does not exist...
    how can I resolve the problem.please help me.
     


  2. svim

    svim Extreme Android User

    Try leaving out that ./ after sudo

    sudo adb pull /proc/config.gz
     
  3. scary alien

    scary alien not really so scary
    Moderator

    Hmm, the OP's syntax looks right (to me) if the adb utility is in the current (present working directory) and it sounds like it really is the /proc/config.gz file doesn't exist vs. an issue with invoking adb itself.

    @mariyamjohn25, can you try this instead if @svim's suggestion doesn't work:

    ubuntu$ sudo ./adb shell
    $ ls -l /proc/config.gz
    $ ls -l -d /proc/config*
    $ exit
    ubuntu$

    That should show/display for you if the config.gz file actually exists in your /proc folder on your device. At the very least, it should tell us more about what is going on.

    Note: the above won't actually pull the file from your device, but will simply verify if the config.gz file exists on your device or not.

    Post back with a copy and paste of the results of the above and let us know.

    Cheers!
     
    El Presidente and mariyamjohn25 like this.
  4. svim

    svim Extreme Android User

    I have to wonder if that's necessary. In order to make ./adb work that is completely dependent on being in same directory as the adb binary. As long as adb was previously installed properly (i.e. /usr/bin) its path should enable it to just be started with just the adb command (sans ./)
     
  5. scary alien

    scary alien not really so scary
    Moderator

    ^^^ Agreed :).

    I'm just going by the gist of the warning/message he reported that seems to indicate that adb successfully launched, but couldn't find the file to pull.

    I don't have access to my Linux PC at the moment to verify that this is what happens (i.e., bad adb file path vs. file not found, etc.), but I can try when I get home.
     
    svim likes this.
  6. mariyamjohn25

    mariyamjohn25 Lurker
    Thread Starter

    @scary alien It seems like there is no such file or directory.I have also tried the location /boot/config...but this also showed the same error.How will I find the Kernel configuration file location?
     
  7. svim

    svim Extreme Android User

    mariyamjohn25 and scary alien like this.
Loading...

Share This Page

Loading...