1. Are you ready for the Galaxy S20? Here is everything we know so far!

[Q] HELP 4.4.2 Update Error "/system/bin/debuggerd" has unexpected contents

Discussion in 'Android Devices' started by nurseric2012, Dec 30, 2013.

  1. nurseric2012

    nurseric2012 Lurker
    Thread Starter

    Hello guys. I'm new here and I hope you can help me with my update problem:

    I'm using ASUS Google Nexus 7 2012 rooted running Android 4.4 KitKat KRT16S

    the problem is when I update it default through OTA in the device itself, when i reboot it, it still not 4.4.2 but the system says I'm running the latest version of android.

    i tried manually using TWRP recovery but i get this error

    Updating partition details...
    Installing '/sdcard/!ReadyToFlash/Root_Files/kk.zip'...
    Checking for MD5 file...
    Skipping MD5 check: no MD5 file found.
    Verifying current system...
    "/system/bin/debuggerd" has unexpected contents.
    E:Error executing updater binary in zip '/sdcard/!ReadyToFlash/Root_Files/kk.zip
    Error flashing zip '/sdcard/!ReadyToFlash/Root_Files/kk.zip

    Note: !ReadyToFlash is the folder where the kk.zip which is the OTA file is located

    I hope somebody here can help me or give me a link of the right debuggerd file. Thanks you very much.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Mr. Lucky

    Mr. Lucky Android Expert

    That's normal - OTA does not work when when rooted. You'll need to restore /system/app back to stock state, unroot, and then it may work. The Pro version of SuperSU has an option for "OTA survival mode," but it's not guaranteed to work with all devices (and I'm not willing to be the guinea pig). :D
     
  3. John Bean

    John Bean Happy Wanderer

    That's not strictly true - my rooted N7 updated perfectly, losing root in the process of course. It was absolutely unaltered stock, just rooted to allow the use of some root-only apps I use.

    In my experience it's not the rooting that breaks OTA's but the various other meddlings that generally follow ;-)

    Edit: and I forgot to add that the use of a non-standard recovery often breaks the OTA too, so as soon as TWRP was mentioned I didn't look any further for the prime suspect.
     
    funkylogik likes this.
Loading...

Share This Page

Loading...