1. Check out our companion app, Forums for Android! Download from Google Play

[Q] JXD S601 Internal Memory unmounted every time the device starts problem.

Discussion in 'Android Lounge' started by MrJohn, Mar 18, 2012.

  1. MrJohn

    MrJohn New Member
    Thread Starter

    Mar 18, 2012

    I've recently bought a JXD S601 device.

    It worked properly for a few days while I was adding some games and apps for it.

    CPU HARDWARE: AMLOGIC MESON3 8726M SKT SH AML8726-M3 REF F 02 (specific board in use) CPU MODEL: ARM v7 (VFPv3, NEON) CPU FREQUENCY 300.0 ~ 600.0 MHz Display: 480-272px GPU ARM Mali-400 MP 1GB NAND 397.5 MB RAM, ~220 MB Available 2GB internal Android 2.3.4 build: MID_PSP.wifi.20120105 kernel: 2.6.34

    That is what benchmark showed while it was working. Both "1GB" of a faster internal NAND, and some 2 GB of additional internal memory. When the device is plugged into the USB, I used to be able to access the device memory + my micro SD card.

    Now, once I start Android, I get a notice "Internal storage safe to remove. Internal storage safely stopped.". If I try to start File Manager, for example, it only shows "SD Card" which is my Micro SD card. If I take out the micro sd, it only shows "SD Card" but the folder is completely empty.

    When it was working normally it showed:
    Internal Memory
    SD Card

    As folder structure. Now the first is missing.

    If I go to android settings > storage >
    It shows the SD card properly if I put one in.

    It shows "Internal NAND flash"

    Total space
    Available space
    Erase internal NAND flash (tried this, it did not make any changes at all, probably because the NAND flash is unmounted and there's no option to mount it back).

    Internal storage
    Available space

    This internal storage is not accessible except with ADB software. But I tried this tutorial: (can't post links so please Google "Missing internal flash memory and SD card does not mount" and check the first result on android.stackexchange site) and it did not solve the problem.

    "mkdosfs -F 32 /dev/block/vold/31:8/"

    I don't have 31:8 but some 200:32 and etc, I tried to use the command for any (all) of the 4, but all returned an error in ADB: "This is not a folder".

    The manufacturer, JXD, has given an update.

    This would be useful, after flashing the system I could again have access to the normal function, as whatever the error is, 99% the error is in system, possibly corrupted after some program (I'm new to the Android systems, not sure).

    I downloaded the update from the JXD site > Download section (filename S601 0229en.rar)

    But it is missing some files. All I have is the 2 docx documents, update.zip and uImage_recovery. The tutorial (upgrade method docx document) shows clearly that I need to have factory update aml, uboot aml, and uImage files as well. I don't have them in my update so I can't follow the instructions and put them on SD Card.

    I tried to follow the instruction anyways, but it says that those files are missing and cannot proceed.

    I've contacted the manufacturer by E-mail and asked them to send me those files, but I'm not sure if I will ever get a reply.

    So now if I plugin the device to the computer without SD card, there are 2 drives, but I can't access any of them. With SD card, the first drive is my SD card and I can only access it, but not the internal storage.

    Any helpful answers would be utmost appreciated. Thanks for reading the thread.


  2. justXelliot

    justXelliot New Member

    May 24, 2012
    Did you flash Skelrom to it? If so have you tried reflashing it? (put skelrom on micro sd and start jxd in recovery)
    I just bought one myself.
    The path for mine is: /sdcard for sdcard and /mnt/flash for the internal memory. There is also /mnt/sdcard which shows the same as /sdcard
    All I can recommend is flash skelrom and if that doesn't work, reflash the stock rom (if that is available anywhere, I haven't looked)
  3. justXelliot

    justXelliot New Member

    May 24, 2012
    Skelrom: http :// forum.openhandhelds.net/index.php/topic,59.0.html

Share This Page