1. Check out our app, Forums for Android! Download and leave feedback here!

Root [Q]Recover contacts from a 'bricked' galaxy s

Discussion in 'Android Devices' started by Loba, Oct 20, 2010.

  1. Loba

    Loba Member
    Thread Starter
    6

    Jun 5, 2010
    6
    1
    6
    Hi everyone,

    Thanks for reading this, I'm facing a problem here, situation as below:

    I was previously running one click lag fix, then I realised I was running out of space on the 2GB partition, so I decided to uninstall OCLF so as to reinstall it to reduce the EXT2 partition space. Freed up to 1.2gb of space in the 2GB partition and reinstall OCLF partition to 880MB, phone reboots and tada, stuck in black screen after boot animation for 45 mins, took out battery and it is still the same, it's semibricked since I could still go to recovery mode and download mode but that is not good enough for me since...

    1) I want to recover my contacts
    2) There are some calendar entries within the local calendar which I need to refer to.
    3) My memos!!!

    Phone is international i9000, running DXJF4, rooted using OCLF. This is what I did so far

    Got adb running on desktop and laptop, successfully connect to phone(Adb devices shows it connected to ADB in recovery mode).

    Objective: retrieve data
    1) Try to go into adb shell to pull EVERYTHING(as below) but since I didn't have root permissions, it gave me a message that remote object doesn't exist. However, in adb shell with ls command, I can view all the directories...

    (Contacts = /data/data/com.android.providers.contacts/databases/contacts.db
    SMS = /data/data/com.android.providers.telephony/databases/mmssms.db
    Bookmarks = /data/data/com.android.browser/databases/browser.db

    adb pull /data/data/com.android.providers.contacts/databases/contacts.db d:\contacts.db)

    FAIL

    New Objective: root the phone in recovery mode
    2)tried adb root and got the "adbd cannot run as root in production builds"
    went into adb shell and typed su but permission denied.

    FAILx2

    3)Ok, tried superoneclick which is supposed to be able to root in recovery mode, got stuck at waiting for device....
    (reason given by superoneclick programmer was that it's either usb port or usb cable fault, since I tried both desktop and laptop and I don't have a spare usb cable...I can't say for sure)

    FAILx3

    I am out of ideas and searches....I really need help, I should be able to just load a rom using odin and reflash it(if nothing goes wrong!) but I seriously do not want to lose the contacts and data etc....
     

    Advertisement

  2. shaahinjjj

    shaahinjjj Well-Known Member
    36

    Aug 12, 2010
    103
    7
    36
    I think on default settings, android always keeps syncing your contacts and calendar with your gmail. Did you check to see if it's in there? at least that's what my desire did and because of this i could recover my contacts after the phone was water damaged. I got my Galaxy S semibricked too but it was fixed with just a total wiping from the download mode. good luck.
     
  3. big_mike

    big_mike Well-Known Member
    88

    Jul 21, 2010
    520
    39
    88
    Male
    Head Chef
    Worcester, UK
    they should be on your gmail account :D

    hope they are...
     
  4. Loba

    Loba Member
    Thread Starter
    6

    Jun 5, 2010
    6
    1
    6
    nope not there, I off the sync, I synced with my school's exchange server but that manual sync was a while back.

    I did a firmware flash and all is good just contacts smses lost.
     
  5. snapper.fishes

    snapper.fishes Well-Known Member
    163

    Jul 13, 2010
    2,279
    263
    163
    Afraid you did the only possible thing in the end. Flashing, that is.
     

Share This Page

Loading...