1. Are you ready for the Galaxy S20? Here is everything we know so far!

Support [Q] Unable to upgrade my samsung galaxy s2x telus to jelly bean 4.1.2

Discussion in 'Android Devices' started by manig, Jul 24, 2013.

  1. manig

    manig Lurker
    Thread Starter

    Hey

    I am trying to update my samsung galaxy s2x telus to jelly bean 4.1.2 through kies.

    I get this weird message
    Your device's current firmware version is not supported to update firmware via Kies
    Current firmware version: PDA:LE4 / PHONE:MC4 / CSC:LE4 (TLS)

    Previously, I already updated to Jelly bean 4.1.2 through kies, due to some issues i restored my backup(version 4.0.3)

    Is there any workaround for this issue.

    Thanks in advance.
     

    Advertisement

  2. Atma

    Atma Extreme Android User

Loading...

Share This Page

Loading...