1. Are you ready for the Galaxy S20? Here is everything we know so far!

Question regarding APKs vs flashable ZIPs

Discussion in 'Android Devices' started by takirb, May 24, 2011.

  1. takirb

    takirb Android Enthusiast
    Thread Starter

    I'm trying to install the latest MIUI camera on King's GB RLS4. I've extracted the miuicamera.apk from the ROM and tried installing it like normal, but get "application not installed". The current MIUI camera i'm using was hosted as a flashable zip originally. Do i need to compile the latest miuicamera.apk into a zip for it to work correctly, or is there more involved that i'm unaware of? What's the difference in the installation being from a flashed zip vs apk installer?

    I'm trying the same for the miuimusic.apk and get the same installation error, whereas i believe the current MIUI music player i have was indeed an apk vs zip.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. evomattnc

    evomattnc Android Expert

    OK shortest explanation I can muster...

    A flashable zip is just a script that tells recovery where to put a certain file and to remove what is already there. Recovery is like a special small OS made to do such things like mv, cp, rm etc. I only flash a zip if there is more than like 2 things being "installed". Installed in parenthesis because thats not technically what is going on dont let me run away here, :reeling back in:

    Some things cannot be side loaded, which is where you click install and it goes. SOmethings need to be pushed. It could also be that it isnt signed, the system will not install an apk that isnt signed, if you pulled it out of another rom thats not the case just a side note...

    A more direct answer is that sometime you have to push something where it needs to go, you can do this numerous ways through root explorers, terminal emulator, adb, make a zip with an update script (ah yes flashing a zip just pushes a file where it needs to be and sets permissions, usually 775) etc.

    Anyhow take your apk and push it (copy, paste, change permissions) to either system/app or data/app depending on what it is and if you are replacing the system app. Then set permission rw-r-r and reboot. If you are pushing an app to data/app (a non system/app) then you can usually just push it there change permissions and select install. (you can technically make anything a system app if you want it to be saved in system and backed up, restored, or wiped when system is edited)
     
    ocnbrze, ardchoille and takirb like this.
  3. evomattnc

    evomattnc Android Expert

    if that isnt clear ask away and i will try and clarify...

    I would in the case of MUIU music push it to data/app, set permission rw-r-r and select install, it should work after that, if it doesnt install try a reboot. If it still doesnt work you can push it to system/app and try there. I dont think you need to replace your current music.apk unless of course you want to...if im "replacing" a system apk i always just rename the original to whatevertheappis.bak

    Edit: You are using MUIU camera, push to system/app, rename original camera.bak, name new camera.apk, set permissions, reboot.
     
    takirb likes this.
  4. takirb

    takirb Android Enthusiast
    Thread Starter

    Dang. Changed old file to .bak extension, copied new file over and changed permissions to rw-r-r, but after the reboot it just FC's when i try to open it. I'm wondering if it's a compability issue since the new MIUI camera was just released recently. I'll give it a bit and see if anyone else has any luck, the MIUI camera seems to be a decently popular alternative to the CM7/AOSP one.
     
  5. evomattnc

    evomattnc Android Expert

    I saw someone else having an issue with the MIUI camera also.

    Doesnt the MIUI camera have associated lib files you will need??
     
  6. evomattnc

    evomattnc Android Expert

    try the older version of the camera i know people use it...
     
  7. evomattnc

    evomattnc Android Expert

    from looking at my lib files for my camera there are numerous lib camera.so files that you probably need to grab out of MIUI for that to run...

    I have 5 I think you will need to bring with your camera

    libcamera.so
    libcamera_client.so
    libcameraservice.so
    liboemcamera.so
    lib0mxVidEnc.so

    Basically anything with camera or video in it. Push them to system/lib and set permission to rw-r-r
     
  8. takirb

    takirb Android Enthusiast
    Thread Starter

    I've been using the older version (version 10) successfully, but the latest release is the only one with FFC capability. I hate having to have 2 seperate cams (well, 3 counting Vignette). When i try to launch either the stock cam or the MIUI camera, my phone just opens either one up at random. Sometimes I have to open the camera twice to get the correct application. The MIUI camera is pretty nice, and having the FFC option in it would cake on top.
     
  9. takirb

    takirb Android Enthusiast
    Thread Starter

    Will those overwrite the current camera lib files for the default AOSP camera or will it hurt to rename the MIUI lib files prior to the push?
     
  10. evomattnc

    evomattnc Android Expert

    It shouldnt open them both at random...apps of same name are not allowed in the system therefore there should only be on app in system associated with camera, is one camera named camera.apk in system and the other named camera.apk in data/app? That may be what causes that issue...

    Anyhow read the post above about the lib files and try that out
     
  11. evomattnc

    evomattnc Android Expert

    Yeah just rename orignals .bak as usual, im not even sure if the MIUI camera has lib files of the same name. I dont use it but its certainly a good place to look.

    .bak just makes it a backup file that wont be read it looks like a text file, if you want stuff to disappear but arent sure you want it to disappear forever .bak is full proof
     
  12. takirb

    takirb Android Enthusiast
    Thread Starter

    Odd, I renamed the old lib files with .bak extension, moved the MIUI lib files over with rw-r-r permissions, rebooted, still getting force close but the AOSP camera works just fine still. Shouldn't the overwrite of the original camera lib files have stopped the AOSP camera from working?

    MIUI did use the same lib file names...
     
  13. takirb

    takirb Android Enthusiast
    Thread Starter

    I'm also noticing when i change the permissions for the new miuicamera.apk, it's not keeping the changes. When i check permissions again all permission boxes are staying checked. I'm using SuperManager for file exploring, with root permissions and i'm mounted as RW
     
  14. evomattnc

    evomattnc Android Expert

    have you tried setting it in terminal?
     
  15. takirb

    takirb Android Enthusiast
    Thread Starter

    they're both in system/app - camera.apk and miuicamera.apk. Nothing referring to either camera is in data/app. I think it's odd i replaced the camera lib files, and the stock camera as well as the older MIUI camera still work fine without having to re-replace the lib files. I simply deleted the newest miuicamera.apk, and just renamed the old MIUI application from .bak to .apk. Back to it's old functionality again. I'm guessing the lib files didn't change much if any between the versions.
     
  16. evomattnc

    evomattnc Android Expert

    To set permission using terminal, should stick, sorry rw-r-r is a 644

    su
    mount -o remount,rw /dev/null /system
    chmod /system/app/[name of your app goes here] 0644
    mount -o remount,ro /dev/null /system
    sync
    reboot

    The actual permission change happens on line 3 with chmod and the hexoctal number

    755 is rwx-rx-rx sorry i mis spoke earlier
     
    takirb likes this.
  17. takirb

    takirb Android Enthusiast
    Thread Starter

    Yea, but i kept fat-fingering every command so i just used a GUI lol

    Just for the heck of it, i glanced at the permissions for Handcent in Supermanager and it was set with the same "all" permissions across the board also, and it's working fine, so i'm not sure if the permissions issue is a problem or not.
     
  18. evomattnc

    evomattnc Android Expert

    ok two apps in system app but have different names, you should actually have two identical camera icons...?

    apparently the lib files do not change much, as long as you have them. I have a copy of camera lib files on my sd card that were to fix something, they may have been for MIUI...?

    It seems that the new version just isnt compatible yet...? I would try terminal emulator chmod and if no go i would assume it isnt compatible. See if anyone else has gotten it. Ive seen this mentioned with the FFC MIUI cam before of course it may have been you in a diff thread...
     
  19. takirb

    takirb Android Enthusiast
    Thread Starter

    I think it was me in the MIUI Community thread LOL

    And yes, they do have different icons and names. The one that works shows MIUI Camera in the app drawer, the newest one just says "Camera", but the icon is different than the stock camera. I even renamed the stock camera with a .bak extension thinking it was puking due to similarities, no success. I'll keep my eye on the forums and see what others can come up with. Thanks for all your help man!
     
  20. evomattnc

    evomattnc Android Expert

    Im not sure extra permission is an issue, missing would be more of an issue but im not sure why handcent thinks it needs read write execute across the board...

    run a fixapk
     
  21. evomattnc

    evomattnc Android Expert

    you can fixapk with a2sd, rom manager, spare parts, maybe TiB..etc...

    Yeah if nothing else you gained a little knowledge...? :D
     
  22. takirb

    takirb Android Enthusiast
    Thread Starter

    Exactly, I've learned to wait on others to make a flashable zip LOL! j/k

    I haven't even tried this whole process with the latest MIUI music player yet, might try that when i get done watching movies and clock out ;)
     
  23. evomattnc

    evomattnc Android Expert

    so when you placed the new one in your system/app did you name it miuicamera.apk (you should have) and changed the other miuicamera.apk to .bak? dont mess with stock camera.apk or htccamera or whatever it is. Apparently MIUI uses the stock lib files and doesnt require its own so you must not need to change those, apparently they can be shared.

    I may have confused you earlier when i said replace the original camera.apk to .bak you should have replaced the other miuicamera.apk i was unaware they were run side by side and shared lib files, like i said i never used it :embarrassed:
     
  24. evomattnc

    evomattnc Android Expert

    Dont make me go home and do this I dont even use the MIUI camera :)
     
  25. takirb

    takirb Android Enthusiast
    Thread Starter

    I didn't change the stock camera.apk to .bak until all other methods failed. That was a last resort in thinking maybe the two icons being named "Camera" was causing a confusion somewhere in the system. They "should" be able to run side by side, the way they're currently running for me now (using the older version 10 MIUI camera).

    The stock HTC camera was fine, but I don't think the AOSP/GB/CM7 or whatever camera is as nice as HTC's or MIUI's.
     

HTC EVO 4G Forum

The HTC EVO 4G release date was June 2010. Features and Specs include a 4.3" inch screen, 8MP camera, 512GB RAM, Snapdragon S1 processor, and 1500mAh battery.

June 2010
Release Date
0
Reviews
Loading...

Share This Page

Loading...