1. Are you ready for the Galaxy S20? Here is everything we know so far!

[Question] Why can't i make my phone STOP swapping operators without my permission? Help!

Discussion in 'Android Lounge' started by Anba, Dec 23, 2011.

  1. Anba

    Anba Lurker
    Thread Starter

    After updating my Incredible S with the newest Android Operation System, was a big update with a lot of new stuff! Anyway my problem is that my phone keeps changing to another network operator than my own, and it uses one from a neighbour country, this month my bill was almost 8 times the normal amount.

    I go into the network settings and manually select my own operator, and I can't find any options to turn off auto connecting to random networks, prior to this update I've never had to
    Anyone who can help?
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Anba

    Anba Lurker
    Thread Starter

    Got another insane bill this month - bumping in hope someone has a solution for me.
     
  3. Tattycakes

    Tattycakes Well-Known Member

    What country are you in? Is your phone actually picking up the network of a neighbouring country?? How far away?
     
    Anba likes this.
  4. Anba

    Anba Lurker
    Thread Starter

    I live in sweden and work in denmark, and I live just 8 km from the border

    And yeah normally I'd use my swedish "Tele2 Sweden 3G" but it keeps changing to a danish operator called IQ, and they charge insane fees if you ask me
     
  5. chanchan05

    chanchan05 The Doctor

    My guess is you're using a phone that does not use a SIM card?

    Since you're using an HTC device, we might have a little difference in the menu structure, but I'd suggest looking into menu>settings>wireless and network>mobile networks>network operator and see if there is a toggle to turn off the automatic network selection.
     
  6. chanchan05

    chanchan05 The Doctor

    My guess is you're using a phone that does not use a SIM card?

    Since you're using an HTC device, we might have a little difference in the menu structure, but I'd suggest looking into menu>settings>wireless and network>mobile networks>network operator and see if there is a toggle to turn off the automatic network selection.
     
  7. Deleted User

    Deleted User Guest

    Have you got 'roaming' switched off? That would stop you connecting to foreign networks for data at least and might keep your operator more stable? Also try a phone reboot....take battery out, replace and turn back on. Reboot often sorts out little glitches.
     
    Anba likes this.
  8. Anba

    Anba Lurker
    Thread Starter


    Really appreciate your feedback!

    I turned Data Roaming off, Data Roaming Sound (doubt it matters, but wth - cant hurt to try) and "Enable always-on mobile data".

    All deactivated, and I did as you suggested it, rebooting it the hard way - still the same.

    Anyone else got any ideas? Willing to try pretty much anything
     
  9. Deleted User

    Deleted User Guest

    OK....next option is with your APN settings, the updates seem to affect them for no reason. Usually they are under Mobile network settings and should give you an option to restore defaults under one of the menus. Try giving that a go.....if that doesn't work try an app called APN lock which I understand overrides the phone stock settings allowing you to force single operator use.

    Hopefully one of those options will help.

    BTW do you know Abbekos?
     
    Anba likes this.
  10. Anba

    Anba Lurker
    Thread Starter

    Sounds like just the thing I was after!

    I'll be giving it a try and fill you in on the result

    Edit: Nope what's Abbekos?
     
  11. Deleted User

    Deleted User Guest

    Just a small fishing village near Malmo that I know as I have family there....when you mentioned living in Sweden but working in Denmark I just wondered...a lot of people commute from that area.
     
    Anba likes this.
  12. Anba

    Anba Lurker
    Thread Starter

    Alright hehe.

    I'm using the HH line, between Helsingborg and Helsing
     
  13. A.Nonymous

    A.Nonymous Extreme Android User

    Have you tried contacting your provider? That would be step 1 for me.
     
Loading...

Share This Page

Loading...