1. Are you ready for the Galaxy S20? Here is everything we know so far!

quick question (possibly dumb)...

Discussion in 'Android Devices' started by Pecosb, May 25, 2010.

  1. Pecosb

    Pecosb Newbie
    Thread Starter

    hey all, just had a quick question. im rooted with fresh2.0d and i have the old 1.5.2 recovery image and want to load on the new 1.6 recovery image before i load fresh2.1.2 on my phone.. so my question is how do i go about loading the new recovery image onto my phone? do i have to unroot and reroot with the new recovery image or is there a simpler way?

    i tried searching but i couldnt find anything specific about flashing the new recovery image onto an alrdy rooted phone. sorry if this question has been asked or if it is just a dumb question, but i figured this would be the most efficient way to get a reliable answer.

    anyways, thanks for your time guys/gals, and i appreciate any info on the matter.

    1. Download the Forums for Android™ app!


  2. JB in AZ

    JB in AZ Android Expert

    Thanks to ccapasso for the following:

    Option A:
    1. Use Kitchen (I didn't but I think it says it can do it)


    Option B:
    1. Mount your SD card, put the 1.6.2 img on your SD card. Unmount your SD Card.
    2. Make sure SD Card is unmounted and USB Debugging Is enabled
    3. Open a command prompt, and cd to your android-sdk-windows/tools directory
    4. Issue the following commands (press enter after each)

    adb remount
    adb shell
    cd /sdcard/
    flash_image recovery recovery-RA-heroc-v1.6.2.img

    After those commands, make sure it flashes successfully (It will return to the # sign). When I did mine, I kept getting the out of memory error. To fix this I simply unplugged the phone, and repeated my steps. Do not reboot the phone until the img successfully flashes.

    After you get it successfully flashed, you will issue the following command

    reboot recovery

    That should take your into RA
    Pecosb likes this.
  3. Pecosb

    Pecosb Newbie
    Thread Starter

    Awesome!! thanks so much.. quick and easy.. i really appreciate it
  4. JB in AZ

    JB in AZ Android Expert

    You're welcome! I have received help from so many here it is nice to be able to help as well.
  5. ccapasso

    ccapasso Android Expert

    Good job JB :). Way to lend a hand.

    I've been terribly sick the past 2 days and haven't moved from my couch. Glad to see others are helping and sharing the knowledge :)
  6. skoo9382

    skoo9382 Member

    where can i find the 1.6.2 img? and is it a must to flash fresh 2.1.2?
  7. Pecosb

    Pecosb Newbie
    Thread Starter

  8. ccapasso

    ccapasso Android Expert

    1.6.2 is not required to Flash fresh 2.1.2. There is a link to download it above, or you can get it from the tutorial (as it is there as well).
  9. skoo9382

    skoo9382 Member

    if it's not required, what (if any) are the benefits of having 1.6.2?
  10. Kelmar

    Kelmar Done by choice

    I've heard bug fixes but am curious to this as well.

    Also, it won't change anything with my current ROM, correct?
  11. ccapasso

    ccapasso Android Expert

    Correct. It will not change anything with the ROM. The RA has no effect on the ROM itself.

    As for bug fixes, it fixed some issues with nandriod backups and restores and a few other things I do believe.
  12. cooolone2

    cooolone2 Android Enthusiast

    Thanks for the info...

    I'm curious as well to the updated recovery image... Differences and fixes - specifically, if anyone is aware of them. I searched and found no info other than it's (recovery) updated.

    Also, is it backward compatible? I.e., to restore and older backup for instance (1.5, not that I would want to, just happy to know I could).

    Happy Trails!
  13. ccapasso

    ccapasso Android Expert

    Yes, it is backward compatible.

    Here is a link to the Dev of the RA post:
    [Recovery] CDMA Sprint [07-Mar-2010] RA-heroc-v1.6.2 - xda-developers

    Release notes are in there :)
    cooolone2 likes this.
  14. cooolone2

    cooolone2 Android Enthusiast

    ok... now I'm done???

    lol, HELP!!! hahaha...

    I tried to update the Recovery to 1.6.2 and now I think my recovery console is gone.

    I couldn't get it going and I read this...
    xda-developers - View Single Post - [Recovery ROM] [07-Mar-2010] RA-hero-v1.6.2

    Of course because it wasn't working I tried this and now...

    When I try to boot into recovery I get the HTC screen and a little red box in the top left hand corner that says FASTBOOT USB. Phone doesn't respond.
    I continually get that file does not exist when trying to flash, but it's there on the root of sdcard.

    So I disconnect the USB and pull the battery. IF I try to boot into recovery it just stays on the HTC screen (I'm assuming it's looking for recovery and it's gone - so stuck). If I just press power button the phones starts normally (phew!!! a relief!) So I can access the phone and debugging/su through the command prompt.


    So... now, how do I replace or restore the recovery? Ideas???
    I feel so defeated and noobish. thanks for any help in advance.

    So embarrassing...
  15. mysticmead

    mysticmead Android Expert

    get fresh kitchen. click root.. on root page check box for flash RA only.. then click root.. it'll put the 1.6.2 RA on for you
  16. ccapasso

    ccapasso Android Expert

    Agreed. If this doesn't work you can always do it manually:

    1. Mount your SD Card. Place recovery image on SD Card.
    2. Unmount SD Card.
    3. Open a command prompt and cd to your android-sdk-windows/tools directory
    4. Issue the following commands: (press enter after each)

    adb remount
    adb shell
    cd /sdcard/
    flash_image recovery recovery-RA-heroc-v1.6.2.img

    After this goes through successfully, you will get the # sign returned (same as you did when rooting and flashing the old RA manually).

    Only enter the next command after the # sign shows up. If it doesn't or you get an error, do NOT enter this command:

    reboot recovery
  17. cooolone2

    cooolone2 Android Enthusiast

    Cool, thanks... I've tried every angle I could read online and nothing worked. So Fresh Kitchen is menu driven then, lol, I enjoy command line, but will make an exception, lmao... I'm freaking cause I don't wanna mess anything else up and lose access to Nandroid Restore, lol.

    Turns out that when looking closer at that page and it's thread, it was NOT for CDMA Hero, I'm usually pretty good making sure, but wow, what a hiccup!
    As always, the computers only do what YOU tell them too, all mistakes are mostly HUMAN error, lol.

    Using the cmd to wipe a folder is not to smart ;)
    "cat /dev/zero > /dev/mtd/mtd1"

    I did read somewhere though that there are copies of those core folders on the phone??? Is that true? Just curious, cause I'm wondering why then it didn't replace what was missing when I rebooted... but maybe I read something wrong. Anyway, also not a good idea to try things at 1:00 a.m., lol.

    Thanks Again!
    Your help is appreciated.
  18. cooolone2

    cooolone2 Android Enthusiast

    ok... here's what I get???

    C:\android-sdk-windows\tools>adb remount
    adb server is out of date. killing...
    * daemon started successfully *
    remount failed: Operation not permitted

    *** What does remount failed mean??? ***
    *** so I continue...

    C:\android-sdk-windows\tools>adb shell
    $ cd /sdcard/
    cd /sdcard/
    $ flash_image recovery recovery-RA-heroc-v1.6.2.img
    flash_image recovery recovery-RA-heroc-v1.6.2.img
    flash_image: permission denied

    *** so I load SU permisson *** Still???

    $ su
    # flash_image recovery recovery-RA-heroc-v1.6.2.img
    flash_image recovery recovery-RA-heroc-v1.6.2.img
    flash_image: not found
    # flash_image recovery /sdcard/recovery-RA-heroc-v1.6.2.img
    flash_image recovery /sdcard/recovery-RA-heroc-v1.6.2.img
    flash_image: not found
    # exit
    $ exit


    So I back out, it tells me the files aren't there and they are, both in tools directory and the sdcard ROOT. What am I missing or doing wrong?


    oh... and this is what I have loaded onto my phone... if it helps.
    [ROM] Newest Sprint leak - RUU_Hero_C_Sprint_2.27.651.5_R_signed_release - xda-developers
  19. ccapasso

    ccapasso Android Expert

    Make sure your USB deubbing is on and try again.
  20. cooolone2

    cooolone2 Android Enthusiast

    ok, tried this too and it says:

    The Kitchen has detected that you don't appear to be running a stock Sprint rom. This root method only works on the Sprint Hero. Would you like to continue.

    ??? lol, I'm just trying to go cautiously here and not screw it up and have to put all my info back into phone. So is it not recognizing the 2.1 update I loaded to the phone? What's your best guess?

    Thanks all... I REALLY appreciate it and hate troubling you.
  21. cooolone2

    cooolone2 Android Enthusiast

    Yes, it's on and I can get to shell and root access too - right?
    Crazy... driving me crazy, lol

    (above post from cmd prompt window)

  22. ccapasso

    ccapasso Android Expert

    Seems to me from what I've read, and it wasn't a lot yet, that people were having SU and adb issues with that ROM. I would suggest a different ROM :)
  23. ccapasso

    ccapasso Android Expert

    Have to get back to work..just remembered though you can't get into recovery. If you can't get into recovery, you can't flash a ROM. Hmm...I'll do some thinking, but at the office currently.
  24. cooolone2

    cooolone2 Android Enthusiast

    ok, So sorry to hijack this thread too... but ...

    So Kitchen failed, flashrec too.

    I'm real interested to know... can I just unpack to recovery image file and push the files where they belong on the phone? hahaha, and if so... what commands or permissions to enable writing the files and the directories they belong.

    IF all else fails, can I re-run the entire ROOT process and just write over everything, but losing what I have and start from scratch again (contacts, apps, data?)

    Wow... what a drag, but, thanks again for any help, in advance!
  25. cooolone2

    cooolone2 Android Enthusiast

    Ok peeps... come now, anyone, any ideas???

    I've been all over the place with this... even checking and changing directory permissions and trying to push recovery.img from the nandroid backup to the phone, all no good. Wow...

    so anyway, if I re-run the entire ROOT process will I be able to start over?
    I have access to shell and root now.

    Thanks :)

HTC Hero Forum

The HTC Hero release date was July 2009. Features and Specs include a 3.2" inch screen, 5MP camera, 288GB RAM, MSM7200A processor, and 1350mAh battery.

July 2009
Release Date

Share This Page