1. Are you ready for the Galaxy S20? Here is everything we know so far!

random no network connection error

Discussion in 'Android Devices' started by jaliy, Dec 27, 2011.

  1. jaliy

    jaliy Android Expert
    Thread Starter

    Whether I'm on wifi or 3g, sometimes my apps would tell me i have no internet connection. But if i spam retry button a few times it works. All this time my phone is connected to the internet. Anyone knows why?

    So far this has happened to market app, youtube app, and other app that require internet connection

    Sometimes the green bar on browser would stuck and not go. I tried refresh same thing. I had to force close the browser and open again to fix. Anyone know why
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Shotgun84

    Shotgun84 Extreme Android User

    Bad reception?
     
  3. jaliy

    jaliy Android Expert
    Thread Starter

    Nope. Reception is excellent
     
  4. kayne5

    kayne5 Member

    Which firmware are you on ? Mine always crashed on 2.3.3, with 2.3.4 had no crashes in browser at all.
     
  5. jaliy

    jaliy Android Expert
    Thread Starter

    Its not a crash, more like a freeze and the green bar doesn't move
     
  6. jaliy

    jaliy Android Expert
    Thread Starter

    Anyone? It seems to be getting worse and worse only lasting a day or so before a reset is needed
     
  7. Medion

    Medion Android Expert

    Check to see if other network-based apps have issues at the same time (Ie, Facebook app, other browsers, etc.). You can have a full-strength signal, but if you're in a congested area then data can still die out completely. AT&T here is notorious for this. There are two main streets here where if I'm on them, I will get no data even though I have H+ at full bars. When I was on Verizon, I'd at least get 100k-250k on these streets.
     
  8. noelmg

    noelmg Lurker

    Yep my wife's S2 having exactly the same issue. It's not the ROM (same issue on stock and on Sensation ROM). It happens on both 3G/HSDPA and on wifi, but only in apps requiring internet access. The actual internet works fine throughout.

    Network is Vodafone UK but it happens on Wifi too so don't think its network related.

    Would be interested to know if there's any reason behind this, its a very strange issue.

    Incidentally, I got my S2 on the same day from the same place, and have the same ROM onboard, and have never experienced the issue.
     
  9. Shotgun84

    Shotgun84 Extreme Android User

    So you have perfect reception? Isn't it similar to your other thread about your internet keeps loosing connection? That says shit reception to me or maybe try a different modem.
     
  10. noelmg

    noelmg Lurker

    Well it makes no difference if on GSM or Wifi, and browsing the internet is fine. It is only in applications.
     
  11. Shotgun84

    Shotgun84 Extreme Android User

    Sorry, that was a suggestion for jaliy. Its where two threads have been joined together its kind of ended up out of place. Or maybe I forgot to press the quote button.
     
  12. Slug

    Slug Check six!
    VIP Member

    Nope, my fault.... I merged the two topics but got interrupted by a PM before I'd got round to checking for just that sort of confusion. :eek:
     
  13. algy3289

    algy3289 Lurker

    Ive had this happen before. have a look at settings and you need to select packet data.
    That seems to work
     

Samsung Galaxy S2 Forum

The Samsung Galaxy S2 release date was April 2011. Features and Specs include a 4.3" inch screen, 8MP camera, 1GB RAM, Exynos 4210 Dual processor, and 1650mAh battery.

April 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...