1. Are you ready for the Galaxy S20? Here is everything we know so far!

RAZR HD Root Method (ICS Only)

Discussion in 'Android Devices' started by Xelios, Oct 19, 2012.

  1. Xelios

    Xelios Android Enthusiast
    Thread Starter

    So I figured I'd help get the ball rolling here. Dan Rosenburg figured out how to root the RHD and the RHDMaxx before it even being released. Successfully tested by me, so it works for sure. Thought someone else would like this.

    You'll need the Motorola Drivers installed, and you need to download the motofail2go resource to do it.

    Drivers here.

    Motofail2go here.

    Process is simple. Hook up your phone via USB on any mode (did mine on mass storage). Unzip the archive and run the batch file titled "run". It'll do pretty much all the work for you. It'll ask you to submit a bug report by pressing the Volume Up/Power button simultaneously, then it'll get you root.

    At the end, itll ask you to hit a key to reboot the phone. In my experience, then phone was rebooting by itself, killing off the process and not getting root. Took me about 5 tries but that last time, I sat at the screen and hit a key immediately when it came up and it worked.

    Enjoy.

    Original XDA thread here.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. WyntersEnd

    WyntersEnd Member

    Worked flawlessly for me on the Maxx
     
  3. radproducts

    radproducts Lurker

    It worked fine for me except WIFI Tether does not work. I tried removing the current release and installing the current beta. Still no success.

    Any ideas?
     
  4. Xelios

    Xelios Android Enthusiast
    Thread Starter

    Same here. I'm guessing it's cause the phone just came out, probably needs an update. I tried a fix I found on XDA but it didn't fix it. FoxFi is in the same boat.
     
  5. Raryn

    Raryn Well-Known Member

    If you didn't pay full price for the phone and are no longer on unlimited data, you can tether for "free" using Verizon's own app with no adjustments. Otherwise, you'll probably have to wait for the sql tweaks.
     
  6. Xelios

    Xelios Android Enthusiast
    Thread Starter

    There's this SQL tweak if you guys want to give it a shot.

    http://forum.xda-developers.com/showthread.php?t=1945274

    I'm not exactly sure what it accomplishes though. It hasn't fixed any of the other apps in tethering. I already did it, does that mean I can use the Verizon app to tether for free? I'm still on unlimited.

    EDIT: FoxFi works if you download the addon, thanks to Grouchy
     
  7. naykam0810

    naykam0810 Newbie

    Good Morning, I downloaded the OTA earlier this morning, after attempting to install it went to fastboot mode anf just got stuck there saying boot failure. I tried hard reset and soft reset with no luck. I can get the phone to power off and to power on, but if it turns on it will automatically shut down into the fastboot mode screen. It's frustrating, any help please?
     
  8. sabirc13

    sabirc13 Lurker

    I did this root a few days ago and i didnt even get a notification for the update and now when i check for it, its giving me that crap about communicating with motorola servers... please help
     
  9. bigbadwulff

    bigbadwulff Android Expert

    With the Droid X you had to unroot to get the OTA updates. Same with this phone?
     
  10. Xelios

    Xelios Android Enthusiast
    Thread Starter

    Sorry dudes, been out of power since the 28th so I haven't been able to respond. Damned hurricanes.

    Naykam, I posted a guide to another thread about restoring your phone, give that a shot. Check through your post history, you should be able to find it.

    sabirc: Not sure whats wrong there. I updated with root, no issue. Try wifi?

    bigbad: I can't confirm that since I had bloat deleted so I wasn't able to get that. Had to restore the phone.
     
  11. clanmurphy

    clanmurphy Lurker

    I am a newb and have rooted by Droid Inc. I just got the RAZR MAXX HD and am following the steps above, but got stuck on Installing the fake package. Any recommendations?
     
  12. Xelios

    Xelios Android Enthusiast
    Thread Starter

    You mean when it's pushing sudoku and that crap? Dunno why it's hanging if that's what you meant. There's another tool that was released actually. Contains the same method but it's within a package. Maybe that might work better for you. Maybe update your drivers if you havent done that. You can find the other tool over here.

    Give me more info on where you're getting stuck if my assessment was wrong. I'm not great at troubleshooting but I'll certainly try to help!

    Make sure USB Debugging is enabled though if it isn't. And maybe you have to enable the install non-market apps too. USB debugging can be found under settings>developer options and install non-market apps can be found in settings>security. It's titled "Unknown Sources".
     
  13. clanmurphy

    clanmurphy Lurker

    Thanks Xelios. I am downloading the other tool now. I had installed the Motorola drivers, turned on USB debugging and allow Unknown sources. I ran run.bat from the motofail2go_windows from Windows 7 in a VM on my Mac. The application run and here is what I get:

    [*]
    [*] Motofail2Go: Motorola Android Root Exploit (Windows version)
    [*] by Dan Rosenberg (@djrbliss)
    [*]
    [*] Tested on Atrix HD, Photon Q, Razr M, and Razr i
    [*]
    [*] Before continuing, ensure USB debugging is enabled, that you
    [*] have the latest Motorola drivers installed, and that your phone
    [*] is connected via USB.
    [*]
    [*] Press enter to root your phone...
    Press any key to continue . . .
    [*]
    * server not running *
    [*] Waiting for device...
    * daemon not running. starting it now *
    * daemon started successfully *
    [*] Device found.
    [*] Installing fake package...

    I have let it sit for over ten minutes at this stage, but seems like it is hung up. How long should the fake package piece take?
     
  14. Xelios

    Xelios Android Enthusiast
    Thread Starter

    Should not take long at all. Much less than 10 minutes, the whole process is about 2 minutes. You said you're on a Mac, in which case the other tool might work better. I assumed you were on Windows, but there's a Linux/Mac version of it. You'll have to register to view the link unfortunately though. That can be found right here. Unfortunately I don't know if the Mac version is any different, nor do I have one to check it on. Best of luck, and report back if there are any issues.
     
  15. clanmurphy

    clanmurphy Lurker

    Just to confirm, this should work on a RAZR MAXX HD, correct?
     
  16. Xelios

    Xelios Android Enthusiast
    Thread Starter

    Yeah it works on the Maxx, absolutely. It was almost flawless on mine. Both before and after the 0.7.2 update.
     
  17. clanmurphy

    clanmurphy Lurker

    Thanks for hanging with me on this one, Xelios. I was unable to get it to work on Windows 7 operating on a VM on a Mac, but did get the Mac version of the software to work. The only funkiness is when the app told me to press Enter, it just sat there and did not progress until I did Control C within the Terminal window. After that, everything progressed nicely and I confirmed with Titanium that I am rooted. I appreciate your assistance and support!
     
  18. Xelios

    Xelios Android Enthusiast
    Thread Starter

    Not a problem, we all needed help at one point!
     
  19. Just posting to note that the root method worked for me without a hitch.
     
  20. PresTeeJ

    PresTeeJ Lurker

    This is my first Android device (finally left Apple thank god) and I'm having trouble getting the root to work on my razr hd. I get to the whole root to seem like it works but at the end where it says to push any button to restart phone, my phone doesn't restart. Any suggestions?
     
  21. Xelios

    Xelios Android Enthusiast
    Thread Starter

    Have you tried manually restarting it? I'm not sure if that would work but you can check if you have root after rebooting by using root checker. Just search those two words in the play store, you should find that app.
     
  22. PresTeeJ

    PresTeeJ Lurker

    Yup I did a manual reset a couple times and checked root using the Root Checker app.
     
  23. Xelios

    Xelios Android Enthusiast
    Thread Starter

    Don't suppose you have a laptop or something you can try it on? Not really sure how to help here because I don't know how to induce a reset that will work with the software.
     
  24. Don't you press a key on your computer and then the .bat file pushes the reboot to the phone ?

    Been a couple of days and I only did it once, so I may not be remembering correctly.
     
  25. Xelios

    Xelios Android Enthusiast
    Thread Starter

    Yup that's all there was too it, but it seems the batch file is hanging on the last step and isn't restarting it.
     

Motorola Droid RAZR HD / MAXX HD Forum

The Motorola Droid RAZR HD / MAXX HD release date was November 2012. Features and Specs include a 4.7" inch screen, 8MP camera, 1GB RAM, Snapdragon S4 Plus processor, and 3300mAh battery.

November 2012
Release Date
0
Reviews
Loading...

Share This Page

Loading...