1. Are you ready for the Galaxy S20? Here is everything we know so far!

Reached Dead End With Rooting

Discussion in 'Android Devices' started by jedimanelas, Dec 18, 2012.

  1. jedimanelas

    jedimanelas Lurker
    Thread Starter

    Hi All,

    So... complete novice loves his HTC Desire but hates the internal memory issue and finally decides to take the plunge and attempt to root his phone.

    And now after overcoming some hurdles I have hit a brick wall and can no longer use the phone at all - I'm hoping it's a simple issue I haven't found a solution to yet - sifting through the forums is hard work and a "20 minute process" has now taken me the good part of 4 hours. I am waving the white flag and hope someone with more experience can come to my aid.

    1) Downloaded HTC Sync then uninstalled to obtain drivers
    2) Installed the HBoot drivers
    3) Ran UnrEVOked and received error 'backup CID is missing'
    4) Discovered 'downgrade froyo 2.2 to stock 2.1' may help
    5) Created GoldCard in accordance with requirements for downgrade
    5) Followed instructions and removed PB99IMG.zip file from SD Card
    6) Loaded up phone to receive 'SIM network unlock PIN' error message
    7) Found HTC Desire Unlock on xda forums - downloaded and attempted to run but could not identify phone. Took out sim so I could get into phone and re-activate USB-debugging which had been reset by downgrade.
    8) Now no error message - command prompt just starts up and sits there.

    I think that's everything... I really didn't expect it to be so difficult and now I can't use the phone at all. Because I never got it rooted I haven't made my first backup file to restore to previous settings. If this isn't going to work can I restore to it's original settings with an RUU?

    Any help / suggestions would be greatly appreciated. I hope there is enough information provided and I also apologise for the lack of links to the things I used - this is a new account so I can't use links yet... but all articles used were either found on Phandroid or xda-developers forums.

    Thanks,
    Dan

    [UPDATE] Have now unlocked phone and have full access to SIM and Orange network again. Was running unlock program while phone was on - instead of whilst on the boot screen... rookies. Upon re-running unrEVOked still receiving error regarding backup CID missing (back to square 3)...
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    Hi Dan, and welcome to AF :)

    Sorry, just a quick post as am going offline for a bit.

    Did you run the RUU to downgrade? If not, don't - there are better ways these days in almost all cases.

    Reboot the phone while pressing the volume down key. What does it say - hboot version in particular.

    As long as you can get into fastboot mode (one of the options in the hboot menu) we can run another RUU if need be. So don't worry, this is fixable. An RUU does wipe the phone though.

    Back later
     
  3. jedimanelas

    jedimanelas Lurker
    Thread Starter

    Hi Hadron - I've worked out the problem with the sim unlock and can now use the phone on my network again (yay) seems I was trying to run the command prompt when the phone was on - and not when it was on the boot screen. The instructions I was following failed to mention this particular step.

    But when running unrEVOked I still get 'Validation error: Backup CID is missing'

    Details on the boot screen are as follows:

    BRAVO PVT1 SHIP S-ON
    HBOOT-0.83.0001
    MICROP-031d
    TOUCH PANEL-SYNT0101
    RADIO-4.08.00.09
    Jun 10 2010, 12:12:05

    This is downgraded from when I first got the phone as the original HBOOT was 0.93xxx - I used this guide http://forum.xda-developers.com/showthread.php?t=768256 to downgrade - I assume that it worked?

    One thing that has confused me is now all the bloatware from Orange is gone so I have obv made some sort of progress. Am I being stupid and this is now rooted? I can't seem to find the superuser app...

    There is so much information my brain is getting frazzled trying to sort out what steps I need to take from here to reach my ultimate goal (internal memory issue).

    Once I'm a bit more comfortable with all this stuff I'd like to take a look at some ROM's and stuff too - until I started reading these forums I didn't realise just how many possibilities there are available!
     
  4. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    It's downgraded, but that tutorial is kinda old. We have some more up-to-date guides in the All Things Root forum here.

    The bloatware is gone because the RUU has replaced the system software with a new (or rather, old) set without the network apps. That's nothing to do with root. The problem is that I think you now have android 2.1, which I doubt is what you want!

    So unrevoked is still not working. I don't know that message, and can't check it at the moment. I'm half inclined to suggest upgrading to 2.3 (another RUU) and then using Revolutionary instead (or maybe flashing an unbranded 2.2 RUU then using either unrevoked or revolutionary). I'll post links when I have a chance.

    If you visit the All Things Root forum there is a sticky post Desire All Things Root Guide with links to instructions for both methods. Perhaps worth taking a look there.
     
  5. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    All I can suggest for that unrevoked error is trying a different version of unrevoked (which one did you use?). Or maybe using a newer RUU first.

    So, while I have a proper browser for a few minutes (rather than a phone):

    You've probably found it, but the place to get Desire RUUs is shipped-ROMs. There's no Orange RUU there, but as you have a goldcard you could consider an unbranded Froyo. The most recent is: RUU_Bravo_Froyo_HTC_WWE_2.29.405.5_Radio_32.49.00.32U_5.11.05.27_release_159811_signed.exe

    Or there's the official Android 2.3 (the RUU is inside the zip): HTC_Desire_Android_2.3_Upgrade.zip

    I think the Froyo one should work for rooting with both unrevoked and revolutionary. If you use 2.3 you need to use revolutionary to root. However, the 2.3 is useful to have a copy of, because it should work even without a goldcard (so useful if you ever get into real problems). Revolutionary gives you more options (S-Off let's you change more stuff than just root), but the process has a few more steps.

    I'm going to move the thread to the All Things Root forum, as more root users will see it there (not that we have so many left here now! ;)).
     
  6. jedimanelas

    jedimanelas Lurker
    Thread Starter

    I used unrEVOked 3.21 from a thread in the All Things Root guides.

    Thanks for the links to the RUU's - Revolutionary/2.3 sounds like a bit more work but also seems a better option in the long run. I've come this far so I may as well give it a go and hope for the best.

    My work schedule for the next couple of days is pretty hectic so prob wont get a chance to try this out just yet, but will post once I've managed it.

    Again, thanks for the links and I'll keep the post updated.
     
  7. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    Good luck :)

    My schedule is going to be erratic too, but there are a few people around here who know this stuff, so hopefully one of us will be able to answer any questions.
     
  8. nicka3200

    nicka3200 Android Expert

    I don't knbow how far you have got with this but having used both Unrevoked & Revolutionary in the past I would recommend Revolutionary. Why? Well even though there are a few more steps you will gain S-Off which opens up many more possibilities such as choosing a superior recovery, flashing custom hboots with specific partition tables, Uninstalling system apps & integrating system app updates into system via Titanium Back up. I would suggest you do the following:


    1. Run the Official 2.3 RUU. This will give you the compatible Hboot & the latest Radio.
    2. Run Revolutionary as per the guide & say no to install their recovery. This will give you S-Off.
    3. Fastboot flash this 4EXT recovery image which comes from here. That will give you a custom recovery.
    4. Place this superuser file on your sd but not inside any folders. Boot into recovery (from off, hold vol-down and power and choose "Recovery"), select install zip from sd, choose zip & confirm. You are now rooted.
    5. Reboot phone

    Congratulations the world is now your oyster!
     

HTC Desire Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...

Share This Page

Loading...