1. Check out our companion app, Forums for Android! Download from Google Play

Root Really annoying Froyo problem

Discussion in 'Android Devices' started by eyelobes, Jun 9, 2010.

  1. eyelobes

    eyelobes New Member
    Thread Starter
    5

    Nov 5, 2009
    4
    0
    5
    So I've got NexFro 1.1 loaded up and I have a problem with all of my Widgets on any launcher I use being gone every time I reboot my phone.

    None of my apps are on my SD card and this is a problem with every froyo Tom o have tried to use so far.

    On the stock launcher they are just gone,and on LauncherPro they all say there was a problem loading widget.
    I have formatted everything several times on each rom I try and still have the same results.

    Any suggestions any suggestions are greatly appreciated.
     

    Advertisement

  2. johnlgalt

    johnlgalt Antidisestablishmentarian
    453

    Oct 28, 2009
    9,416
    1,924
    453
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    How did you get FroYo installed? exactly?
     
  3. eyelobes

    eyelobes New Member
    Thread Starter
    5

    Nov 5, 2009
    4
    0
    5
    I installed it via CW with fabs newest release. I tried it once and then formatted system,data and cache three times and the loaded it again. I am also running the p3 1200 kernel with it.

    Market, maps and chrometophone all work great.
     
  4. johnlgalt

    johnlgalt Antidisestablishmentarian
    453

    Oct 28, 2009
    9,416
    1,924
    453
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    Try loading a lower kernel - your phone may not be playing nicely with that kernel.
     
  5. xmr405o

    xmr405o Well-Known Member
    333

    Dec 7, 2009
    4,171
    1,185
    333
    I'm not sure it's a Froyo issue. What widgets/shortcuts are you having issues with? I have beautiful widgets and they don't disappear after I reboot my phone. The only issues I've had are the widgets/shortcuts from apps that are stored on my SD. Do you have a task killer installed? Do you have Launcher pro excluded from the list?
     
  6. eyelobes

    eyelobes New Member
    Thread Starter
    5

    Nov 5, 2009
    4
    0
    5
    All my widgets except for Facebook. Beautiful, Pandora, mixzing, slacker, audiomanager pro.

    I am going to try for the stock kernel. My phone has never had a problem running at 1.2 ghz before.
     
  7. ska.t73

    ska.t73 Well-Known Member
    163

    Mar 11, 2010
    1,659
    305
    163
    Phoenix, AZ
    The actuall notes for devs from Google notes that if your app has a widget it will not be visable on the home screen if your app is moved to the SD card... They are suggesting that Devs with app widgets not enable this feature for there app... An app will not have the option to move to the SD card unless the Dev enables it in the apk...
     
  8. eyelobes

    eyelobes New Member
    Thread Starter
    5

    Nov 5, 2009
    4
    0
    5
    I haven't moved anything to the SD card, that's what is so annoying.
     
  9. ska.t73

    ska.t73 Well-Known Member
    163

    Mar 11, 2010
    1,659
    305
    163
    Phoenix, AZ
    Ah woops sorry misread :)
     
  10. johnlgalt

    johnlgalt Antidisestablishmentarian
    453

    Oct 28, 2009
    9,416
    1,924
    453
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    The key is that this kernel is not the same kernel that you were using before.

    Your statement is analogous to saying "My car has always been able to do 120 mph before, why is it not doing it now?" There are so many variables involved, it's not just a matter of bumping the clock speed.

    Even if your previous successful OCs to 1.2 were from P3, this is still a kernel that was developed for FroYo specifically. Just like I had to, in order to find a good OC that your phone can use you'll have to keep trying them out.
     
  11. deadhd5

    deadhd5 Member
    5

    Jun 10, 2010
    5
    0
    5
    I am having this issue and it is driving me crazy. I am almost positive it has to do with the modded services.jar file. I am having this issue with every theme that has white notification text. When I was modding my own framework w ninjamorph everything was going great until I tried to push a services.jar pulled from clean black theme or droptheme for froyo. I also noticed that when this occurs it takes much longer to shut the phone down.
     
  12. johnlgalt

    johnlgalt Antidisestablishmentarian
    453

    Oct 28, 2009
    9,416
    1,924
    453
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    Well, I have NexFro installed, and thus my fonts and such are white, and yet I am not exhibiting this issue at all.

    It could, though, indeed be the services.jar....I wonder if Fab had to play around with his before he got it working correctly.

    I'll try to PM him and ask him to take a look at this thread.
     
  13. deadhd5

    deadhd5 Member
    5

    Jun 10, 2010
    5
    0
    5
    Looks like I will be hooking up some NexFro until this issue gets worked out. Thanks for the tip and the help John!
     
  14. johnlgalt

    johnlgalt Antidisestablishmentarian
    453

    Oct 28, 2009
    9,416
    1,924
    453
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    Make a backup of where you are now - I said am not exhibiting these issues - doesn't mean you will not either.
     
  15. deadhd5

    deadhd5 Member
    5

    Jun 10, 2010
    5
    0
    5
    Well, I tried NexFro, and while I love the look of it I still have this same issue. Also, it seems this problem is only with market apps. The fact that not everyone has this issue leads me to believe that it has something to do with the fact that I came from CM5.0.7 and had Apps2sd enabled combined with the modded services.jar. Stock Froyo does not have this issue. I am going to reformat my sdcard later today and remove the apps2sd partition and see if that helps. It is frustrating not having the knowledge to diagnose this problem myself. Any more advice would be welcome. Thanks
     

Share This Page

Loading...