1. Download our Official Android App: Forums for Android!

Support Receiving MMS messages

Discussion in 'Android Devices' started by shaunyjames, May 11, 2011.

  1. shaunyjames

    shaunyjames Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    11
    Joined:
    May 9, 2011

    May 9, 2011
    11
    3
    16
    Hi Guys,

    I have searched high and low yet cant seem to find anything on this.

    Basically I received a picture from a friend and in the string of messages it says message size, expires, then a box to download - when I hit download either nothing happens atall or I get this message:

    Message not downloaded - review message and try again.

    I have tried with wifi on only, data network only and both on to no avail :(
     

    Advertisement

  2. NFG

    NFG Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jul 7, 2011

    Jul 7, 2011
    1
    0
    5
    I have exactly the same problem. I receive an MMS with a DOWNLOAD button, press it, and nothing ever happens. One time out of three I actually downloaded the image (206kB, much larger than the two failed ones which were <60kB).

    I cannot send MMS at all. If i'm on WiFi, it just spins and nothing happens. If I'm on 3G, the 3G logo disappears ~5 seconds after pressing SEND, comes back 30s later, but the message is never sent.
     
  3. ironass

    ironass Android Expert
    Rank:
     #19
    Points:
    1,343
    Posts:
    11,391
    Joined:
    Aug 17, 2010

    Aug 17, 2010
    11,391
    5,591
    1,343
    Male
    Keeping one step ahead of the Tax man
    Cotswolds, England
    You both do not seem to have the correct APN settings to allow MMS sending and receiving I'm afraid.

    *These can be obtained from your service providers (or their websites) and are different for each one.

    APN settings are here on the phone...

    Settings > Wireless & network >Mobile networks > Access Point Names


    * be advised... my own service provider got the settings wrong several times.
     
  4. Waleedq8

    Waleedq8 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Apr 12, 2011

    Apr 12, 2011
    5
    0
    5
    I checked that I have the right APN setting from my network provider, but what is really frustrates me is that my friend who has SGS2 with the same company is sending and receiving MMS, we both compared the APN setting and found no difference! :thinking:

    I'm on wifi by the way. . . Any thoughts?

    Thanks,
     
  5. halfman21

    halfman21 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Jun 29, 2011

    Jun 29, 2011
    4
    0
    5
    I have the exact same problem on AT&T, I have tried different apn settings that other have mentioned worked for them. I have also tried sending mms without () in the contacts number and from the gallery or different messaging apps to no avail. Others have mentioned that the sending could be do to some kind of compression issue with the stock messaging app, but nothing works for me.
     
  6. shruby

    shruby Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jun 25, 2011

    Jun 25, 2011
    1
    0
    5
    I also have the same problem.. but from time to time it will work. Not sure why it does that.. Its very frustrating.

    I'm able to send no problem, but when receiving.. sometimes I will get that download box, and sometimes i actually see the MMS. Apparently some people are saying to turn off Wifi and then try downloading the image on the 3g network only, but even that didn't work.. but sometimes when I'm on wifi it works as well.

    Any other suggestions that might fix this problem?
     
  7. eirikdh

    eirikdh Member
    Rank:
    None
    Points:
    16
    Posts:
    57
    Joined:
    Jul 5, 2011

    Jul 5, 2011
    57
    4
    16
    Maybe stupid tip, but hold down the power bottom. Check that Data network mode is enabled. I
     
  8. ivanck

    ivanck Newbie
    Rank:
    None
    Points:
    15
    Posts:
    22
    Joined:
    Jul 15, 2011

    Jul 15, 2011
    22
    0
    15
     
  9. DaveSyd

    DaveSyd Android Enthusiast
    Rank:
    None
    Points:
    53
    Posts:
    428
    Joined:
    Jul 19, 2011

    Jul 19, 2011
    428
    62
    53
    Australia
    I would be calling your carrier. Not sure which location you are in - but generally the carriers are quite helpful because it's in their interests to use more data intensive traffic, eventually it translates to bottom line.

    Here in Aus the carrier will either over the phone or on a web site - send you setup information via SMS. You click on the line in the SMS agree to load the file and it creates the right APN setup entry. You should have to do this only once, as it retains these settings after a factory reset. When I got the phone, it took literally less than 5 min to get the details and install from the carrier?

    Hope this works in your location?
    D
     
  10. iynCognito

    iynCognito Well-Known Member
    Rank:
     #432
    Points:
    58
    Posts:
    101
    Joined:
    Apr 21, 2010

    Apr 21, 2010
    101
    13
    58
    Manchester, UK

    Some carriers have a separate apn for mms and for internet. this should let you use mms without other internet data. You can always test if your mms works by sending one to yourself.
     
  11. ironass

    ironass Android Expert
    Rank:
     #19
    Points:
    1,343
    Posts:
    11,391
    Joined:
    Aug 17, 2010

    Aug 17, 2010
    11,391
    5,591
    1,343
    Male
    Keeping one step ahead of the Tax man
    Cotswolds, England
    If you go into look at your current APN, using Edit access point, and you have settings in the following for MMS...

    MMSC
    MMS proxy
    MMS port
    MCC
    MNC
    Authentication type (either/or both...PAP/CHAP)
    APN type should have... internet + mms

    If not then you will need to get a seperate MMS APN from your service provider.
     
  12. zeroatom

    zeroatom Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    May 9, 2013

    May 9, 2013
    1
    0
    5
    Male
    1. Go into your message App
    Press menu button and click on Settings
    3. Turn off Auto-Retrieve
    4. Go back into any unfinished text message downloads and press Download
     

Share This Page

Loading...