1. Are you ready for the Galaxy S20? Here is everything we know so far!

Recording video to 64 Gb memory card.

Discussion in 'Android Devices' started by Fozzy757, Jul 31, 2018.

  1. Fozzy757

    Fozzy757 Lurker
    Thread Starter

    Hey there,



    I'm trying to use my Galaxy S8 to record my guitar performances in 1080p but the video would always cut off at 10 min. So I did some research and found that Open Camera would probably be the better alternative to the stock camera app on my phone. Now the videos stop at 30 min and starts recording where it left off which is better, but I have it set to 1 hour increments and it's not doing thst. Plus, it's saving it to the internal storage which is problematic because I don't have enough internal storage to support a couple of hours long recordings. How would I get the recorded video to go Directly into the 64Gb card I have in my phone??



    Peace.
     


  2. El Presidente

    El Presidente Beware The Milky Pirate!
    VIP Member

    In open camera, hit the settings icon, hit more camera controls and scroll down to the option which says "Use Storage Access Framework".

    Hit the 3 line menu button on the top left of the screen and it should allow you to set the SD Card as the default save location. Let me know if it doesn't and I'll have another play about.

    I've always found the S8 pretty bad at handling heavy distortion or effects when recording, is Open Camera better or how do you work around it?
     
  3. Fozzy757

    Fozzy757 Lurker
    Thread Starter

    Ok that seems to work. I'll test it out later today and see if I can get a couple of hours recorded.

    Are you referring to the audio? I use a rode mic me microphone when recording. Works great.
     
  4. Fozzy757

    Fozzy757 Lurker
    Thread Starter

    Ok so I tried recording a video and the videos are recording to the extrnal storage.

    I recorded continuously and got a 30min video, a 28min video, and a 5min video. The 5-minute video could have been longer but I had to turn it off to check some text messages. The storage on the card filled up 51/64 GB. I'll probably get a larger memory card. The thing I don't get is that I have my record increments set to 1 hour and I'm only getting 30 minutes at the most. I'll send a screenshot of the Open Camera setting. Maybe I'm not doing something right.
     

    Attached Files:

  5. svim

    svim Extreme Android User

    Buried in that 'Maximum duration of video' option in the app's Settings there's an 'Unlimited' checkbox, oddly not under that '1 hour' checkbox but at the very top of the listing over the '2 seconds' checkbox. Maybe try that.
    Also, what 'class' is your current microSD card? A slower speed card might be hampering how well the video content is getting written to the card.
    https://www.sdcard.org/developers/overview/speed_class/
    (... and keep in mind that your S8 is specified to use up to a 256MB card, if you are going to be getting a new one. A lot of people state the manufacturer microSD card size limitations are arbitrary and that they have no problems using larger capacity cards, but it's your data you'll be putting at risk -- https://www.samsung.com/global/galaxy/galaxy-s8/specs/ )
     
  6. Fozzy757

    Fozzy757 Lurker
    Thread Starter

    Ok, so I went to the store and bought a Samsung 128 GB SD card with 100MB/s. I plugged it in and when I press record, it says 'Failed to save video file'. Ugh! Is there something I'm supposed to do to the memory card to make it compatible?
     
  7. chanchan05

    chanchan05 The Doctor

    on the files that were stopping, were you hitting the file size limit? How big were they?
     
  8. Fozzy757

    Fozzy757 Lurker
    Thread Starter

    Sorry bro. Not sure what you mean.
     
  9. chanchan05

    chanchan05 The Doctor

    Android uses FAT32 formatted storage, and this is also the default format for SD cards. Which means that the maximum file size it can take is 4GB (Something around 3.8 Gb). So if you're video quality is high and you're hitting that limit, there's nothing you can do. The file creation will stop at that because it's a hard limit for that technology. The only way you can go around that is you have to format your SD card to exFAT which Android accepts and can handle bigger file sizes.

    EDIT: Checked your photos, and I assume the 30min video is the one that's 4GB? So that means I probably hit the nail on the head.

    AFAIK Android uses FAT because it's the one that's cross-compatible with all computer OS (Windows/Mac/Linux, etc) If for example they used NFTS (which Windows uses), then I don't think it will work with Macs, and so on.
     
    #9 chanchan05, Aug 1, 2018
    Last edited: Aug 1, 2018
  10. svim

    svim Extreme Android User

    Try going into your Settings menu and format that new card just to make sure it's set up appropriately for your phone. Then go back into Open Camera's gear icon to reset the new card as the default save location (perhaps when you removed the old card it just reset the default back to internal storage).
     

Samsung Galaxy S8 Forum

The Samsung Galaxy S8 release date was April 2017. Features and Specs include a 5.8" inch screen, 12MP camera, 4GB RAM, Exynos 8895 processor, and 3000mAh battery.

April 2017
Release Date
0
Reviews
Loading...

Share This Page

Loading...