1. Are you ready for the Galaxy S20? Here is everything we know so far!

- Recovering from Virgin Mobile Animation Boot Loop -

Discussion in 'Android Devices' started by Curtis1973, Aug 22, 2012.

  1. Curtis1973

    Curtis1973 Android Expert
    Thread Starter

    If you are like me and do themeing on the elite. Then you've probably gotten stuck either at the LG logo boot screen or at the virgin mobile animation/jingle boot screen. In case of being stuck at the animation screen after ending up in a boot loop,you can successfully recover. Not tested this method from just being stuck at LG logo.


    1. Power down the device and boot into recovery by holding the volume down and power button.

    2. Connect phone to pc via usb cable.

    3. Use Jcase root method to reinstall via the tot flash root method.


    If you already have used the jcase method and have left everything installed from your original root. All you need to do is start LGNPST and pick your modified phone dll,pick the tot file,and begin the install.

    Now this isn't a full proof fail safe for those of us that like to theme and take the chance of bricking,but it is at least a way to recover from one of the two that WILL happen if you push theming to much. I'm thinking you can also recover from the LG logo boot loop also,just do not wipe data and factory reset beforehand after entering recovery. If you do it will hang you in boot loop permanently. This is untested however. The reason I think you can recover even from the LG boot loop after theming is because the last time it happened to me,I didn't think NOT to touch anything in recovery and just try the Jcase root method to restore. I wiped and tried a factory reset first instead. That could have stopped the Jcase method from working properly when I did try it.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Hashtag

    Hashtag Android Enthusiast

    Are you sure it's safe to flash with LGNPST while starting out in recovery mode? When we were testing the root at first, we did that and a phone got its NVRAM wiped and had to be sent back to the factory.
     
  3. Curtis1973

    Curtis1973 Android Expert
    Thread Starter

    I'm running right now. I updated and rooted with your method earlier today,afterwards I was copying over a theme I made and it started boot looping when I copied framework-res over,I shut down phone l,booted right into recovery and tried the jcase method without changing anything in revovery like data wipe etc. worked fine. now I was just updated to zv5 also,not zv4. that may have made the difference l.
     
  4. Curtis1973

    Curtis1973 Android Expert
    Thread Starter

    also this was not lg screen boot loop,I was on the animation/virgin mobile logo boot loop.
     
  5. Artine

    Artine Android Expert

    I just had to do this exact same thing - factory reset followed by jcase tot flash - because my Bluetooth software (system) foobar'd and my apk for the play store went right with it, and somehow managed to disable any potential connection to wifi in the process, followed by a gapps FC notice every few minutes. And the post-bluetooth stuff aforementioned happened after I tried a hand at theming myself and pushed SystemUI (modified). Restarted and got bootloop after all of that mayhem. I had a backup made with Titanium Backup though, and I booted right into recovery, factory reset, jcase flash, and now it's perfectly fine and working properly again. Got everything restored properly too. All within an hour.

    The relevant point is; I think that this may actually be a failsafe method to restoring your phone from bootloop, including if you get your hands really dirty with theming and something goes wrong.
     
  6. Curtis1973

    Curtis1973 Android Expert
    Thread Starter

    if you cant get lgnpst to recognize from recovery,reinstall the original lg elite drivers,power down phone and computer. reboot computer,start phone in recovery mode..phone should be recognized at that point. had this issue earlier and remembered i had the modified drivers still installed.
     
  7. james391

    james391 Well-Known Member

    I would like to add that this works from Lg boot screen brick/loop. You cant go into recoverymode, only download, and qspt(or what ever its called) works
     
  8. Curtis1973

    Curtis1973 Android Expert
    Thread Starter

    ive noticed that after the lg update,i cant seem to overwrite my framework-res with another. it could be that my framework im trying to use is corrupted somehow. not sure. anyone that is theming and has been since updating,can you verify if you are getting the animation boot loop or is the file copying properly?
     
  9. ktb83

    ktb83 Android Enthusiast

    I've modified the framework-res.apk since the ZV5 update. I'm always careful about first copying the modified APK to /system, then setting the proper permissions on it before moving it to /system/framework (which writes over the existing one). I reboot immediately afterward. I've never had a problem when making changes in this manner using Root Explorer.
     
    cfreeman90 and Curtis1973 like this.
  10. Curtis1973

    Curtis1973 Android Expert
    Thread Starter

    what permission settings are appropriate for the framework-res? ive just been directly copying from external sd to system\framework.
     
  11. ktb83

    ktb83 Android Enthusiast

    rw-r--r-- (644)
     
    Curtis1973 likes this.
  12. slutyman

    slutyman Android Enthusiast

    uhm can someone help i rooted my phone on zv5 and reset it and now i have no root and none of my root application open
     
  13. Curtis1973

    Curtis1973 Android Expert
    Thread Starter

    hmm. by reset do you mean you did factory reset? if so,check that factory reset didn't revert you to zv4..haven't had to use it so not sure on that. if you're still zv5,just rerun the one click method again to regain root.
     
  14. slutyman

    slutyman Android Enthusiast

    infact hagtag rooted me like i dont noe how to do that
     
  15. ktb83

    ktb83 Android Enthusiast

    Is the su binary still there in /system/xbin/ ?

    If so, what permissions are set on it?

    They should be set to rwsr-sr-x
     
  16. slutyman

    slutyman Android Enthusiast

    yes and how do i set it like that??
     
  17. ktb83

    ktb83 Android Enthusiast

    You can't set them without root access.

    You'll need to reroot with giantpune's method or Hashtag's click-version of the same method.

    Or you can flash the ZV4 .TOT file again and use jcase's method.

    I'd recommend just using giantpune's method whether the manual way or click-root way, since you'll just have to root it again if you flash ZV4 and then update to ZV5 again.
     
  18. Curtis1973

    Curtis1973 Android Expert
    Thread Starter

    yeah i agree. best just to reroot with either of those methods. and it wouldn't hurt to take a little time and learn it yourself so you are independent and can do it whenever you need. running through the manual install of zv5 root or the click method won't harm anything so it makes good practice. just remember the click root method may need to be closed out and restarted on step 1 and on step 2 you may need to manually start zdiag.exe in case it doesnt load up. atleast on xp thats how it behaves. step 3 is click and it does its thing right off.
     
  19. Can someone explain what Jcase method is ? I am stuck on a boost loop in optimus elite
     
  20. So, you are saying if you hard reset and clear phone's cache, there is no way you can fix your phone ?
     
  21. Artine

    Artine Android Expert

    @Bugatti Veyron

    Jcase method is here.

    I'm also not sure what your situation is, but if you're rooted and have installed CWM and made a nandroid backup prior to any issue, you could simply restore your nandroid backup. The method Curtis posted is now an old-school method.

    EDIT: To answer your other question, I did hard reset, and cleared my cache, and my phone is working properly. So yes, you can fix your phone even if you do these things. However, my situation was with theming. It was system-apps/framework stuff that caused the bricking to occur. If it is something else, this may not work (OE: flashing a ROM or TOT file restores the /system directory whatever it specifies, even if you had previously removed or altered it before).
     
    Bugatti Veyron likes this.
  22. Do I have to perform all the steps from 1 to 8 ? That process is for rooting your phone so I guess 1-3 is enough ? I don't feel like going through all that to obtain my MSL because thats too hard and will probably take like 3 hours...
     
  23. Artine

    Artine Android Expert

    It all takes a lot of time, that is to be expected. Again, I have no idea what situation you're faced with.

    If you are following the jcase method, which will repair the /system directory, then you have to follow the jcase method. If you're just looking to be rooted, giantpune's method has got you covered. You are required to have your MSL if you are following the jcase method, but not if you are simply rooting via giantpune's. To install CWM, you have to take care of Required steps 1-7, and 9. Then follow the installation instructions.

    For example, right now I'm reflashing my firmware back to jcase's ZV4 so that I can update to ZV5 to install CWM, myself. I had removed some system apps that were bloat, and so when I tried installing the ZV5 firmware update it completely failed.
     
    Bugatti Veyron likes this.
  24. The phone is already rooted. I tried to install a ICS theme on it and it got stuck on a boot loop. Thats too much to go through for a 100 dollar phone. I will probably just return it Anyway thanks for your help. What happens if I install this http://androidforums.com/elite-all-things-root/621574-ics-elite-theme-optimus-elite.html zip file from sd card onto the phone through that clockwork mod ? Will the phone be functional again ?
     
  25. Curtis1973

    Curtis1973 Android Expert
    Thread Starter

    i would suggest not installing that theme. it is also causing a boot loop because of some file errors. it would be best to install the harmonia rom using clockwork mod. be sure you back up your current system using clockwork before installing/flashing anything. that way you can boot into recovery and restore to previous state if you encounter any boot loops,etc.
     

LG Optimus Elite Forum

The LG Optimus Elite release date was May 2012. Features and Specs include a 3.5" inch screen, 5MP camera, 512GB RAM, Snapdragon S2 processor, and 1520mAh battery.

May 2012
Release Date
0
Reviews
Loading...

Share This Page

Loading...