1. Are you ready for the Galaxy S20? Here is everything we know so far!

Root Recovery induced reboot loop - help!

Discussion in 'Android Devices' started by ericbmn1, Feb 24, 2011.

  1. ericbmn1

    ericbmn1 Lurker
    Thread Starter

    I need help understanding why I'm stuck in reboot loop with my EVO 4G.

    I originally was trying to root the device using unrevoked3 but getting the ERROR "Backup CID is Missing" message and unable to proceed. I followed the instructions at http://androidforums.com/evo-4g-all-things-root/194918-rooting-dummies.html which talk about troubleshooting this. It talks about going into recovery mode to see if I've lost the recovery mode which I did (black screen with phone and read arrows). It says to reboot but I was unable to so I unplugged the battery.

    Since then I have been stuck in a mode where the device boots but the sdcard is not recognized and upon completion of boot up it shuts down and vibrates five times. I did a bunch of research last night on understanding what I thought I needed to do alleviate this. My thought was since I was stuck without a recovery image I need to flash new one. At this point I'm fine with not being rooted with all the trouble I've had.

    I downloaded the latest stock recovery rom (3.70.651.1) from http://androidforums.com/evo-4g-all-things-root/259446-clockwork-amon-ra-pc36img-files.html and pushed it to my sdcard under the name PC36IMG.zip (with two files .info and recovery.img). I restarted my phone via HBOOT and it sees the zip file, reads it in, goes to checking and then does nothing (back to HBOOT screen). I don't get what I'm doing wrong. I also tried getting the stock image from OTA_supersonic_3.70 + full RUU - xda-developers but I can't seem to open the firmware.zip file to try that recovery image.

    Again I just want to get back to stock ROM and recovery files now. Any help would be greatly appreciated!
     

    Advertisement

  2. Mr. Ed

    Mr. Ed Extreme Android User

    akazabam has a thread with the recovery img listed. let me find it and post back.

    you shouldn't be pulling anything out of/opening these zips..just put it on the root of the sd card as pc36img.zip and boot into fastboot. confirm when it asks you if you wish to install.

    an ruu (if I understand corerctly) is run from your computer, while the phone is connected to the computer via usb
     
  3. akazabam

    akazabam Android Expert

    You're probably almost finished with the process, to be honest. That is strange about what happens when you boot up, though. Start with this, though:

    1) Turn the phone off then turn it back on while pressing and holding volume down to get to hboot. Do you currently have S-ON or S-OFF?
    2) Assuming you have S-OFF, get Clockwork 2.6.0.1 or RA 2.3 from the link Mr. Ed posted. Follow those specific instructions in that link to flash it. The stock recovery will do you no good right, even if you just want to unroot.

    Start with that, and let's take it from there.
     
  4. ericbmn1

    ericbmn1 Lurker
    Thread Starter

    Mr. Ed, Akazabam, thanks for the help...

    I used the exact page you posted to try to download the stock ROM. I put it as is in the /sdcard directory and named correctly as SD36IMG.zip and it was giving me the problem of not going to the update question. I'll try out Clockwork or RA or tonight (hindsight I probably shouldn't have tried to root my phone just before going on vacation!). In HBOOT I still have S-ON. Would this cause problems with flashing Clockwork or RA?

    Thanks!
     
  5. akazabam

    akazabam Android Expert

    Hm, yes, that's a problem. Likely, you won't be able to flash Clockwork. You can try. Does it not boot up, and stay up at all?
     
  6. ericbmn1

    ericbmn1 Lurker
    Thread Starter

    It boots up and when finishing boot up it shuts down with 5 vibrates. I notice that the sdcard is not found at all.

    So, you are saying it's not even worth a try to try clockwork with S-ON? I'm not going to further screw this thing up am I? Of course any other ideas are appreciated. I'm a newbie to all this but learning. Unfortunately I'm learning the hard way to the point where my problems may prevent me from doing it again though!
     
  7. akazabam

    akazabam Android Expert

    You can try flashing it, but I don't think it will work since you have S-ON and it's not signed. Try this one, and see if it works. That one is signed. I'm still pretty sure it won't work, but give it a shot, anyway.
     
  8. ericbmn1

    ericbmn1 Lurker
    Thread Starter

    No luck with that one either. It just goes right back to the HBOOT menu. Shouldn't I be doing something in recovery to "fix the recovery image"? Either that or its like I lost the files necessary to flash via HBOOT. Is there other files I can verify exist on the SDCARD needed for flashing?
     
  9. akazabam

    akazabam Android Expert

    Right now, you have neither a custom recovery, nor S-OFF. Unrevoked can push the custom recovery, then use it to flash the unrevoked-forever, which is how you get S-OFF. Without that, you can't do either. You're going to have to boot up. Do you have anything on the phone you need to save? I'd say, take the sdcard out, just to be safe, boot into hboot, select the option to clear storage, put the sdcard back in, then see if you can boot up. That will wipe everything out, but hopefully you'll be able to boot up.
     
  10. ericbmn1

    ericbmn1 Lurker
    Thread Starter

    I figured it was a good chance I'd have to go with the nuclear option and clear storage. I can deal with that as long as I can back to a known "factory reset" state. I assume then I'd have to download the latest OTA update and then start from there. I still want to root so I'd then run unrevoked from there.

    I assume I want the sdcard cleared as well? I'll take inventory of my apps (I don't have a ton of paid apps) and clear off both tonight. If I can't get things working tonight I won't be able to debug until next Thursday evening (on a cruise from Sun-Thurs).

    Thanks again for your insight and help...
     
  11. akazabam

    akazabam Android Expert

    1) Clear storage will do just that - it will clear all user data, apps, and settings. It will not touch your ROM. It can't. Think about it - you have a certain amount of internal storage. Only a certain amount is partitioned for the system. When you update the system with a new OTA, you have to overwrite what was there. For the system to be able to go back to a previous OTA, it would have to keep an image of a previous OTA in storage. That would be a huge waste of space. Once you've updated to a new OTA, there is no way to go back to a previous one without rooting. Clear storage, factory reset, etc., all do the same thing, and that is to wipe data. Your OTA sw version will not changes.

    2) Right, once you clear storage, see if you can boot up, then run unrevoked.

    3) No, you shouldn't need to wipe the card. That's why I said to take it out before selecting clear storage. I *think* that wipes the card too, but I'm not positive.
     
  12. ericbmn1

    ericbmn1 Lurker
    Thread Starter

    After clearing storage it did the same thing on boot (actually didn't get through a full boot up). Doing a full startup (after pulling the plug did the same thing). I did this with the sdcard not loaded. I did try rebooting with it installed and the same thing happened.

    Do I need to do a full wipe data/factory reset from the recovery menu (power+volume-up)? +cache wipe? Would I be digging a further hole by doing this? I don't understand what exactly is deleted here. Judging by your comments then you can't get back to previous OTA's. So what's the difference between clear storage and wipe/data/factory reset. I guess I'm asking if I should go ahead and try this as well.
     
  13. akazabam

    akazabam Android Expert

    Theoretically, it's basically the same thing. I thought you weren't able to get to recovery...
     
  14. ericbmn1

    ericbmn1 Lurker
    Thread Starter

    When I select recovery from HBOOT I get the phone + ! page. From there I can do a Power+Volume-UP to get the Android System Recovery menu. I did the data wipe/factory reset and selected the one line in the list that said yes. Upon completing that I selected reboot and it didn't even get to the flash screen before shutting down with 5 vibrates. Subsequent hard boots do the same as before (get into startup before rebooting).

    I'm running out of ideas here now. Unless I hear about a magic elexir to try out in the next few days (I won't be able to respond back now until Thursday probably) then I'll probably have to try to return it as a warranty issue. It's still goit S-ON so I'm not sure how much they'd be able to tell that'd I was screwing around with the phone. Just hate probably dealing with a refurb phone though.

    I just don't get how things could get in this f*'ed up state from where I was. Obviously the recovery image was messed up but I should have been able to flash a new one.

    Thanks again for your help.
     
  15. akazabam

    akazabam Android Expert

    It sounds like there is some corruption in the system that cannot be cleared up by a factory reset. It happens from time to time. What is your hboot version? I will give you one more file to try. It will completely wipe out everything, but you've already tried clearing storage, so I suppose it doesn't much matter now.
     
  16. ericbmn1

    ericbmn1 Lurker
    Thread Starter

    I got a replacement swap done at the local sprint store. It's obviously a refurb but I got a new battery out of the deal (as it wasn't charging now it seemed). Not crazy of course on the refurb but at least it was a 0-cost change out. Not sure what exactly corrupted things...
     
  17. sprocketlife5

    sprocketlife5 Lurker

    i am stuck identical to this but flashing the king runny rom for evo 4g. was currently sinister. but all is wiped now cannot mount sd and stuck on boot animation of android, flashing slowly. cannot mount usb either
     
  18. mikem0269

    mikem0269 Android Expert

    Not sure wich rom u flashed I could not find it but if this is a 3.5 rom i have read that 1st boot can take a long time. If you can post the link where you got it i may beable to help a little more.
     
  19. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    welcome to the forums!!!!!!!!!!!!!!!!!!
    like mikey said some roms can take a bit longer then normal to boot up on first boot. especially some of the sense 3.0 and sense 3.5 roms.

    can you get to recovery? how long are you waiting? what recovery do you have? what do you normally wipe?
     
    Rxpert83 likes this.
Loading...
Tags:

Share This Page

Loading...