1. Are you ready for the Galaxy S20? Here is everything we know so far!

Red circle after HBOOT flash... can't get past

Discussion in 'Android Devices' started by dragginthru, Dec 29, 2012.

  1. dragginthru

    dragginthru Lurker
    Thread Starter

    OK I think I have buggered my Desire in my ongoing quest for more system memory :(

    I've over the last few months had it rooted and running Mildwild quite happily but still having to juggle app installs so I wanted to put on the CM7 HBOOT that takes the system partition to a smaller size and would have freed up another 100 meg for me.

    I managed to get S-OFF no problems using Revolutionary.

    Then I used FastBoot Commander to flash the HBOOT to the image I downloaded from AlphaRev (bravo_alphaspl-cm7r2.img). This gave me a flash successful message.

    On reboot I can only get as far as the red circle - I've left it running for 20 mins or so and no change. I'm guessing this means it is broken.

    I can get in to recovery - tried to reinstall Mildwild from zip - still only get to red circle.

    Any ideas? All help appreciated :)
     


  2. shauny13

    shauny13 Android Expert

    can you get to fastboot (back and power)? or use fastboot commander again to

    fastboot erase cache

    fastboot reboot bootloader
     
    dragginthru likes this.
  3. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    Changing hboot rearranges the internal storage, so your existing ROM is toast. If you took a nandroid before doing this then just restore that and you'll be fine.

    Otherwise wipe everything - data, cache and system - then flash the ROM.

    There are full instructions for flashing hboot on alpharev.nl, which include the steps I suspect you missed.

    But don't panic - as long as the hboot works it's recoverable.
     
    dragginthru likes this.
  4. dragginthru

    dragginthru Lurker
    Thread Starter

    Shauny13 and Hadron - thanks a lot.

    Based on the info you gave me - I was able to fix this in literally one click, you legends!

    For the benefit of other users - I did:
    1. Power off
    2. Hold down volume and press power to reboot into recovery
    3. Select clear data
    4. Phone rebooted and now working - with the desired increased storage!

    Now the big problem is I bought a replacement phone which has it's own merits, now I have to decide between lol
     
    Tyseyh, shauny13 and Hadron like this.
  5. xct

    xct Lurker

    This thread is well-timed, I'm having similar trouble. Again, I was trying to change my partition sizes, but I used Firerat's Custom MTD Partitions. I followed the instructions, and used the version that's supposed to be bravo-compatible. I backed up, wiped everything, flashed the recovery, restored and flashed the boot, but when I rebooted again it got stuck on the CM7 splash screen. The animation kept restarting every few seconds but never finished booting up. So I went back to recovery and tried to restore the backup I'd just made, but on rebooting again it just got stuck on the carrier splash screen, it didn't even get as far as the CM7 splash screen. I've tried wiping all data both from HBOOT and from recovery before restoring, but it isn't helping.

    That's where I am now. I still have HBOOT and can get into recovery (I'm using ClockworkMod Recovery v2.5.0.7), but I'm not sure what to do next. At this point I'd be satisfied just to get any ROM running so I can use my phone again! Cheers.
     
  6. shauny13

    shauny13 Android Expert

    i am not familiar with firerat's custom hboots, but if you just want a working rom dGB is only 60 or 65 mb (depending on which one you choose). It is the smallest desire rom so should fit your hboot. I'm guessing your system partition is 75mb if designed for cm7?
    As i say been a while since i had my desire.
     
  7. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    Hi xct, and welcome to AF :)

    Simplest is probably to undo the custom mtd, then flash a ROM. Then you can have another go once the phone is working.

    To undo the custom mtd I believe the trick is to reflash the recovery with one that hasn't been patched. See the section on custom mtd in http://androidforums.com/showthread.php?p=1891277.

    If you have a GSM phone then a custom hboot is a simpler way of achieving the same result as the custom mtd (see section in that same faq). If you have CDMA that's not an option, but maybe the faq will help you spot what went wrong.

    Good luck & let us know how you get on, or if you still have problems.
     
    xct likes this.
  8. xct

    xct Lurker

    Yep, that did it. My mistake was that I was trying to flash the recovery from within the recovery itself (not on my home computer, so no drivers, adb etc) which didn't work. But after getting all the right software onto this painfully slow old netbook I could use fastboot to get the job done. I did the AlphaRev custom HBOOT while I was in there too, so now I've got my extra memory :).

    I managed to get it to boot into a fresh install of CM7, but I can't get the recovery to read the original nandroid backup I made. I tried making another backup to make sure I had the files in the right place, and it reads the new one just fine, it just doesn't recognise the old one. The recovery version is the same.

    Still, data or no, I have a working phone again so thank you very much!
     
  9. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    What's the error with the old nandroid? Does it complain about the md5 checksum, or does it fail to work after restoring?

    If it's the checksum then you may be able to use the advanced restore option to restore just the data. Titanium Backup Pro claims it can extract stuff from a nandroid, but I've not tried it so don't know what recoveries it works with or how well it works. Might be worth a go though (Ti Pro is worth the money anyway imo).
     
  10. xct

    xct Lurker

    Not even that, it just doesn't show up on the list of backups to restore, despite being right there in the backup directory alongside the new one (which it does see). I'm guessing there's some record of which backups were taken when, and it's either located somewhere else I don't know about or it was overwritten when I reflashed the recovery.

    To be honest, all my really important data was on the SD card anyway, I just wanted to avoid having to reinstall and reconfigure all my apps. In the end I just bit the bullet and reinstalled everything manually, and now everything is back as it was (minus a bit of clutter). So all's well that ends well, eh :).
     
  11. Tyseyh

    Tyseyh Android Expert

    +1 about TI being worth the money.

    It really is.
     
  12. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    Actually recovery doesn't keep any record - I can move backups off to my computer, delete them, put them back on the card and it all works. So I'm not sure why it wasn't working.

    Still, glad it's working.
     

HTC Desire Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...

Share This Page

Loading...