1. Download our Official Android App: Forums for Android!

Root Red Light + Black Screen after root

Discussion in 'Android Devices' started by WEBEL, Dec 31, 2013.

  1. WEBEL

    WEBEL Lurker
    Thread Starter
    Rank:
    None
    Points:
    25
    Posts:
    9
    Joined:
    Dec 31, 2013

    Dec 31, 2013
    9
    0
    25
    New guy here folks!
    I purchased a ZTE AWE today and decided to root it for the overclocked kernel.

    I followed ALL instructions from this video:
    Tutorial: ZTE Awe (N800) Root - Recovery - Overclock - YouTube

    Only thing I did different, was instead of using a SD card, I remotely loaded the ZIP files from my computer to the phone using the command prompt.

    Always said "success" after each installation but when rebooting the device at the very end of the process, I get the android logo and right after that, when you expect the virgin mobile logo, I get a black screen and a red light.

    Any idea whats going wrong?
     

    Advertisement

  2. cooldudezach

    cooldudezach Android Enthusiast
    Rank:
    None
    Points:
    93
    Posts:
    556
    Joined:
    Jun 27, 2011

    Jun 27, 2011
    556
    195
    93
    Male
    Apparently our implementation of 'adb sideload' doesn't properly flash the files all the time - for some unknown reason. If you place all the same files on your SD card, they should work with no problems.

    The whole adb sideloading issue is just now being realized, as when I was doing the initial testing, I had already done the custom stuff, so it only appeared to work. It was a bit of a facepalm moment for me. :p
     
  3. WEBEL

    WEBEL Lurker
    Thread Starter
    Rank:
    None
    Points:
    25
    Posts:
    9
    Joined:
    Dec 31, 2013

    Dec 31, 2013
    9
    0
    25
    first of all...thanks for the reply mate!


    ohh darn it....i am in the middle of nowere with no SD card - im screwed
    if i try it over and over again, will it maybe work?
    can I install it from the phone storage directly?
    or is there any other way besides SD card?

    lucky me the recovery image installed properly
     
  4. cooldudezach

    cooldudezach Android Enthusiast
    Rank:
    None
    Points:
    93
    Posts:
    556
    Joined:
    Jun 27, 2011

    Jun 27, 2011
    556
    195
    93
    Male
    You can just push them onto the internal sdcard.

    If they didn't work the first time, it won't work again. Some of the updater-script commands behave funny when the zip is sideloaded.
     
  5. WEBEL

    WEBEL Lurker
    Thread Starter
    Rank:
    None
    Points:
    25
    Posts:
    9
    Joined:
    Dec 31, 2013

    Dec 31, 2013
    9
    0
    25
    how do I strat the ZIP frpom the internal storage?
    CWM recovery doesnt have a option as fasr as I know to load ZIP from internal storage
     
  6. WEBEL

    WEBEL Lurker
    Thread Starter
    Rank:
    None
    Points:
    25
    Posts:
    9
    Joined:
    Dec 31, 2013

    Dec 31, 2013
    9
    0
    25
    OK I got my hands on a card.
    I did the whole process again - and now instead of a black screen and red light I get a infinite boot cycle......this is getting annoying....did everything EXACTLY as told :(
     
  7. cooldudezach

    cooldudezach Android Enthusiast
    Rank:
    None
    Points:
    93
    Posts:
    556
    Joined:
    Jun 27, 2011

    Jun 27, 2011
    556
    195
    93
    Male
    What exactly are you trying to flash? I'll be able to help you better if I know what you're flashing. I'm really sorry for the troubles you are having.

    Edit: Oh yeah, I forgot we haven't published a build with working internal sd support. My bad ^-^;
     
  8. WEBEL

    WEBEL Lurker
    Thread Starter
    Rank:
    None
    Points:
    25
    Posts:
    9
    Joined:
    Dec 31, 2013

    Dec 31, 2013
    9
    0
    25
    http://androidforums.com/awe-all-th...root-kernel-recovery-how-install-zte-awe.html

    Exactly that haha ^^

    If I "stream" the zips from the computer via USB, I get a stuck black boot screen. If I use the SD card, I get a infinite boot loop.
    A reply also mentioned the same problem.
     
  9. cooldudezach

    cooldudezach Android Enthusiast
    Rank:
    None
    Points:
    93
    Posts:
    556
    Joined:
    Jun 27, 2011

    Jun 27, 2011
    556
    195
    93
    Male
    There is probably an issue with the kernel.zip you have. Have you tried re downloading it? I can get a fresh OC kernel out tomorrow, did you make a backup before flashing the zips? If so, do an advanced restore and restore the boot partition.
     
  10. WEBEL

    WEBEL Lurker
    Thread Starter
    Rank:
    None
    Points:
    25
    Posts:
    9
    Joined:
    Dec 31, 2013

    Dec 31, 2013
    9
    0
    25
    yep - tried re downloading...dont know why it does not work for me
     
  11. cooldudezach

    cooldudezach Android Enthusiast
    Rank:
    None
    Points:
    93
    Posts:
    556
    Joined:
    Jun 27, 2011

    Jun 27, 2011
    556
    195
    93
    Male
    There could be an issue with the version of the kernel. We've had so many while developing it, it got a little out of hand keeping track of them. Try restoring your backed up boot partition in the advanced restore.
     
  12. WEBEL

    WEBEL Lurker
    Thread Starter
    Rank:
    None
    Points:
    25
    Posts:
    9
    Joined:
    Dec 31, 2013

    Dec 31, 2013
    9
    0
    25
    can you post a link of one that you know will work for a fact?
     
  13. kiijamkcalb

    kiijamkcalb Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jan 1, 2014

    Jan 1, 2014
    1
    0
    5
    I've also had the boot loop/red light issue after flashing the oc kernel. Glad someone already got the ball rolling on a fix! :smokingsomb:
     
  14. WEBEL

    WEBEL Lurker
    Thread Starter
    Rank:
    None
    Points:
    25
    Posts:
    9
    Joined:
    Dec 31, 2013

    Dec 31, 2013
    9
    0
    25
    I feel you mate!
    The 1.94GHz have me sitting here mouth watering!!! @_@
    too bad I only know PHP and HTML5 otherwise I would be sitting here coding non stop! :D
     
  15. cooldudezach

    cooldudezach Android Enthusiast
    Rank:
    None
    Points:
    93
    Posts:
    556
    Joined:
    Jun 27, 2011

    Jun 27, 2011
    556
    195
    93
    Male
    I'm working on it. I'm rebuilding the kernel now, but I had to fix a bug I accidentally introduced. The zip you're downloading is probably bad.
     
  16. dragonhart6505

    dragonhart6505 Android Expert
    Rank:
    None
    Points:
    173
    Posts:
    1,101
    Joined:
    Feb 4, 2012

    Feb 4, 2012
    1,101
    346
    173
    Its not necessarily the zip, its the compatibility with each different phone. Theyre all reacting differently. A bunch of people have had the exact same issues and we are working on it. I actually have 9 different versions of the kernel on my pc and actually use 2 of them for different purposes. When we get it fixed, youll know firsthand ^_^
    Btw...sup cdz! I should have my webs again today so I'll be back in irc. Ttyl!
     
  17. cooldudezach

    cooldudezach Android Enthusiast
    Rank:
    None
    Points:
    93
    Posts:
    556
    Joined:
    Jun 27, 2011

    Jun 27, 2011
    556
    195
    93
    Male
    This kernel zip should work fine. as always make sure you have a backup before flashing, and do not sideload it. Place it on your SD card and install from there.
    Dev-Host - cdz-kernel-latest.zip - The Ultimate Free File Hosting / File Sharing Service

    I have not had a chance to test yet, but will do so when I get back from work.

    edit: sup dragon! I wondered when you were coming back. We have the source source set up for the OC kernel. more info in IRC.
     
Tags:

Share This Page

Loading...