Help Reinstall Android without an OS on the HTC Magic?


I got my hands on a brand new HTC Magic, the only problem being no OS installed. The phone turns on, but won't boot without Android.

Any ideas how to solve this problem? I'm new to Android, so please explain it like I'm 5 : )


Hello mihkels and welcome to Android Forums. You lost me when you said new Magic and no OS. Could you elaborate?


Thread starter
I bought an unused (quite rare for such an old phone) HTC Magic, but it has no OS installed on it. Think formatted hard drive in a PC - it powers on without a problem but will not boot.

I found this quote on another forum:
Do you have access into Hboot mode (volDown+powerkey) ,Fastboot(back key+powerkey) or Recovery (home+powerkey)

I'll try this and get back to you.
Hi everyone,

I've recently been given an HTC mytouch 3g phone, which a friend brought back from her stay in the US (I believe it's known as the HTC magic in Europe). Anyway, the problem is that the phone is basically a blank slate with no Androis system on it and I can't work out how to install one.

I'll give a few more details. It was region and sim unlocked and being used here in Hungary but wasn't functioning correctly so I though maybe a new rom might sort it out instead of throwing it away. I rooted it (using super one click), checked that through a root checking app and then installed rom manager. Through rom manager, I flashed the correct clockworkmod recovery image and then tried to make a back up. Here is where things started to go wrong.... After creating the backup, the phone rebooted but went into a boot loop where it would get as far as the green splash screen and then shut down and start again. I pulled the battery and restarted it and it booted up OK. I figured it was maybe a glitch and everything would be OK (bad move).

Next, I tried to use the HTC developers website to unlock the bootloader about a hundred times but every time I got to the fastboot oem get_identifier_token stage it would tell me that the command was unknown. I scoured teh forums and tried every piece of advice but nothing worked... So, I figured that I may not need that anyway since the general web opinion seemed to be that rooting is enough for flashing a custom rom.

So, I downloaded a bunch of roms e.g. cyanogen, ginger yoshi, bananabread which were stated as for the 32B version of my phone (the one I have). I followed the installation instructions and used the recovery mode to install one but none of them will boot correctly. They just get as far as the green splash screen and then either hang (I left them for over an hour just to be sure), or go into a boot loop. The best result I got was with bananabread which (as long as you don't install the final kernal zip) will boot to the bananabread splash screen but then stay there and not proceed further.

Unfortunately, it also turns out at this stage that my backup was no good and so I can't go back to the original set up....

Sorry for the length of the post but I really wanted to try and provide as much detail as possible in order that someone may be kind enough to help me try and save this phone. I figure it's not bricked as I have full access to hboot and recovery mode so the system still works, I just can't install any version of android!

Thanks in advance to anyone that even reads this far! :eek:)

As I was able to access fastboot, I went back and retried all of the official RUUs again. This time one of them worked! As a result, I am now back at stage one again with an unrooted android system. I guess I'll just have to try the whole process again and hope for the best. Does anyone know where the correct drivers are for my phone, I'm using win7 64 bit. I wonder if that might be why I can't get things like the bootloader unlocker to work.

By the way, the RUUs came from the xda developers forum marked official RUUs.