1. Download our Official Android App: Forums for Android!

Support Remove Google Search History

Discussion in 'Android Devices' started by Pavilion, Oct 25, 2011.

  1. Pavilion

    Pavilion Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    95
    Joined:
    Jul 8, 2010

    Jul 8, 2010
    95
    2
    16
    How to remove all Google search history?

    Right now, I can only remove three at a time...
    [​IMG]

    During confirmation, it asks me to "Go to Preferences for more options."
    There is NOT a "Preferences" anywhere... I tried browser's "Settings;" cleared all cache, history, cookies data, data, and location access. But it isn't that. Browser setting has nothing to do with the search history...
    [​IMG]

    And it isn't in my Google account either. To make thing more confusing, I actually have paused the web history more than a year ago; so, it actually has nothing in the web history under my account...
    [​IMG]

    Folks, any ideas? Or I am stuck with 3 at a time?

    p.s. If it helps, this is a Droid X at v2.3.340.MB810...
     

    Advertisement

  2. Pavilion

    Pavilion Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    95
    Joined:
    Jul 8, 2010

    Jul 8, 2010
    95
    2
    16
    No one know? Or no one have the problem?
     
  3. scary alien

    scary alien not really so scary
    Moderator
    Rank:
     #9
    Points:
    2,138
    Posts:
    22,218
    Joined:
    Mar 5, 2010

    Mar 5, 2010
    22,218
    23,355
    2,138
    Male
    space alien ;)
    Indy
    Pavilion,

    How about menu -> More -> Settings -> Clear history (Clear the browser navigation history)?

    I didn't want to try that on my phone since I don't want to clear the history...but it sounds like the navigation (search?) history is what you want?

    Hope that helps.

    Cheers!
     
  4. asapling

    asapling Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Apr 17, 2012

    Apr 17, 2012
    1
    0
    5
    I have the same problem. I don't want to clear my history, I'd like Google or the Browser to respect my settings and NOT save it at all. I'm having trouble pinpointing exactly who to blame: different browsers behave the same which leads me to blame Google, yet they do not share their query history, which seems like it's the browser doing the saving and not the site. No option to clear data in the browser's settings does anything, you are forced to clear them 3 at a time with the useless advice to Go To Preferences. The browser does not save info from other forms, as per my request. Google.com is unique in its tenacity.

    Droid Bionic using default browser and Dolpin HD.
     
  5. kmfdm515

    kmfdm515 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Aug 9, 2011

    Aug 9, 2011
    4
    0
    5
    exact same issue here. All Web history is off, and there seems to be NO way to stop google (when accessed from the stock browser) from displaying your previous searches in magenta when you click on the search bar.

    You can clear that history, but not prevent it from being logged in the first place? Surely I am missing something here?!?
     
  6. ronentemp

    ronentemp Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Nov 9, 2013

    Nov 9, 2013
    1
    0
    5
    Did anyone find a solution to thin annoying problem?
    I'm think this particular type of search history is saved by Google in a cookie on the device and not on Google website because I was able to clear it by clearing the cookies.
    But since they keep referring to a preferences option that doesn't exist, maybe there is a setting hiding somewhere...
     
  7. Raargh0

    Raargh0 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Feb 17, 2015

    Feb 17, 2015
    2
    0
    5
    Male
    Yeah, it's cookies. Local to the particular browser, such as Mercury, Chrome, etc. I think the "preferences " thing is just Google arrogantly referring to the press in Chrome.
     
  8. ihadtosignupforthis1post

    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Dec 2, 2015

    Dec 2, 2015
    1
    0
    5
    Male
    Problem Solved! I finally figured out where the "preferences" are. It's not called preferences at all. It's called settings. I have an iPhone but this isn't an OS thing...it's a Google thing. it will work for any browser as long as you can access Google.com.
    Do as follows
    open google.com>scroll to bottom of page>click settings>click search settings> click clear> click do not save searches> change any other settings> make sure you click save at the bottom. Done. double check this in incognito.
     

    Attached Files:

Share This Page

Loading...