1. Are you ready for the Galaxy S20? Here is everything we know so far!

Remove tasker - Tasker

Discussion in 'Android Apps & Games' started by ynotamil, Jan 27, 2017.

  1. ynotamil

    ynotamil Newbie
    Thread Starter

    I am not using tasker anymore and I can't remove it. If I try to do it, Android tells me me that Tasker is an Administrator .
    As such I go to SETTINGS, DEVICE ADMINISTRATOR, DEVICE ADMINISTRATION and there I see that TASKER is tricked.
    I cannot remove the thick.
    If I long press or keep tapping TASKER in DEVICES ADMINTRATION this message displays:
    Unfortunately Settings has Stopped.
    Anyone knows how to get around this problem?
    Anyone with a way to disable Tracker under the conditions above described?


    RickJohn57 likes this.

    1. Download the Forums for Android™ app!


  2. Unforgiven

    Unforgiven ...eschew obfuscation...

    It may be that tasker is trying to do something when you are in that menu. Can you boot into safe mode and remove administrator priviledges from there. That way you can be sure tasker isn't running.
    Dannydet likes this.
  3. Tasker is running in the background. To uninstall Tasker ...
    • Choose Uninstall.
    • When dialog appears click on Manage Device Administrators.
    • Uncheck Tasker.
    • Exit.
    • Power off/power on.
    • Uninstall Tasker (it doesn't give the Administration dialog)
    ... Thom
    #3 Thom, Jan 27, 2017
    Last edited: Jan 27, 2017
  4. ynotamil

    ynotamil Newbie
    Thread Starter

    Thanks for the reply.
    DEVICE ADMINISTRATION, then I click on
    Next I get a screen with 6 Apps.
    The 1st one is TASKER with a tick-box ticked with a green tick.
    I touch the green tick, the screen freezes for 3 or 4 seconds & I get the message UNFORTUNATELY, Settings has stopped.
    This happens in SAFE MODE as well.
    How can an App crash a system utility (SETTINGS)?
    Any other ideas?
    Appreciate your input.

  5. Unforgiven

    Unforgiven ...eschew obfuscation...

    I know @Thom uses tasker far more than I do, so I would give his instructions a try. Also you mentioned having 6 apps listed in Device Administrators. Can you list those out in case there is a known conflict or problem maker that may be unrelated to Tasker.
    Thom likes this.
  6. I actually did the uninstall on a test device and documented the procedure for this question.

    Since Tasker was not written by my ex-wife it is therefore not perfect. Tasker has a lot of tendrils into the system.

    Give it a try and let me know how it worked out for you.

    ... Thom
    Unforgiven likes this.
  7. ynotamil

    ynotamil Newbie
    Thread Starter

    Thank you for your reply.
    scroll down to TASKER, click it.
    I get a screen
    (TASKER version 4.9u 4)
    with 2 buttons:
    both are not active. I can click and click, no action.

    Any idea on how to overcome this?

  8. Since I don't know where you are starting from ...
    Power off/power on.
    Go to the app drawer.

    Drag the Tasker icon to Uninstall.
    When dialog appears click OK
    When dialog appears click on Manage Device Administrators.
    Uncheck Tasker.
    When dialog appears click Deactivate.
    Power off/power on.
    Go to the app drawer.

    Drag the Tasker icon to Uninstall.
    When dialog appears click OK(it doesn't give the Administration dialog).
    (The reboot is needed to totally remove it.)

    ... Thom
    #8 Thom, Jan 27, 2017
    Last edited: Jan 27, 2017
  9. ynotamil

    ynotamil Newbie
    Thread Starter

    Did all that before.
    What happens is that I do not get the UNINSTALL button. I get the same options of I try that with CAMERA, or INTERNET, some system apps that you
    can't uninstall nor DISABLE.
    The options that I get are:
    If I do that to GOOGLE, GMAIL & others, I get a 4th option that is DISABLE; this 4th option is not available for TASKER.
    My cell phone is Samsung S5
    model number = SM-G900F,
    with Android 6.0.1
    As I mentioned before TASKER is version 4.9u 4


  10. I am on a Droid Turbo 2 and not a Samsung S5 and have a different interface.
    I assume your result is because Tasker is a Device Administrator.

    Go to Settings/Security and in Device Administrators uncheck Tasker. Answer and dialogs. (I don't know what they will be.)
    Power off/power on.
    Go to the Tasker icon and try the uninstall.

    ... Thom
  11. ynotamil

    ynotamil Newbie
    Thread Starter

    Hello Thom,
    Yes TASKER is set as Device Manager and I cannot reset that. If I try to remove the thick, the SETTINGS crashes. See my 1st post.
  12. Can you remove Device Administrator authorization for any of the apps that are listed? If not it would appear to be a device problem and not a Tasker problem.

    ... Thom
  13. ynotamil

    ynotamil Newbie
    Thread Starter

    those are the apps listed in my DEVICE ADMINISTRATORS:
    Android Device Manager,
    AVG Anti Virus,
    Macro Droid Dev. Manager.
    If I set any one of them or all, I can reset the status of each of all of them any time without problems.
    The only exception is with TASKER. As I said before, if I press /long press on TASKER the message: Unfortunately, Settings has stopped, as I described on my original post.
    Unforgiven likes this.
  14. ynotamil

    ynotamil Newbie
    Thread Starter

    Yes I can do that as described on my previous post to UNFORGIVEN.
    Because of that message UNFORTUNATELY SETTINGS HAS STOPPED, I agree with you. Seams to be a device /Android Problem.
    But how to correct that?
  15. It took some work to come up to speed on your totally different system interface.

    I bumped your problem to the Tasker author and will get back to you with what is concluded.

    It would also help if I moved thread to the Tasker sub-forum. There might be some S5 users there who could help.

    ... Thom
    Unforgiven likes this.
  16. This thread was moved to this sub-forum that is dedicated to Tasker discussions.

    Perhaps another S5 Tasker user will have some insight ... no new information from the developer ... yet.

    ... Thom
    ynotamil likes this.
  17. ynotamil

    ynotamil Newbie
    Thread Starter

    Thank you for your help.
    Let's wait for good news.


  18. I communicated with Tasker's author ...
    • There is a problem with Settings on your phone.
    • It is assumed that someone disabled the permission to Draw over other apps on your phone and that is inducing the failure.
    • It might take a little searching to find this permission.
    The following works for me on Droid Turbo running 6.0.1 ...
    • Go to Settings/Apps and select the Cog in the upper right
    • In Advanced select Draw over other apps
    • Scroll down to Tasker
    • Enable the permission
    • Power off/power on
    • Uninstall Tasker
    ... Thom
    RickJohn57 and Unforgiven like this.
  19. Did this solve the problem? Did you uninstall?

    ... Thom
  20. ynotamil

    ynotamil Newbie
    Thread Starter

    Hello Thom,
    No, that doesn't work.
    I searched the net & the problem is definitely with SETTINGS; not with TASKER & it is an old problem that Android still carries from previous releases. I think it was reported on release 3 for the first time;
    still not fixed. I tried some fixes / suggestions that I found, but none worked so far.
    Looks to me that the only solution is to flash/reset the phone.
    Thanks for the help.
  21. Yes it is apparently a system problem and not a Tasker problem. Apparently Draw over other apps is not enabled for the app you are trying to uninstall (Tasker).

    So when you followed the steps you found that Tasker already had Draw over other apps already enabled?

    (I want to get your report back to the Tasker author who recommended this correction.)

    ... Thom
    #21 Thom, Feb 6, 2017
    Last edited: Feb 6, 2017
    RickJohn57 likes this.
  22. RickJohn57

    RickJohn57 Lurker

    Thank you Thom.
    That advice to ENABLE the app to display "On Top" allowed me to disable Tasker's ability to Administer Device.
    THEN I was able to uninstall Tasker.

    My phone is infested with malware that randomly interrupts everything to bring up a Chrome ad window and Tasker was suspect when I couldn't uninstall it (like a sick malware would want).
    But alas, Tasker is okay since the malware keeps popping up windows once in a while. (very bad when driving and navigating w/map).
  23. Trom

    Trom Android Enthusiast

    I know I'm popping in late..

    I had a similar issue with Tasker once, wherein I was doing some testing which involved forwarding text messages. I chose my daughter as the test forward. After finishing with playtime, I deleted the profile, but the task remained, and each text I received was going to my daughter as well. I had to recreate the profile, EXACTLY as it had been, and then delete the task and profile. Try that angle.


Tasker Forum


⚙No repetitive tasks for you, let your Android device handle it!⚙
Total Automation, From Settings to SMS. Here are only some
of the things you could do with Tasker. Its real power is the flexibility to combine contexts and tasks however you wish: https://tasker.joaoapps.com/exampleuses.htmlAutomations
Make your phone a true smart
phone! Why remember to change the volume every day when you leave home when your phone can do it for you? Automate stuff based on the app you're in
, the time of day
, your location
, your Wi-Fi network
, Received SMS or Calls
, the currently playing song
and many other (130+) states and events! Check out how easy it is to create an automation: https://www.youtube.com/watch?v=s6EAbLW5WSkActions
350+ actions allow you to truly customize your phone like never before! Send SMS, create notifications, change almost any system setting like Wifi Tether, Dark Mode, Always On Display, change any volume, control Do Not Disturb, open apps, file manipulation, control music playback, get your location... you get the idea. If you can think of it, Tasker can probably do it for you! Note: root is NOT (I repeat NOT) required for majority of the functions.
However, a few of the actions (like the Airplane Mode action and the Mobile Data action on some devices) require root. Regarding those few actions that do require root, this is because of Android security policies that developers cannot work around. ☑ Other Triggers
Manually trigger your actions via launcher shortcuts, quick setting tiles, widgets, long-pressing volume buttons, media buttons (like the ones on your BT headsets or headphones), Bixby button, Navigation Bar, Notificaitons and more! ☑ Join - Remote Tasker
Adding Join (https://play.google.com/store/apps/details?id=com.joaomgcd.join) to the mix will even allow you to trigger tasks from another Android device or PC! ☑ Scenes
Design your own UI and use it to display any info you want or trigger any task! ☑ App Creation
Create your own standalone apps to share or sell with the Tasker App Factory (https://play.google.com/store/apps/details?id=net.dinglisch.android.appfactory)! ☑ Developer Friendly
A lot of 3rd party developers already allow you to perform actions in their apps and listen to their events/states through Tasker! Check out a list of plugins https://tasker.joaoapps.com/pluginlist.html. You can also call most of the Web APIs from Tasker with the powerful HTTP Auth and HTTP Request actions! Check out an example https://youtu.be/yAt2D1XmgUI. ☑ 7 day trial - one time payment to unlock
Get it here: https://tasker.joaoapps.com/download.htmlUseful Links
Starter Guides: https://tasker.joaoapps.com/guides.html Pre-made projects: https://forum.joaoapps.com/index.php?resources/ Official Support Forumhttps://groups.google.com/forum/#!forum/tasker Community full of people willing to help: https://www.reddit.com/r/tasker/ It's not possible to fix problems reported via Play Store Comments so please use the "Report Issue To Developer" option in the app > Menu to do so. Note
: Tasker uses the BIND_DEVICE_ADMIN permission in order to provide the System Lock functionality

February 15, 2020
Last Updated

Share This Page